К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Вышла ЗиК 7.70.371

0 - 22.01.2019 - 17:50
зачастили :)


41 - 07.02.2019 - 19:25
Цитата:
Сообщение от oops! Посмотреть сообщение
продукта с названием "Комплексная конфигурация" в прайс-листе 1С никогда не было - такого артикула не существует и не существовало, потому и прекратить его поддержку они не могут.
Как отдельной позиции в прайсе может и не существовало, наверно потому что такая конфигурация шла в составе комплексной поставки.
Хотя... я бы не была столь уверена в таком утверждении, что никогда в прайсе не было, ибо помнится DeiMos когда то говорил, что вроде бы когда то была.. в начале 2000-х.. но не буду утверждать, прайсов за те времена у меня нет :))

Но вот как программный продукт как отдельная конфигурация - и существовала и пока еще существует.
Правда, надо сказать, что полное название звучит как
Комплексная конфигурация "Бухгалтерия + Торговля + Склад + Зарплата + Кадры"
Но мы просто привыкли сокращать название..
http://1c.ru/rus/products/1c/predpr/complex77.htm#01


Более того - вот только на днях было обновление. Для продукта, которого никогда не было :)
42 - 07.02.2019 - 20:06
Цитата:
Сообщение от oops! Посмотреть сообщение
продукта с названием "Комплексная конфигурация" в прайс-листе 1С никогда не было - такого артикула не существует и не существовало
угу.
Вот как хочешь, a к DeiMos'у у меня доверие.
А к тебе - увы, нет.
потому как:
http://1c.ru/news/info.jsp?id=366

43 - 12.02.2019 - 13:31
Цитата:
Сообщение от Блондинка в шок Посмотреть сообщение
потому как:
Да-да. Подтверждаю, ибо видел коробку. В далёком 2001 году.
44 - 20.02.2019 - 16:51
(7) Так, добавим ошибок в копилку. Помимо того, что
ВремТаблицаСоСтажем.ПолучитьСтрокуПоНомеру(НомерСт роки);
надо поставить в начало цикла, так ещё и строчку
ВписыватьПараметр = 1;
перенести туда же - внутрь цикла в самое начало, а не перед ним.
Если сотрудник-вредник уйдёт в начале года в отпуск за свой счёт, а потом в середине - в оплачиваемый отпуск, то оплачиваемый отпуск не попадёт в СЗВ-Стаж. Потому что последовательно перебирая строки стажа и наткнувшись на неоплачиваемый отпуск программа занулит ВписыватьПараметр. А когда дойдёт до нормального отпуска - будет считать, что раз ВписыватьПараметр=0, отпуск в СЗВ-Стаж отражать не надо.

Просто удивительно, как добавляя по 10 строчек на релиз, 1С умудряется плодить ошибки.
45 - 24.02.2019 - 14:31
Патент. Авансовый платеж по НДФЛ. Уведомление введено. При выгрузке ищет среди вычетов и, соответственно, вылетает с руганью...
46 - 25.02.2019 - 10:02
Цитата:
Сообщение от Buhta Посмотреть сообщение
Патент. Авансовый платеж
Ясно дали понять: заканчивайте в ней работать.
47 - 01.03.2019 - 07:57
Тут озадачили, что ОплатаЛьготныхДнейРодителей должна разрывать льготный стаж работника.
СЗВ-СТАЖ не проходит проверку в ПФР, т.к. нельзя указывать сварщику одновременно льготу (Код профессии = 23200000-13786) и доп. выходные (ИТС:третий параметр = ДОПВЫХ).

Если это так, то нужно в очередной раз править ЗИК, а именно в проц. глСобратьДанныеДляСЗВ2017():
Код:
		ИначеЕсли (ВР = ВидРасчета.ОплатаЛьготныхДнейРодителей) Тогда
			СписокВРОплатаЛьготныхДнейРодителей.ДобавитьЗначение(ВР);
			СписокВРОтпускаБезСохранения.ДобавитьЗначение(ВР); //тщи < ---- добавляем исключение из льготного стажа
Или проверка ошибается? Что в законе по этому поводу?
48 - 01.03.2019 - 13:31
(47) Таких нет у меня людей, так что не скажу... Но судя по коду льготные дни родителей и так исключаются из льготного стажа. Что делает правка?
49 - 02.03.2019 - 14:17
(47) Льготные дни и так льготный стаж разрывают.
И проверка права
50 - 03.03.2019 - 15:09
Цитата:
Сообщение от Блондинка в шок Посмотреть сообщение
Цитата: Сообщение от oops! продукта с названием "Комплексная конфигурация" в прайс-листе 1С никогда не было - такого артикула не существует и не существовало угу. Вот как хочешь, a к DeiMos'у у меня доверие. А к тебе - увы, нет. потому как: http://1c.ru/news/info.jsp?id=366
посыпаю голову пеплом - комплексная поставка, содержащая полноценную ЗиК, и комплексная конфигурация, которую содержит в себе та же комплексная поставка, это несколько разные вещи, и о прекращении поддержки комплексной конфигурации ещё не было ни звука, так что есть ещё шанс обновления ЗиК за счёт обновлений комплексной конфигурации - там блок зарплаты практически полностью идентичен тому, что сделано в ЗиК.
51 - 04.03.2019 - 19:43
Нет, не полностью...
Там в справочнике сотрудники отсутствует реквизит "Основной элемент", что приводит к полному отсутствию совместительства. Соответственно учет зарплаты становится примитивным.
52 - 05.03.2019 - 05:24
48-Харлампий Дымба >А какой именно код исключает? Потому что проверял, и при просмотре строк стажа через отчет "Перс. сведения о стаже" вижу, что льгота остается для периодов ДОПВЫХ.

Правку не проверял, чисто умозрительно. Может ничего и не делает она.
53 - 05.03.2019 - 16:34
(53) Проверил. С правкой согласен. Изящно ты конечно из стажа льготные дни исключил. Я бы конечно просто топорно блок
Если ЕстьЛьготныеДниРодителей>0 Тогда
скопипастил из блока
Если ЕстьОтпускЗаСвойСчет > 0 Тогда
исправив
Перечисление.СЗВПараметр3ИТС2014.НЕОПЛ и СписокВРПрочиеИсключаемыеИзСтажа
на
Перечисление.СЗВПараметр3ИТС2014.ДОПВЫХ и СписокВРОплатаЛьготныхДнейРодителей
54 - 05.03.2019 - 17:11
7.70.371a:
Константа.ЕдиновременнаяВыплатаНаРебенка.Установит ь('01.02.2019', 17479.73);
Константа.ЕдиновременнаяВыплатаБеременным.Установи ть('01.02.2019', 655.49);
Константа.ЕдиновременнаяВыплатаНаПохороны.Установи ть('01.02.2019', 5946.47);
Константа.ПособиеПоУходуДоПолутораЛетМинимумВторой .Установить('01.02.2019', 6554.89);

Константа.ПособиеПоУходуДоПолутораЛетМинимумПервый .Установить('01.01.2019', 4512.00);//40% от МРОТ
55 - 06.03.2019 - 05:14
53-Харлампий Дымба >Слишком громоздко. Пожалуй оставлю свой вариант.
56 - 06.03.2019 - 05:45
МД с исправленными ошибками ZIK371a_fix.rar.
Список исправлений в файле ReadMe.txt
Цитата:
Отличия версии 731а ( 06.03.19) от версии 731 (28.01.19):
7а. глСобратьДанныеДляСЗВ2017 - "ОплатаЛьготныхДнейРодителей" исключается из льготного стажа
12а. глВписатьОсновнуюЗаписьОСтаже2010 - испр. ошибки: Вышла ЗиК 7.70.371 (Харлампий Дымба #44)
13а. добавлена обработка ЗИК_731а_ОбновлениеКонстант010219.ert для установки констант на 01.02.19 Вышла ЗиК 7.70.371 (Харлампий Дымба #54)
57 - 06.03.2019 - 15:00
55-victuan >Нет, моя правка работает некорректно. Она льготу убирает, но при этом ДОПВЫХ меняет на НЕОПЛ.

53-Харлампий Дымба >Пытаюсь эту правку реализовать, но не понимаю, что куда копипастить и что менять.
Можешь выложить в виде готового кода?
58 - 06.03.2019 - 21:06
53-Харлампий Дымба >Выкрутился вот таким способом:
Цитата:
Если ЕстьЛьготныеДниРодителей>0 Тогда

ТаблицаЛьготныеДниРодителей="";
Если глЗаполнитьТаблицуПериодовДействияВР(Сотрудник,Таб лицаЛьготныеДниРодителей,Начало, Окончание, СписокВРОплатаЛьготныхДнейРодителей)=1 Тогда

//[+] тщи Создадим набор для стажа, которым будем замещать периоды
НаборДляСтажа.УдалитьВсе();
НаборДляСтажа.ДобавитьЗначение("");
НаборДляСтажа.ДобавитьЗначение("");
НаборДляСтажа.ДобавитьЗначение(Перечисление.СЗВПар аметр3ИТС2014.ДОПВЫХ);
НаборДляСтажа.ДобавитьЗначение("");
НаборДляСтажа.ДобавитьЗначение("");
//[-] тщи
//впишем периоды
ТаблицаЛьготныеДниРодителей.ВыбратьСтроки();
Пока ТаблицаЛьготныеДниРодителей.ПолучитьСтроку()=1 Цикл
НачалоПериода=ТаблицаЛьготныеДниРодителей.НачалоПе риода;
ОкончаниеПериода=ТаблицаЛьготныеДниРодителей.Оконч аниеПериода;
//"впишем" во временную таблицу период
//тщи глВписатьОсновнуюЗаписьОСтаже2010("ВписатьБЛ",Врем ТаблицаСоСтажем,НомерЗаписи,НачалоПериода,Окончани еПериода,,,,Перечисление.СЗВПараметр3ИТС2014.ДОПВЫ Х);
глВписатьОсновнуюЗаписьОСтаже2010("Вписать",ВремТа блицаСоСтажем,НомерЗаписи,НачалоПериода,ОкончаниеП ериода, НаборДляСтажа); //тщи
КонецЦикла;
КонецЕсли;

КонецЕсли;
Но смущает, что пришлось слово ""ВписатьБЛ" заменить на "Вписать". Не вылезут ли из-за этого глюки с льготным стажем в других местах?
59 - 06.03.2019 - 21:14
Подумал и упростил правку донельзя - в блоке:
Цитата:
Если ЕстьЛьготныеДниРодителей>0 Тогда
в строке
Цитата:
глВписатьОсновнуюЗаписьОСтаже2010("ВписатьБЛ",Врем ТаблицаСоСтажем,НомерЗаписи,НачалоПериода,Окончани еПериода,,,,Перечисление.СЗВПараметр3ИТС2014.ДОПВЫ Х);
заменил "ВписатьБЛ" на "Вписать"

Но смущает, что пришлось слово ""ВписатьБЛ" заменить на "Вписать". Не вылезут ли из-за этого глюки с льготным стажем в других местах?
60 - 07.03.2019 - 08:02
(49,59) Посмотрел свои базы - у меня этот блок уже давно дописан, вот и работает как надо)))
Сделал так:

Если ЕстьЛьготныеДниРодителей>0 Тогда

ТаблицаЛьготныеДниРодителей="";

Если глЗаполнитьТаблицуПериодовДействияВР(Сотрудник,Таб лицаЛьготныеДниРодителей,Начало, Окончание, СписокВРОплатаЛьготныхДнейРодителей)=1 Тогда
//Создадим набор для стажа, которым будем замещать периоды
НаборДляСтажа.УдалитьВсе();
НаборДляСтажа.ДобавитьЗначение("");
НаборДляСтажа.ДобавитьЗначение("");
НаборДляСтажа.ДобавитьЗначение(Перечисление.СЗВПар аметр3ИТС2014.ДОПВЫХ);
НаборДляСтажа.ДобавитьЗначение("");
НаборДляСтажа.ДобавитьЗначение("");
//впишем периоды
ТаблицаЛьготныеДниРодителей.ВыбратьСтроки();
Пока ТаблицаЛьготныеДниРодителей.ПолучитьСтроку()=1 Цикл
НачалоПериода=ТаблицаЛьготныеДниРодителей.НачалоПе риода;
ОкончаниеПериода=ТаблицаЛьготныеДниРодителей.Оконч аниеПериода;
//"впишем" во временную таблицу период
глВписатьОсновнуюЗаписьОСтаже2010("Вписать",ВремТа блицаСоСтажем,НомерЗаписи,НачалоПериода,ОкончаниеП ериода, НаборДляСтажа);
КонецЦикла;
КонецЕсли;

КонецЕсли;
61 - 07.03.2019 - 08:03
Вроде тоже самое, что в (58)
Но у меня это уже несколько лет)
62 - 07.03.2019 - 15:11
(59) Всё так. "ВписатьБЛ" - подменяет только одно поле "Дополнительные сведения" (3), "Вписать" - весь набор для стажа. Так что всё ОК.
Так я в (53) и писал - просто скопируй блок для отпусков за свой счёт в блок для льготных дней родителей, поменяв список отбора и значение параметра стажа НЕОПЛ на ДОПВЫХ.
(61) А у меня множества вредников и родителей детей со льготой слава богу исчезающе малы и не пересекаются. Так что никогда и не натыкался на эту проблему.
63 - 08.03.2019 - 07:47
Цитата:
Сообщение от Харлампий Дымба Посмотреть сообщение
Так я в (53) и писал - просто скопируй блок для отпусков за свой счёт в блок для льготных дней родителей, поменяв список отбора и значение параметра стажа НЕОПЛ на ДОПВЫХ.
Как оказалось этого недостаточно. Ключевым является, что нужно менять "ВписатьБЛ" на "Вписать". И в этом случае даже копипастить НаборДляСтажа становится лишним.
Достаточно только одной лишь правки в (59) **в типовом коде меняем только одну строку кода и ничего не копипастим** .
65 - 08.03.2019 - 07:56
МД с учетом этого исправления ZIK371b_fix.rar.
Список исправлений в файле ReadMe.txt
Цитата:
Отличия версии 731b ( 07.03.19) от версии 731а ( 06.03.19):
7a. глСобратьДанныеДляСЗВ2017 - "ОплатаЛьготныхДнейРодителей" исключается из льготного стажа: исправлены ошибки


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены