К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

ЗиК 7.7, сверхурочные на доплату

0 - 01.03.2012 - 18:18
Помогите, пожалуйста.Подскажите можно ли в ЗиКе настроить так, чтобы сверхурочные начислялись и на оклад, и на доплату? Например,у сотра есть фиксированный оклад и есть варьируемая доплата к окладу. Когда есть переработка, то начисляют сверхурочные, но они начисляются только на оклад, а на доплату нет. Заранее спасибо.


1 - 01.03.2012 - 18:45
База
слева направо клац-клац
2 - 01.03.2012 - 19:06
ВР Оплата сверхурочных часов: "Вид расчета не использует расчетную базу!"
3 - 01.03.2012 - 19:07
Как в базу этого начисления залезть?
4 - 05.03.2012 - 21:06
ВР "Оплата сверхурочных часов" не может использовать никакую базу, кроме оклада.
Например: оклад у работника 10000р. Стоимость сверхурочного часа = 10000/166часов х 1,5(если полуторный размер оплаты) = 90.36. У работника 2 часа с/у, тогда 180,72. Доплата к окладу составляет 10000р. И нужно, чтобы с/у от доплаты считались таким же образом. А ЗиК считает только с оклада и всё.
5 - 06.03.2012 - 05:38
(5) сумма и произведение действительных чисел коммутативны...
что тащить доплату в сверхурочные, что сверхурочные тащить в доплату...
6 - 06.03.2012 - 06:24
Гена>Не пойму как проще это сделать? У работника оклад фиксированный. Доплата зависит от отработанных дней. А сверхурочные должны быть начислены как на оклад, так и на доплату.
Гость
7 - 06.03.2012 - 07:34
Гена имел ввиду - включите в базу для расчета Доплаты не только оклад, но и сверхурочные
8 - 07.03.2012 - 08:20
Dump 20031>Чет не получается. у Доплаты порядок расчета указан:Суммой, пропорционально отработанным часам. В базу кроме оклада, табеля включил "Оплата сверхурочных часов". В документе Ввод расчета сотруднику указал сумму 10000р. Начисление - доплата к окладу. И в ЖР получается сумма 10000р, а не 10180,72, как хотелось бы.
9 - 07.03.2012 - 08:22
Может где в табеле косяк нафигачен?
10 - 07.03.2012 - 08:25
(9) в ЖР какой из ВР лежит выше? Доплата за сверхи или произвольная доплата к окладу?
11 - 07.03.2012 - 08:26
А может потому, что доплата берет за основу "всего отработано времени"? И Серхурочные часы не включает?
Сверхурочные в табеле занесены как отдельная запись, где указан тип отработанных часов:Сверхур. часы(полуторный размер).
12 - 07.03.2012 - 08:27
Цитата:
Сообщение от Гена Посмотреть сообщение
(9) в ЖР какой из ВР лежит выше? Доплата за сверхи или произвольная доплата к окладу?
Свехурочные выше. Их надо сместить вниз? Как?
13 - 07.03.2012 - 08:33
(13) выкладывайте трассировку расчёта своей записи произвольной доплаты...

режим трассировки любых расчётов включается в Настройки пользователя - Комментировать...
Гость
14 - 07.03.2012 - 08:57
(9) Как это "суммой" и "в базу"? Если фикс.суммой - это не пропорционально ничему. Если в базу - это процент от чего-то. Определитесь
15 - 07.03.2012 - 09:07
(14)Вот что получилось:
Величина начисления 10000.00 введена документом "Ввод расчета сотруднику"
Виду расчета Произвольная доплата к окладу определен порядок расчета: Суммой, пропорционально отработанным часам
Всего рабочих часов по графику работника: 128
Отработано часов: 128
Сумма к начислению: 10000.00 руб.
16 - 07.03.2012 - 09:12
(15) Доплата опрелделяется как сумма, в данном случае 10000р. Но полнота суммы от количества отработанных дней. Если сотрудник отработал полмесяца, то и доплата 5000р.
Гость
17 - 07.03.2012 - 09:16
(17) А 5 или 10 - вручную вводите?
18 - 07.03.2012 - 09:20
А сверхурочные выдают такую запись:
Ход расчета записи "Оплата сверхурочных часов" с 01.01.12 по 31.01.12
В документе введены подробные данные об отработанном за месяц времени - будут учтены все изменения расчетных данных работника в течение Январь 2012 г..
По состоянию на 31 Января 2012 г.: часовой тариф сотрудника составил 60.24 руб.
Всего отработано праздничных часов: 2, сумма к начислению: 180.72 руб.
19 - 07.03.2012 - 09:23
(18)Да, вручную. Определяется размер доплаты сотруднику (по-видимому, по внешним характеристикам сотрудника). Заносится документом "Ввод расчета сотруднику" с открытой датой.
20 - 07.03.2012 - 09:28
(18) Уточнюсь. Размер дрплаты - фиксированная сумма, но зависит от количества отработанного времени.
21 - 07.03.2012 - 09:34
(21) не подойдёт... сделайте новый ВР и строго "Процентом от базы"... замените свой неверный...

когда в базе Оплата по окладу или табелю - то в ЖР и будет уже рассчитано по отработанному времени... и новый ВР возьмёт как надо...
22 - 07.03.2012 - 09:34
Может есть зависимость от системы оплаты сотруднику?
"Повременно-премиальная по окладу согласно табеля (по часам)"?
23 - 07.03.2012 - 09:37
(22)Если процентом от базы, то независимо сколько отработал сотрудник в месяце, ему будет начислено? Так?
24 - 07.03.2012 - 09:43
(22)Так получилось. Но самой суммы доплаты в документе не видно. Например, оклад 4611, а доплата составляет 11000р. В таком случае трудно вычислить точный процент.
25 - 07.03.2012 - 09:45
Да и наглядность такого начисления утрачивается. Расчетчику неудобно. Если сотрудников чел. 250-300.
Гость
26 - 07.03.2012 - 09:48
(24) Так выясни, как эту доплату "кто-то" считает. При этом может обнаружиться сильная зависимость от "левой ноги" считающего ;-)
27 - 07.03.2012 - 09:48
Но тем не менее, результат есть. Спасибо.
28 - 07.03.2012 - 09:57
(27)А про "левую" ногу вы правильно заметили...
Гость
29 - 07.03.2012 - 10:00
(29) О, сколько таких "ног" вылазит при внедрении...
30 - 07.03.2012 - 17:15
6-Гена > Суммы и произведения коммутативны. Да.
Но.
Источники выплат этих сумм некоммутативны.
К примеру, наша полиция(наш бережет) может получать основную зарплату (и сверхурочные в том числе) из муниципального бюджета, а вот эту самую фиксированную доплату - из федерального. И таскать туда-сюда между бюджетами(источниками выплат) 180 рублей (как в примере) - никакая Счетная Палата бюджетнику не позволит...

20-Gawws > А может, все-таки не по "внешним характеристикам"? Может, зависит от стажа, образования, квалификации? Может, ты просто не в курсе, за что и по каким критериям назначается эта самая индивидуальная доплата?
29-Gawws > А может, все таки не от "левой ноги"? Может, эта доплата называется типа "квалификационная надбавка" или "надбавка за квалификацию" и назначается по четко определенным (и прописанным в локальных НПА) критериям? Да, каждому индивидуально, но ведь и стаж и образование и квалификация и выполняемый объем работ тоже инивидуальны...
А тебе просто кажется, что эта доплата назначается "за красивые глазки" и "как левая пятка пожелает"???

30-Dump 20031 > О, сколько внедренцев не слышали словосочетания "НСОТ"... :)

(0) если не делать "коммутативность" (а я считаю, что доплата должна считаться так, как прописано, а не по законам коммутативности подстраиваться под ЗиК) и не менять ВР с "суммой пропорционально" на "процентом от базы", то...
то остается вариант залезть в модуль расчета сверхурочных.
типа так:
перед строкой
Если Документ.ПолнотаВводаДанных = 1 Тогда // подробные данные
вставить:
Величина = 0;
ЖЗр=СоздатьОбъект("ЖурналРасчетов.Зарплата");
Нач=ЖЗр.НачалоТекущегоПериода();
Кон=ЖЗр.КонецТекущегоПериода();
ЖЗр.ВыбратьЗаписиПоОбъекту(Объект,Нач,Кон);
Пока ЖЗр.ПолучитьЗапись()=1 Цикл
Если ЖЗр.ВидРасч=ВидРасчета.ПроизвольнаяДоплата23 Тогда //Здесь ставишь номер своей доплаты
ДокИзЖЗр = ЖЗр.Документ;
Если ДокИзЖЗр.Вид()="НачисленияУдержанияСотрудника" Тогда
Величина = ДокИзЖЗр.Величина;
ИначеЕсли ДокИзЖЗр.Вид() = "НачисленияУдержанияСписком" Тогда
Если ЖЗр.НомерСтрокиДокумента > 0 Тогда
ДокИзЖЗр.ПолучитьСтрокуПоНомеру(ЖЗр.НомерСтрокиДок умента);
Величина = ДокИзЖЗр.Величина;
КонецЕсли;
КонецЕсли;
// Прервать;
КонецЕсли;
КонецЦикла;

строку:
//ТарифСотрудника = глПолучитьСуммуИзРеквизита(Объект.Оклад.Получить(Д атаОкончания),ДатаОкончания)/глПолучитьСреднемесячноеКолвоЧасов(ГрафикРаботы,Да таОкончания);
заменить на:
ТарифСотрудника = (глПолучитьСуммуИзРеквизита(Объект.Оклад.Получить( ДатаОкончания),ДатаОкончания)+Величина)/глПолучитьСреднемесячноеКолвоЧасов(ГрафикРаботы,Да таОкончания);


ps: это навскидку в случае, если в течение месяца оклад не менялся. Если менялся, делаешь по аналогии для кусочков.

зы: кстати, а почему только сверхурочные? а ночные? а праздничные?
31 - 07.03.2012 - 17:17
эээ... один КонецЕсли лишний скопировался... :(
32 - 07.03.2012 - 17:24
(31) круто! снимаю шляпу... и заодно:

33 - 07.03.2012 - 17:25
И, естественно, приоритет твоей произвольнойДоплаты23 должен быть меньше, чем ОплатаСверурочныхЧасов, например, поставь приоритет 11
34 - 07.03.2012 - 17:26
33-Гена > Спасибо, Геночка!
:)
Гость
35 - 07.03.2012 - 17:36
(31) А что такое НСОТ?
36 - 07.03.2012 - 17:41
36-Dump 20031 > официально утвержденный аналог "как левая пятка директора пожелает" :)))
Гость
37 - 07.03.2012 - 17:48
Не, я без прикола и шуток - не знаю
38 - 07.03.2012 - 17:52
гугль? яндекс? :)
Гость
39 - 07.03.2012 - 17:55
Новая система оплаты труда (НСОТ)? Так это в бюджете? Я с ним не работаю


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены