К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Заполнение табличной части

Гость
0 - 05.12.2014 - 12:20
нужно из одной табличной части, где реквизитом табличной части является документ, которые являются документами -основаниями, заполнить другую табличную часть данного документа.
Управляемая форма.
Могу ли я все это сделать на клиенте?
Для каждого СтрОсн Из Объект.ДокументыОснования Цикл

Вот здесь кажется что-то не так.
Для каждого СтрТабл Из СтрОсн.ДокументОснование Цикл
НайденнаяСтрока = Объект.Товары.Найти(СтрТабл.Номенклатура, "Номенклатура");
Если НайденнаяСтрока <> Неопределено Тогда
НоваяСтрока = Объект.Товары.Добавить();
НоваяСтрока.Номенклатура = СтрТабл.Номенклатура;
НоваяСтрока.Количество = СтрТабл.Количество;
Иначе
НоваяСтрока.Количество = НоваяСтрока.Количество+СтрТабл.Количество;
КонецЕсли;
КонецЦикла;
КонецЦикла;

система выдает итератор для значения не определен ...



Гость
1 - 05.12.2014 - 12:21
Можно ли сделать все это на клиенте?
Гость
2 - 05.12.2014 - 12:37
1-Pusto > Так? - Нет. Клиент не имеет доступа к ИБ.
Uho
3 - 05.12.2014 - 12:44
так нельзя ни на клиенте, ни на сервере
Гость
4 - 05.12.2014 - 12:59
3-Uho > Я так понимаю, вопрос (1) вовсе не о коде: ТС его готов поменять ;) Вопрос "Можно ли сделать это на клиенте?". Ответ отрицательный, но с дополнением: На сервере можно сделать. Но не так, конечно :)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены