К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Записать элемент в группу

0 - 04.11.2014 - 23:21
ЗиК 77

Напомните, как программно записать элемент в нужную группу справочника. Вот код, но он не срабатывает:

Процедура Сформировать()

СпрСотр = СоздатьОбъект("Справочник.Сотрудники");
НужнаяГруппа = СоздатьОбъект("Справочник.Сотрудники");

ТЗДиалога.ВыбратьСтроки();
Пока ТЗДиалога.ПолучитьСтроку() = 1 цикл

Если СпрСотр.НайтиПоНаименованию(ТЗДиалога.ФИО) = 1 тогда

Если СпрСотр.ТекущийЭлемент().ПометкаУдаления() = 1 Тогда
Сообщить(ТЗДиалога.ФИО + " - найден, но помечен на удаление!");
продолжить;
КонецЕсли;

Сообщить(ТЗДиалога.ФИО + " - найден, перезаписываю!");
Иначе
СпрСотр.Новый();
КонецЕсли;
СпрСотр.Наименование = ТЗДиалога.ФИО;

СпрСотр.Записать();
СпрСотр.ОсновнойЭлемент = СпрСотр.ТекущийЭлемент();

НужнаяГруппа.НайтиПоКоду(0000000519);
СпрСотр.Родитель=НужнаяГруппа;

СпрСотр.Записать();

КонецЦикла;

КонецПроцедуры



Гость
1 - 04.11.2014 - 23:32
Бросил бы ты это дело, а?
Гость
2 - 04.11.2014 - 23:33
код надо "0000000519", а у тебя он 519
3 - 05.11.2014 - 05:07
1-VZ >+1
Ну а так, кроме кучи остальных ошибок, ещё и эта:
НужнаяГруппа.НайтиПоКоду("0000000519");
СпрСотр.Родитель=НужнаяГруппа.ТекущийЭлемент();
4 - 05.11.2014 - 09:01
в этом разделе форума даже сисек не просят:) и уж тем более в вопросах по 7-ке. 7-чники голодные до кода и вопросов по нему (даже самых глупых):) но терпение тоже может лопнуть:)
5 - 05.11.2014 - 09:41
Ctrl-F5
Гость
6 - 05.11.2014 - 12:36
(0) =========>>>>>>>> вам туда
Гость
7 - 08.11.2014 - 02:55
у вас метод не правильно написан. Надо писать "Запейсать"


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены