Форум на Kuban.ru (http://forums.kuban.ru/)
-   Территория 1С (http://forums.kuban.ru/f1040/)
-   -   Записать элемент в группу (http://forums.kuban.ru/f1040/zapisat-_element_v_gruppu-6240806.html)

dft2014 04.11.2014 23:21

Записать элемент в группу
 
ЗиК 77

Напомните, как программно записать элемент в нужную группу справочника. Вот код, но он не срабатывает:

Процедура Сформировать()

СпрСотр = СоздатьОбъект("Справочник.Сотрудники");
НужнаяГруппа = СоздатьОбъект("Справочник.Сотрудники");

ТЗДиалога.ВыбратьСтроки();
Пока ТЗДиалога.ПолучитьСтроку() = 1 цикл

Если СпрСотр.НайтиПоНаименованию(ТЗДиалога.ФИО) = 1 тогда

Если СпрСотр.ТекущийЭлемент().ПометкаУдаления() = 1 Тогда
Сообщить(ТЗДиалога.ФИО + " - найден, но помечен на удаление!");
продолжить;
КонецЕсли;

Сообщить(ТЗДиалога.ФИО + " - найден, перезаписываю!");
Иначе
СпрСотр.Новый();
КонецЕсли;
СпрСотр.Наименование = ТЗДиалога.ФИО;

СпрСотр.Записать();
СпрСотр.ОсновнойЭлемент = СпрСотр.ТекущийЭлемент();

НужнаяГруппа.НайтиПоКоду(0000000519);
СпрСотр.Родитель=НужнаяГруппа;

СпрСотр.Записать();

КонецЦикла;

КонецПроцедуры

VZ 04.11.2014 23:32

Бросил бы ты это дело, а?

Управление торговлей 11 04.11.2014 23:33

код надо "0000000519", а у тебя он 519

Billi 05.11.2014 05:07

1-VZ >+1
Ну а так, кроме кучи остальных ошибок, ещё и эта:
НужнаяГруппа.НайтиПоКоду([b]"[/b]0000000519[b]"[/b]);
СпрСотр.Родитель=НужнаяГруппа.[b]ТекущийЭлемент()[/b];

Buhta 05.11.2014 09:01

в этом разделе форума даже сисек не просят:) и уж тем более в вопросах по 7-ке. 7-чники голодные до кода и вопросов по нему (даже самых глупых):) но терпение тоже может лопнуть:)

user1C 05.11.2014 09:41

Ctrl-F5

Helen1986 05.11.2014 12:36

(0) =========>>>>>>>> вам туда

Morons 08.11.2014 02:55

у вас метод не правильно написан. Надо писать "Запейсать"


Текущее время: 01:48. Часовой пояс GMT +3.