К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Вышел релиз 331 "Зарплата и Кадры"

0 - 29.12.2012 - 16:06
Список изменений релиза 7.70.331 по сравнению с релизом 7.70.330
================================================== ==============
Исправлено:
Изменен номер релиза


Глобальный модуль
-----------------------------------------------------------------
Исправлено:
В соответствии с Федеральным законом "О внесении изменений в Федеральный закон "
Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством"
уточнен алгоритм определения среднедневного заработка для исчисления пособий
на период отпуска по беременности и отпуска по уходу за ребенком
до достижения 1.5 лет, начинающихся после 1 января 2013 года.

Добавлены функции
глУчитыватьДниБолезниДляПособийПоМатеринству
глУчитываемыхДнейДляРасчетаСреднегоЗаработкаПособи й2011

Внесены изменения в функции
глСуммаСреднегоЗаработкаБольничного2011
глДнейБолезниУходаЗаДетьми
глРасчетДоплатыПоБЛ2011
глСобратьДанныеДляБЛ2011


Внесены изменения в функции
глРассчитатьСуммуПособия

Документ БольничныйЛист ("Больничный лист")
-----------------------------------------------------------------
Исправлено:
В соответствии с Федеральным законом "О внесении изменений в Федеральный закон "
Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством"
уточнен алгоритм определения среднедневного заработка для исчисления пособий
на период отпуска по беременности и отпуска по уходу за ребенком
до достижения 1.5 лет, начинающихся после 1 января 2013 года.

Внесены изменения в диалог формы документа.
Внесены изменения в модуль формы документа.


Документ ОтпускПоУходуЗаРебенком ("Отпуск по уходу за ребенком")
-----------------------------------------------------------------
Исправлено:
В соответствии с Федеральным законом "О внесении изменений в Федеральный закон "
Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством"
уточнен алгоритм определения среднедневного заработка для исчисления пособий
на период отпуска по беременности и отпуска по уходу за ребенком
до достижения 1.5 лет, начинающихся после 1 января 2013 года.

Внесены изменения в модуль формы документа.

Отчет КарточкаУчетаПоСтраховымВзносам ("Карточка учета по страховым взносам")
-----------------------------------------------------------------
Исправлено:
В связи с изменением ПФР правил заполнения формы СЗВ-6-3 по категориям «НР», «ВЖНР» и «ВПНР»
и правил сверки их показателей с Расчетом РСВ-1 и ИС по формам СЗВ-6-1,2
уточнены алгоритмы заполнения формы СЗВ-6-3 и правила встроенных проверок,
выполняемых в рабочем месте подготовки отчетности в ПФР.

Внесены изменения в диалог формы отчета.
Внесены изменения в модуль формы отчета.
Внесены изменения в таблицу Таблица формы отчета.
Внесены изменения в таблицу Карточка2013 формы отчета.

Отчет ПодготовкаСведенийДляПФР2010 ("Метаданные")
-----------------------------------------------------------------
Исправлено:
В связи с изменением ПФР правил заполнения формы СЗВ-6-3 по категориям «НР», «ВЖНР» и «ВПНР»
и правил сверки их показателей с Расчетом РСВ-1 и ИС по формам СЗВ-6-1,2
уточнены алгоритмы заполнения формы СЗВ-6-3 и правила встроенных проверок,
выполняемых в рабочем месте подготовки отчетности в ПФР.

Внесены изменения в диалог формы отчета.
Внесены изменения в модуль формы отчета.
Внесены изменения в таблицу АДВ-6-4 формы отчета.

Отчет ПроверкаКомплектаДокументовПФР ("Метаданные")
-----------------------------------------------------------------
Исправлено:
В связи с изменением ПФР правил заполнения формы СЗВ-6-3 по категориям «НР», «ВЖНР» и «ВПНР»
и правил сверки их показателей с Расчетом РСВ-1 и ИС по формам СЗВ-6-1,2
уточнены алгоритмы заполнения формы СЗВ-6-3 и правила встроенных проверок,
выполняемых в рабочем месте подготовки отчетности в ПФР.

Внесены изменения в диалог формы отчета.
Внесены изменения в модуль формы отчета.

Обработка ОбновлениеИБ ("Обновление информационной базы")
-----------------------------------------------------------------
Исправлено:
Добавлено обновление релиза

Внесены изменения в модуль формы обработки.
Внесены изменения в таблицу Обновления формы обработки.

Обработка РедактированиеСведенийПФР ("Метаданные")
-----------------------------------------------------------------
Исправлено:
В связи с изменением ПФР правил заполнения формы СЗВ-6-3 по категориям «НР», «ВЖНР» и «ВПНР»
и правил сверки их показателей с Расчетом РСВ-1 и ИС по формам СЗВ-6-1,2
уточнены алгоритмы заполнения формы СЗВ-6-3 и правила встроенных проверок,
выполняемых в рабочем месте подготовки отчетности в ПФР.

Внесены изменения в диалог формы обработки.
Внесены изменения в модуль формы обработки.



41 - 23.01.2013 - 15:53
39-Гена >Т.е. это перепутки для подряд идущих разрядов?
А i подбираем опытным числом, чтобы оно получилось целым и не больше 9. Если не получается, то это не перепутки.
А есть формула для перепуток не для подряд идущих разрядов?
42 - 23.01.2013 - 16:00
90% всех ошибок при набивании чисел большой ведомости - в перемене соседних мест цифр в числе...

если разница делится на 9 - то это так и есть... далее:
1. если не делится на 10 - это разряды 0 и 1
2. делится на 10 - разряды 1 и 2
3. делится на 100 - разряды 2 и 3
...

ну и затем оставшаяся после делений на 9 и 10^i цифра даёт разницу цифр перепутки... причём со знаком +/-
43 - 23.01.2013 - 16:05
например, итого по ведомости рвёт в уменьшение на сумму -72 (минус в уменьшение)...

72/9 = 8

1. перепутаны две последние цифры
2. из всех чисел ведомости проверяем лишь те, что оканчиваются на "19" или "08"
Гость
44 - 24.01.2013 - 16:06
обновилась 77 бухгалтерия и отчетность
ЗЫ на сайте как всегда бормотуху в текущих показывает
Гость
45 - 25.01.2013 - 08:53
ВидыРаботСДосрочнойПенсией = Сотрудник.Должность.Получить(ДатаМесяца).Взимаются ВзносыЗаЗанятыхНаРаботахСДосрочнойПенсией;
Если (ВидыРаботСДосрочнойПенсией<>Перечисление.ВидыРабо тСДосрочнойПенсией.ПодземныеИВредныеРаботы) Тогда //начало вставки
Пенс = СоздатьОбъект("Периодический");
Пенс.ИспользоватьОбъект("Должность",Сотрудник);
Пенс.ВыбратьЗначения(НачМесяца(ДатаМесяца),ДатаМес яца);
Пока Пенс.ПолучитьЗначение()=1 Цикл
ВидыРаботСДосрочнойПенсией = Пенс.Значение.ВзимаютсяВзносыЗаЗанятыхНаРаботахСДо срочнойПенсией;
Если ВидыРаботСДосрочнойПенсией=Перечисление.ВидыРаботС ДосрочнойПенсией.ПодземныеИВредныеРаботы Тогда
РаботникСДосрочнойПенсией = ?(Сч=1,"",Лев(РаботникСДосрочнойПенсией,Сч-1))+"1"+?(Сч=12,"",Прав(РаботникСДосрочнойПенсией, 12-Сч));
СписокВидыРаботСДосрочнойПенсией.УстановитьЗначени е(Сч, ВидыРаботСДосрочнойПенсией);
Прервать;
КонецЕсли;
Если ВидыРаботСДосрочнойПенсией=Перечисление.ВидыРаботС ДосрочнойПенсией.ТяжелыеИПрочиеРаботы Тогда
РаботникСДосрочнойПенсией = ?(Сч=1,"",Лев(РаботникСДосрочнойПенсией,Сч-1))+"1"+?(Сч=12,"",Прав(РаботникСДосрочнойПенсией, 12-Сч));
СписокВидыРаботСДосрочнойПенсией.УстановитьЗначени е(Сч, ВидыРаботСДосрочнойПенсией);
КонецЕсли;
КонецЦикла;
КонецЕсли;




Что бы исключить все варианты переходов со списков 1 и 2 между собой, а также тех кто работает при суммированном учете льготного стажа
46 - 28.01.2013 - 07:42
45-Nikkleo >А еще надо учесть ручную правку стажа пользователем в обход справочника Должности! )))
Гость
47 - 28.01.2013 - 08:10
46-victuan >пока откажемся от этой затеи, у нас нет суммированного учета на данный момент. Если идти в обход справочника получается нужно будет делать ежемесячные правки стажа для расчета налога кадровикам, плюс делать это в сжатые сроки, до отчетности.
48 - 28.01.2013 - 16:47
47-Nikkleo >Угу, у нас уже так начали делать. Причем такое требование поставил нач.ОК.
Гость
49 - 29.01.2013 - 14:06
По сабжу, может это кому поможет. Вот кусочек из глобальника, где считается среднедневной заработок за 2011 и 2012 года для расчета больничного при отпуске по беременности и родам. Причем переменная "Дни" содержит правильное количество дней (с учетом высокосного года и больничных), предел выплат был превышен только в 2011 году. Функция возвращает с 01.01.2013 Предел:


ВсегоЗаработок = ?(Дни=0,0,(ЗаработокЗаПервыйГод + ЗаработокЗаВторойГод) / Дни);

Если УчитыватьДниБолезни=1 Тогда
// применим ограничение среднедневного
Предел = Окр((ПределПервыйГод + ПределВторойГод)/730,2);
Возврат Мин(ВсегоЗаработок,Предел);
КонецЕсли;
Возврат ВсегоЗаработок;
КонецФункции //глСуммаСреднегоЗаработкаБольничного2011
Гость
50 - 29.01.2013 - 15:16
+(49) "ВсегоЗаработок" содержит правильное значение.
Исправить недолго, но за державу обидно. Видать на Фирме не принято в декрет ходить, разработчикам проверить не на ком :)
51 - 29.01.2013 - 18:05
(50) а что не устраивает в модуле?
Гость
52 - 30.01.2013 - 10:15
(51) в печатной форме больничного над таблицей среднедневной заработок считается правильно(звонили наши бухи, выясняли):
ВсегоЗаработок = ?(Дни=0,0,(ЗаработокЗаПервыйГод + ЗаработокЗаВторойГод) / Дни);
у нас:
ВсегоЗаработок=(463000+484339.43)/706=1341.84,
где 706=731-7-18

в таблицу печатной формы среднедневной берется по формуле:
Предел = Окр((ПределПервыйГод + ПределВторойГод)/730,2);
Предел=(463000+512000)/730=1335.62
53 - 30.01.2013 - 10:26
умная программа сравнивает СДЗ с максимумом и обрезает его...

так что скажите программе спасибо - она за вас всё продумала...
Гость
54 - 31.01.2013 - 10:44
Пришла новая инструкция из ФНС. Бухи убедились, что программа в этом месте считает правильно. Вернул все взат: в БЛ в серединке СДЗ=1341.84, в табличке СДЗ=1335.62.
Это для сведения. Не понял, почему так, да и стараюсь не вникать глубоко в правила расчетов поскольку это, имхо, вредно для мозга :)
55 - 31.01.2013 - 11:03
(54) тогда вечно будете только и двигать вперёд и "взат"
Гость
56 - 11.02.2013 - 07:41
Кто столкнется с необходимостью использования "Корректировка доходов для страховых взносов" в 2013 году для подземных, вредных и пр... - гарантирована ошибка при формировании свода проводок.
- для своих исправил на коленке по временной схеме, так не знаю как дальше будут исправлять в 1с...
Гость
57 - 11.02.2013 - 11:36
Очень нужен md для посдедней ЗИК. chmv2005@mail.ru
58 - 11.02.2013 - 12:47
chmv, ты адресом ошибси.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены