К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Помогите, пожалуйста!!! Не счтитает страховые взносы!!!

0 - 13.04.2013 - 16:38
Пожалуйста, помогите, после обновления на 551 релиз, а затем на 557 перестали счтитаться страховые взносы.Что делать??? Подскажите, где настроить???


1 - 13.04.2013 - 16:56
Если глСпрТарифСтраховыхВзносов.НайтиПоРеквизиту("ВидТа рифа",ВремТаблица.ВидТарифа,0) = 0 Тогда
{Обработка.СтавкиСтраховыхВзносов.Форма.Модуль(439 )**: Неверное имя реквизита! вот что пишет при заполнении тарифа страховых взносов.
Гость
2 - 13.04.2013 - 17:21
Это какая конфигурация-то? Для России последняя 556 от 03.04.2013...
3 - 13.04.2013 - 17:22
Для России, да. Это 556 релиз.
4 - 13.04.2013 - 17:23
Ошибочка в первом посте в номере релиза. 556 сейчас.
5 - 13.04.2013 - 17:28
Я обновила до 556 релиза обнулились справочники страховых взносов , а при попытке заполнить вручную выдает сообщение глСпрТарифСтраховыхВзносов.ПФР.Установить(Дата(Пер иод,01,01), ВремТаблица.ПФР);
{Обработка.СтавкиСтраховыхВзносов.Форма.Модуль(444 )**: Не выбран элемент!
6 - 13.04.2013 - 17:37
Помогите, пожалуйста, уже и не знаю где еще смотреть.
Гость
7 - 13.04.2013 - 17:38
5-Sabot > Во... "вручную". А на кой, спрашивается?
Константа ТарифОсновныхВзносов заполена? Поди нет... А надо (учитывая, что периодическая, т.е., значение всегда на 1 января.
8 - 13.04.2013 - 17:41
А где ее найти константу эту, в каком справочнике? уже голова кругом второй день
9 - 13.04.2013 - 17:45
я заполнила поставила на 01.01.2013 правильно?( в операциях-константы-тариф основных взносов)
10 - 13.04.2013 - 17:46
и все равно при заполнении справочника тарифов тоже самое сообщение
Гость
11 - 13.04.2013 - 17:54
9-Sabot > Вообще-то, эта константа не "заполняется", а ее значение выбирается из списка соответствующего перечисления (их там 11):
Организации, применяющие ОСН, кроме с/х производителей
Организации, уплачивающие ЕНВД
Организации инвалидов
... и т.д.
12 - 13.04.2013 - 17:57
я ее и выбрала Организации, применяющие ОСН, кроме с/х производителей, дату поставила 01.01.2013 , а тарифы не заполняются
13 - 13.04.2013 - 18:00
сообщение выходит такое жеглСпрТарифСтраховыхВзносов.ПФР.Установить(Дата(П ер иод,01,01), ВремТаблица.ПФР);
{Обработка.СтавкиСтраховыхВзносов.Форма.Модуль(444 )**: Не выбран элемент!
Гость
14 - 13.04.2013 - 18:01
13-Sabot > Константу надо заполнять при закрытой обработке Тарифы Страховых взносов: обработка при запуске сразу читает значение константы, и изменения ее при работе не почуствует.
15 - 13.04.2013 - 18:05
я закрыла справочник Налоги-Тарифы страховых взносов и заполнила заново константу, а потом открыла Тарифы страховых взносов, а там пусто!!!
Гость
16 - 13.04.2013 - 18:29
15-Sabot > Значит, были траблы при обновлении... Вообще-то, сами ставки заполнялись в 525 релизе, а в 551 токмо дополнительный тариф для "вредников".
Попробуем для начала удалить индексные файлы в БД (.CDX). Потом зайдем в монопольном режиме, и посмотрим ставки...
Если не изменится ничего, надо будет перезалить справочник.
17 - 13.04.2013 - 18:40
что мне надо сделать для этого. куда зайти?
18 - 13.04.2013 - 18:50
может сразу начать с перезаливки справочника?
Гость
19 - 13.04.2013 - 19:24
18-Sabot > Взять и перезалить. Основа: обработка ОбновлениеИБ
Делаем внешнюю обработку. На морде лица текст "Перезаливка страховых тарифов" (чтоб не забыть).
Внутри: переносим из ОбновлениеИБ процедуры:
УдалитьИсториюТарифа и ЗаполнитьТарифыДополнительныхВзносовЗаЗанятыхНаРаб отахСДосрочнойПенсией
Посмотреть в справочник Налоги есть ли там строки "ПФР_вред" и "ПФР_тяж". Если нет, добавить процедуру ЗаписатьПолноеНаименование.
Найти строку Номер = 770524
Начиная со строки // опишем новый тариф и до строки Таб.ВывестиСекцию(Строка(Номер)); копируем, и переносим в нашу обработку в процедуру Сформировать()
Затем ищем строку ИначеЕсли Номер = 770550 Тогда
Здесь нам нужна строка ЗаполнитьТарифыДополнительныхВзносовЗаЗанятыхНаРаб отахСДосрочнойПенсией();
Все, что выше - в зависимости от наличия в справочнике Налоги строк для вредников.
Проверяем, запускаем.
20 - 13.04.2013 - 19:39
наверное я не смогу, я не программист
Гость
21 - 13.04.2013 - 19:55
20-Sabot > Посмотреть в плане счетов наличие 69.2.4 и 69.2.5 сможешь? В в справочнике Налоги строки с кодами ПФР_вред и ПФР_тяж есть?
22 - 13.04.2013 - 20:20
есть такие счета и строки
23 - 13.04.2013 - 20:22
и что дальше делать?
Гость
24 - 13.04.2013 - 20:25
http://www.hddfiles.ru/download/24872/
25 - 13.04.2013 - 20:28
спасибо, скачала. куда теперь это вставить?
Гость
26 - 13.04.2013 - 20:30
23-Sabot > Возьми обормотку из ссылки. Перед записью конфигуратором закомментируй строки 196 - 213. Из (22) следуют, что они лишнии в данном случае. Сохрани, и запусти в режиме предприятия.
Гость
27 - 13.04.2013 - 20:33
25-Sabot > Сохранять лучше в каталог ExtForms. Вызов: Файл - открыть (ищешь обормотку), и жамкаешь кнопку.
28 - 13.04.2013 - 20:33
что-то не понятно. я скачала ваш файл. он у меня на рабочем столе. дальше я запускаю конфигуратор?
Гость
29 - 13.04.2013 - 20:35
28-Sabot > С рабочего стола может и не запустится. См. 27.
Правка модуля - в режиме конфигуратор.
Запуск на исполнение - в режиме Предприятие.
Гость
30 - 13.04.2013 - 20:37
+29 В принципе, можно и не править. Без правки сработает.
31 - 13.04.2013 - 20:39
ну вот я на вкладке модуль что там править?
Перем Сч, ТаблицаСоответствияСчетов, Сч76_Н;

//************************************************** ****************************
// УдалитьИсториюТарифаНаДату()
//
// Параметры:
//
//
// Вызывается из формул элементов диалога:
//
//
// Описание:
//
//
Процедура УдалитьИсториюТарифа(ВидТарифа, НачальныйГод)

Спр = СоздатьОбъект("Справочник.ТарифСтраховыхВзносов");
Если Спр.НайтиПоРеквизиту("ВидТарифа", ВидТарифа, 1)=0 Тогда
Возврат;
КонецЕсли;

Периодический = СоздатьОбъект("Периодический");

Периодический.ИспользоватьОбъект("ПФР",Спр);
Периодический.ОбратныйПорядок(1);
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение()=1 Цикл

ДатаЗначения = Периодический.ДатаЗнач;
Период = ДатаГод(ДатаЗначения);
Если Период >= НачальныйГод Тогда
Периодический.Удалить();
Спр.Записать();
КонецЕсли;

КонецЦикла;

Периодический.ИспользоватьОбъект("ПФРНакопительный ",Спр);
Периодический.ОбратныйПорядок(1);
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение()=1 Цикл

ДатаЗначения = Периодический.ДатаЗнач;
Период = ДатаГод(ДатаЗначения);
Если Период >= НачальныйГод Тогда
Периодический.Удалить();
Спр.Записать();
КонецЕсли;

КонецЦикла;

Периодический.ИспользоватьОбъект("ФСС",Спр);
Периодический.ОбратныйПорядок(1);
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение()=1 Цикл

ДатаЗначения = Периодический.ДатаЗнач;
Период = ДатаГод(ДатаЗначения);
Если Период >= НачальныйГод Тогда
Периодический.Удалить();
Спр.Записать();
КонецЕсли;

КонецЦикла;

Периодический.ИспользоватьОбъект("ФФОМС",Спр);
Периодический.ОбратныйПорядок(1);
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение()=1 Цикл

ДатаЗначения = Периодический.ДатаЗнач;
Период = ДатаГод(ДатаЗначения);
Если Период >= НачальныйГод Тогда
Периодический.Удалить();
Спр.Записать();
КонецЕсли;

КонецЦикла;

Периодический.ИспользоватьОбъект("ТФОМС",Спр);
Периодический.ОбратныйПорядок(1);
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение()=1 Цикл

ДатаЗначения = Периодический.ДатаЗнач;
Период = ДатаГод(ДатаЗначения);
Если Период >= НачальныйГод Тогда
Периодический.Удалить();
Спр.Записать();
КонецЕсли;

КонецЦикла;

КонецПроцедуры //УдалитьИсториюТарифа

//************************************************** ****************************
// ЗаполнитьТарифыДополнительныхВзносовЗаЗанятыхНаРаб отахСДосрочнойПенсией()
//
Процедура ЗаполнитьТарифыДополнительныхВзносовЗаЗанятыхНаРаб отахСДосрочнойПенсией()

ПФР_вред = глПолучитьНалог("ПФР_вред");

НалогПериодический = СоздатьОбъект("Периодический");
НалогПериодический.ИспользоватьОбъект("Ставка", ПФР_вред);

НалогПериодический.Значение = 4;
НалогПериодический.ДатаЗнач = '01.01.2013';
НалогПериодический.Записать();

НалогПериодический.Значение = 6;
НалогПериодический.ДатаЗнач = '01.01.2014';
НалогПериодический.Записать();

НалогПериодический.Значение = 9;
НалогПериодический.ДатаЗнач = '01.01.2015';
НалогПериодический.Записать();

ПФР_тяж = глПолучитьНалог("ПФР_тяж");

НалогПериодический = СоздатьОбъект("Периодический");
НалогПериодический.ИспользоватьОбъект("Ставка", ПФР_тяж);

НалогПериодический.Значение = 2;
НалогПериодический.ДатаЗнач = '01.01.2013';
НалогПериодический.Записать();

НалогПериодический.Значение = 4;
НалогПериодический.ДатаЗнач = '01.01.2014';
НалогПериодический.Записать();

НалогПериодический.Значение = 6;
НалогПериодический.ДатаЗнач = '01.01.2015';
НалогПериодический.Записать();

КонецПроцедуры //ЗаполнитьТарифыДополнительныхВзносовЗаЗанятыхНаРаб отахСДосрочнойПенсией

//************************************************** ****************************
// ЗаписатьПолноеНаименование(Счет, ПолноеНаименование)
//
Процедура ЗаписатьПолноеНаименование(КодСчета, ПолноеНаименование)

Если Сч.НайтиПоКоду(КодСчета) = 1 Тогда
Сч.ПолнНаименование = ПолноеНаименование;
Сч.Записать();
КонецЕсли;

КонецПроцедуры // ЗаписатьПолноеНаименование()

//*******************************************
Процедура Сформировать()

// опишем новый тариф
Спр = СоздатьОбъект("Справочник.ТарифСтраховыхВзносов");
ВидТарифа = Перечисление.ТарифыСтраховыхВзносов.НародныеХудоже ственныеПромыслы;
УдалитьИсториюТарифа(ВидТарифа, 2011);
Если Спр.НайтиПоРеквизиту("ВидТарифа", ВидТарифа, 1)=0 Тогда
Спр.Новый();
Спр.ВидТарифа = ВидТарифа;
КонецЕсли;

Спр.ИспользоватьДату('01.01.2011',1);
Спр.ВидТарифа = ВидТарифа;
Спр.ПФР = 16;
Спр.ПФРНакопительный = 6;
Спр.ФСС = 1.9;
Спр.ФФОМС = 1.1;
Спр.ТФОМС = 1.2;
Спр.Записать();

Спр.ИспользоватьДату('01.01.2012',1);
Спр.ПФР = 16;
Спр.ПФРНакопительный = 6;
Спр.ФСС = 1.9;
Спр.ФФОМС = 2.3;
Спр.ТФОМС = 0;
Спр.Записать();

Спр.ИспользоватьДату('01.01.2013',1);
Спр.ПФР = 21;
Спр.ПФРНакопительный = 6;
Спр.ФСС = 2.4;
Спр.ФФОМС = 3.7;
Спр.ТФОМС = 0;
Спр.Записать();

Спр.ИспользоватьДату('01.01.2015',1);
Спр.ПФР = 26;
Спр.ПФРНакопительный = 6;
Спр.ФСС = 2.9;
Спр.ФФОМС = 5.1;
Спр.ТФОМС = 0;
Спр.Записать();

// ИначеЕсли Номер = 770550 Тогда

Если ПустоеЗначение(Константа.ИспользуютсяРаботыСДосроч нойПенсией) = 1 Тогда
Константа.ИспользуютсяРаботыСДосрочнойПенсией = Нет;
КонецЕсли;

Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.У становить('01.01.2013', 568000);

ПФР_вред = глПолучитьНалог("ПФР_вред");
ПФР_тяж = глПолучитьНалог("ПФР_тяж");

// добавление в план счетов
Состояние("Добавление наименований счетов");
Сч = СоздатьОбъект("Счет." + ВыбранныйПланСчетов().Идентификатор());
ЗаписатьПолноеНаименование("69.2.4", "Дополнительные взносы на страховую часть пенсии работникам, занятым на работах с тяжелыми условиями труда");
ЗаписатьПолноеНаименование("69.2.5", "Дополнительные взносы на страховую часть пенсии работникам, занятым на работах с вредными условиями труда");
ЗаписатьПолноеНаименование("Н11.11", "Убытки за 2011 год");
ЗаписатьПолноеНаименование("Н11.12", "Убытки за 2012 год");
ЗаписатьПолноеНаименование("СВЗ.01.6", "Дополнительные взносы на страховую часть пенсии работникам, занятым на работах с тяжелыми условиями труда");
ЗаписатьПолноеНаименование("СВЗ.01.7", "Дополнительные взносы на страховую часть пенсии работникам, занятым на работах с вредными условиями труда");

ЗаполнитьТарифыДополнительныхВзносовЗаЗанятыхНаРаб отахСДосрочнойПенсией();

КонецПроцедуры
32 - 13.04.2013 - 20:41
значит можно не править? просто все закрываю и запускаю 1с в режиме предприятия
Гость
33 - 13.04.2013 - 20:47
32-Sabot > Да. Если есть TeamView, смогу сам сделать :)
34 - 13.04.2013 - 20:47
Попробуйте обновить ставки обработкой ЗаполнитьСтавкиСтраховыхВзносов:
http://hdd.tomsk.ru/file/gynxsukm

- так, обнаружил, VZ опередил... :-)
- если что - можете ещё и этой обработкой попробовать...
35 - 13.04.2013 - 20:48
закрыла конфигуратор. запустила пердприятие. основной тариф стоит в константах, а в справочнике опять что-то не то, тоже самое может где не правильнос делала?
36 - 13.04.2013 - 20:49
есть такая программа
37 - 13.04.2013 - 20:51
запускать TeamView?
Гость
38 - 13.04.2013 - 20:55
37-Sabot > Запусти. Выложи ID и пароль (это безопаснр: пароль каждый раз новый)
39 - 13.04.2013 - 20:56
ID 689 272 946 пароль 8209


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены