К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Отчет О Розничных Продажах

Гость
0 - 22.05.2012 - 01:03
Помогите правильно создать документ ОтчетОРозничныхПродажах УТ 11.0.8.8.

УСН, ЕНВД на розничном складе, Автономная ККМ.
Если документ создавать руками, то все нормально, а если обработкой, то ругается, что нет товара на складе. И в отчете "Остатки товаром организация" по документу не выдает "Вид запасов", "Организация" "Налогообложение НДС". А при создании точной копии документа "руками" выдает все правильно.



&НаСервере
Процедура СоздатьДок(КассаККМ)
Док = Документы.ОтчетОРозничныхПродажах.СоздатьДокумент( );
Док.КассаККМ = КассаККМ.Ссылка;

РеквизитыКассыККМ = Справочники.КассыККМ.РеквизитыКассыККМ(КассаККМ);
ЗаполнитьЗначенияСвойств(Док, РеквизитыКассыККМ);

Док.НалогообложениеНДС = Справочники.Организации.НалогообложениеНДС(Док.Орг анизация, Док.Склад, Док.Дата);

Док.Подразделение = КассаККМ.Подразделение;
Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;

СтрДок = Док.Товары.Добавить();
СтрДок.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("0001");
СтрДок.КоличествоУпаковок = 1;
СтрДок.Количество = 1;
СтрДок.Сумма = 100;
СтрДок.Цена = СтрТЧ.Сумма/СтрТЧ.Количество;
СтрДок.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;

СтрДок.Партнер = Справочники.Партнеры.РозничныйПокупатель;

Док.СуммаДокумента = Док.Товары.Итог("Сумма");
Док.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаОблагае тсяЕНВД;
Попытка
Док.Записать(РежимЗаписиДокумента.Проведение);
Исключение
Док.Записать();
КонецПопытки;
КонецПроцедуры



1 - 22.05.2012 - 08:15
ИМХО скрытые реквизиты
Все читать лениво, да и УТ11 нет под рукой.
Но "обычная процедура нижеследующая" ©Сава:
1) Создаешь док руками
2) Запускаешь какую-нить универсальную обработку, показывающую все реквизиты, включая скрытые (например, КниверсальныйЖурналДокументов)
3) Разбираешься в необходимости заполнения реквизитов
4) Только после этого создаешь док программно.
2 - 22.05.2012 - 08:16
+(1) "УниверсальныйЖурналДокументов"
Гость
3 - 22.05.2012 - 08:21
Так в принципе и начинал...
C помощью простой обработки вывожу все реквизиты:

&НаСервере
Процедура Сформировать()
Для каждого Реквизит Из Док.Метаданные().Реквизиты Цикл
Сообщить(""+Реквизит.Представление()+" "+Док[Реквизит.Имя]);
КонецЦикла;

Сообщить("---------------------");
КонецПроцедуры

Они абсолютно совпадают...
Гость
4 - 22.05.2012 - 09:38
Люди... Ну что? Действительно с таким вопросом никто не сталкивался?
5 - 22.05.2012 - 09:40
(3) Если ты чего-то не видишь, то не значит, что этого нет.
На вскидку: ошибка из-за того, что нет заполнения таб.части "ВидыЗапасов".
За ОтчетОРозничныхПродажах не скажу, а когда программно формировал ПеремещениеТоваров в УТ11 без этого никак.
PS Может и еще чего-то забыл. "Видишь суслика? А он есть!" ©
Гость
6 - 22.05.2012 - 13:34
в крайнем случае перед записью включи режим обмена


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены