Форум на Kuban.ru (http://forums.kuban.ru/)
-   Территория 1С (http://forums.kuban.ru/f1040/)
-   -   Отчет О Розничных Продажах (http://forums.kuban.ru/f1040/otchet_o_roznichnyh_prodazhah-2632884.html)

RatGray 22.05.2012 01:03

Отчет О Розничных Продажах
 
Помогите правильно создать документ ОтчетОРозничныхПродажах УТ 11.0.8.8.

УСН, ЕНВД на розничном складе, Автономная ККМ.
Если документ создавать руками, то все нормально, а если обработкой, то ругается, что нет товара на складе. И в отчете "Остатки товаром организация" по документу не выдает "Вид запасов", "Организация" "Налогообложение НДС". А при создании точной копии документа "руками" выдает все правильно.



&НаСервере
Процедура СоздатьДок(КассаККМ)
Док = Документы.ОтчетОРозничныхПродажах.СоздатьДокумент();
Док.КассаККМ = КассаККМ.Ссылка;

РеквизитыКассыККМ = Справочники.КассыККМ.РеквизитыКассыККМ(КассаККМ);
ЗаполнитьЗначенияСвойств(Док, РеквизитыКассыККМ);

Док.НалогообложениеНДС = Справочники.Организации.НалогообложениеНДС(Док.Организация, Док.Склад, Док.Дата);

Док.Подразделение = КассаККМ.Подразделение;
Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;

СтрДок = Док.Товары.Добавить();
СтрДок.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("0001");
СтрДок.КоличествоУпаковок = 1;
СтрДок.Количество = 1;
СтрДок.Сумма = 100;
СтрДок.Цена = СтрТЧ.Сумма/СтрТЧ.Количество;
СтрДок.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;

СтрДок.Партнер = Справочники.Партнеры.РозничныйПокупатель;

Док.СуммаДокумента = Док.Товары.Итог("Сумма");
Док.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяЕНВД;
Попытка
Док.Записать(РежимЗаписиДокумента.Проведение);
Исключение
Док.Записать();
КонецПопытки;
КонецПроцедуры

Mitrich 22.05.2012 08:15

ИМХО скрытые реквизиты
Все читать лениво, да и УТ11 нет под рукой.
Но "обычная процедура нижеследующая" ©Сава:
1) Создаешь док руками
2) Запускаешь какую-нить универсальную обработку, показывающую [b]все[/b] реквизиты, включая скрытые (например, КниверсальныйЖурналДокументов)
3) Разбираешься в необходимости заполнения реквизитов
4) Только после этого создаешь док программно.

Mitrich 22.05.2012 08:16

+(1) "УниверсальныйЖурналДокументов"

RatGray 22.05.2012 08:21

Так в принципе и начинал...
C помощью простой обработки вывожу все реквизиты:

&НаСервере
Процедура Сформировать()
Для каждого Реквизит Из Док.Метаданные().Реквизиты Цикл
Сообщить(""+Реквизит.Представление()+" "+Док[Реквизит.Имя]);
КонецЦикла;

Сообщить("---------------------");
КонецПроцедуры

Они абсолютно совпадают...

RatGray 22.05.2012 09:38

Люди... Ну что? Действительно с таким вопросом никто не сталкивался?

Mitrich 22.05.2012 09:40

(3) Если ты чего-то не видишь, то не значит, что этого нет.
На вскидку: ошибка из-за того, что нет заполнения таб.части "ВидыЗапасов".
За ОтчетОРозничныхПродажах не скажу, а когда программно формировал ПеремещениеТоваров в УТ11 без этого никак.
PS Может и еще чего-то забыл. "Видишь суслика? А он есть!" ©

Управление торговлей 11 22.05.2012 13:34

в крайнем случае перед записью включи режим обмена


Текущее время: 20:33. Часовой пояс GMT +3.