К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

1С 7.7 Мигающая строка

Гость
0 - 03.02.2014 - 17:11
Имеется информационная строка. Подскажите как заставить её мигать. Спасибо

Функция ИнформационнаяСтрока()
Стр = "";
Сч.ИспользоватьВладельца(ВыбраныйЛицевой);
Сч.ВыбратьЭлементы();
Пока Сч.ПолучитьЭлемент()=1 цикл
Если Сч.ФлагОтключения=1 тогда
Если Сч.ДатаПоверки<ТекущаяДата() тогда
Стр = Стр+"Дата поверки счетчика "+СокрЛП(Сч.ТекущийЭлемент())+"-"+СокрЛП(Сч.ДатаПоверки) +РазделительСтрок;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Возврат Стр;
КонецФункции



Гость
1 - 03.02.2014 - 17:31
Стр.Мигать(1);
Гость
2 - 03.02.2014 - 17:39
1-Одинэсник > очень смешно)
Гость
3 - 03.02.2014 - 18:17
(0) ЦЕЛЬ ?
1c-Это не мультимедийное приложение,
а что бы выделить - выведи разным шрифтом, размером, цветом и радуйся или ВК используй если уж так надо
Гость
4 - 03.02.2014 - 18:18
3-nordbox > цель: максимально привлечь внимание пользователя
Гость
5 - 03.02.2014 - 18:30
formex.dll от Альфа насколько я помню, проста и работоспособна, там можешь раскрашивать как попугая во все цвета со всеми эффектами хоть всю 1С
Гость
6 - 03.02.2014 - 18:38
5-nordbox > а где взять и описание?
Гость
7 - 03.02.2014 - 18:40
по поисковикам смотреть не судьба? или религия не позволяет?
http://dorex.pro/?download
Гость
8 - 03.02.2014 - 19:07
лучше Форма.ОбработкаОжидания - никаких внешних компонент не требуется
Гость
9 - 03.02.2014 - 19:16
Цитата:
Сообщение от Ang070 Посмотреть сообщение
цель: максимально привлечь внимание пользователя
ОткрытьФормуМодально()
Гость
10 - 03.02.2014 - 19:22
(8)(9) НЕЕЕЕЕЕЕ! им нужна новогодняя гирлянда ))
я не против украшательства и удобства предоставления инфы но .... если на экране все цвета радуги со всякими мигалками через час работы завыть можно будет
Гость
11 - 03.02.2014 - 22:16
Цитата:
Сообщение от nordbox Посмотреть сообщение
(8)(9) НЕЕЕЕЕЕЕ! им нужна новогодняя гирлянда ))я не против украшательства и удобства предоставления инфы но .... если на экране все цвета радуги со всякими мигалками через час работы завыть можно будет
открывается форма лицевого счета приема платежа коммунальных услуг, на форме очень много всяких гадостей написано и вот нужно чтобы просроченные счетчики мигали. можно конечно выкинуть предупреждение, но хотелось что-нибудь эдакое...
12 - 03.02.2014 - 22:19
Нетленку ваяешь? Зря.
Гость
13 - 03.02.2014 - 22:26
(11) приходи к нам в гости!!!
Гость
14 - 03.02.2014 - 22:33
11-Ang070 > Модальное окно с перечнем просроченных позиций с закрывающей кнопкой "Я прочитало". При закрытию по "крестику" выкидывает их 1С нафиг.
В другой раз подумают капризы выставлять.
Гость
15 - 03.02.2014 - 22:38
14-VZ да понятно пока ограничился: Предупреждение("поверка счетчика просрочена",10)
Гость
16 - 03.02.2014 - 22:40
ну а вообще пугающие мигающие надписи прикольно действуют когда нет кнопки <закрыть>
Гость
17 - 03.02.2014 - 23:34
16-Ang070 > Кнопа "Я прочитало" как бе предупреждает ;)
Гость
18 - 04.02.2014 - 06:15
Ang070>> "эдакое... "
это когда с программой работают вменяемые люди,
а способов вынести мозги пользователю просто несчитанное количество, напряги фантазию.
Исходя из опыта наблюдения за работой юзверей:
как правило чем больше гадостей на экране..... юзвери просто привыкают к этому и не обращают внимание потом.
VZ>> "Я прочитало".
Скажи ка, ты часто лицензионные соглашения полностью читаешь с крестиком "Я согласен" ? как правило нажимаешь крестик и не прочитав что там, жмешь "Далее" ))))
если юзверю "Надо", то любые надписи ему пофигу.
Гость
19 - 04.02.2014 - 06:31
+18 ты бы ещё мощный речевой информатор прикрутил к 1с ))) повеселился бы )))
20 - 04.02.2014 - 06:40
...220 под задницу
Гость
21 - 04.02.2014 - 07:24
в инете давным давно где резидент первоапрельский валялся, при нажатии кнопки, появления сообщения или клика мышки на спикер выдавал "ОЙ" )))
22 - 04.02.2014 - 07:39
Цитата:
Сообщение от nordbox Посмотреть сообщение
в инете давным давно где резидент первоапрельский валялся, при нажатии кнопки, появления сообщения или клика мышки на спикер выдавал "ОЙ" )))
ты можешь пояснить смысл своего сообщения?
там что-то непонятное с пунктуацией
23 - 04.02.2014 - 11:26
Цитата:
Сообщение от nordbox Посмотреть сообщение
ты бы ещё мощный речевой информатор прикрутил к 1с ))) повеселился бы )))
Ну... Скрепку из МСОфиса прикручивали... даже со звуком... было приколько, но быстро всех достало.
Гость
24 - 04.02.2014 - 15:08
(22) Ирли Бёрд>> извиняюсь, писала спросонья, поясняю для особо одаренных.
в интернете, давным давно где то на одном из сайтов, была размещена резидентная программа- первоапрельская шутка,
при нажатии кнопки на клавиатуре,
при появлении на экране сообщения или нажатии на манипуляторе мышь любой кнопочки,
на динамик который находится в системном блоке,
воспроизводилось голосовое сообщение из фильма "Чужие"
Гость
25 - 04.02.2014 - 18:30
Цитата:
Сообщение от nordbox Посмотреть сообщение
(22) Ирли Бёрд&gt;&gt; извиняюсь, писала спросонья, поясняю для особо одаренных. в интернете, давным давно где то на одном из сайтов, была размещена резидентная программа- первоапрельская шутка, при нажатии кнопки на клавиатуре, при появлении на экране сообщения или нажатии на манипуляторе мышь любой кнопочки, на динамик который находится в системном блоке, воспроизводилось голосовое сообщение из фильма "Чужие"
Было такое...к сожалению частично мимо(


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены