К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

ЗУП 3.1, при изменении нормы внешней обработкой пересчитать данные

_U2
0 - 21.05.2018 - 13:26
Платформа 8.3.11.3034, ЗУП 3.1.6.37.
В документе "Начисление зарплаты и взносов" меняю норму отработанного времени внешней обработкой типа:
///////////////////////////////////////
&НаКлиенте
Процедура Заполнить(Команда)

Для каждого ТекущаяСтрока из ВладелецФормы.Объект.Начисления Цикл
//
Если ТекущаяСтрока.НормаДней>0 Тогда
ТекущаяСтрока.НормаДней = НормаДней ;
текущаяСтрока.ФиксРасчетВремени=Истина;
КонецЕсли;

Если ТекущаяСтрока.НормаЧасов>0 Тогда
ТекущаяСтрока.НормаЧасов=НормаЧасов;
текущаяСтрока.ФиксРасчетВремени=Истина;

КонецЕсли;


КонецЦикла ;

КонецПроцедуры
/////
Нормы проставляютя,
Признак ручного изменения есть (жирный шрифт)
Не могу сообразить как пересчитать данные при изменении нормы:
Пробовал:
ЗарплатаКадрыРасширенныйКлиент.ВводНачисленийНачис лениеПриИзменении(ВладелецФормы, ОписаниеТаблицыВидовРасчета, 2);
//
РасчетЗарплатыРасширенныйКлиент.ДокументыВыполнени яНачисленийПриАктивацииСтроки(ВладелецФормы, "Начисления", Истина);
//

ЧОТ СОВСЕМ ЗАТЫРКАЛСЯ..:-((



1 - 22.05.2018 - 14:19
0-_U2 > См. процедуру перерасчета в модуле формы документа ПересчитатьСотрудников(Команда) и ПересчитатьСотрудниковНаСервере().
_U2
2 - 22.05.2018 - 17:05
(1)Спасибо, гляну!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены