К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

ЗиК при смене способа начисления НДФЛ с отпускных увеличивает облагаемую базу

Гость
0 - 25.02.2013 - 19:23
Доброго времени суток! Вопрос ниже.


Гость
1 - 25.02.2013 - 19:24
Помогите, пожалуйста, убрать в феврале 2012 лишний доход по НДФЛ.
Сотрудник ушел в отпуск в декабре 2011 с переходом на январь 2012. Во время отпуска в январе 2012 он заболел и проболел до февраля 2012 принеся помимо основного больничного продолжение в феврале 2012, таким образом у нас появилось два больничных (один в январе 2012 и его продление в феврале 2012) и два исправления отпуска увеличивающих его срок (одно в январе 2012, другое в феврале 2012).
Весь 2012 год мы работали по прежней методике начисления НДФЛ с переходящих отпусков по которой отпуска приравнивались к заработной плате. При этом в 2-НДФЛ доход и НДФЛ с него отражались верно. В декабре 2012 мы меняем методику начисления НДФЛ с переходящих отпусков задав значение константы «Оплату отпуска в учете НДФЛ учитывать по месяцу начисления (применяется с 2012 г.)» = 1. После расчета декабря 2012 в 2-НДФЛ за февраль 2012 появился лишний доход в размере 45730,34 и с него начислился НДФЛ.
То есть помимо верного объединения суммы отпускных января 2012 (4035,03) и февраля 2012 (26900,20) в январь 2012 (30935,23), появилась дополнительная сумма в размере 45730,34 (на скриншоте обвел красной рамкой)

Привожу скриншоты
Первоначальный док-т отпуска декабрь 2011
http://i011.radikal.ru/1302/2b/ad857bd34e06.jpg
Исправление 001 док-та отпуска январем 2012
http://s48.radikal.ru/i120/1302/cd/b8cf0ce67241.jpg
Исправление 002 док-та отпуска февралем 2012
http://s019.radikal.ru/i628/1302/aa/0519ef186253.jpg

Первоначальный БЛ январь 2012
http://i056.radikal.ru/1302/9c/d1e50fd366d5.jpg
Продолжение БЛ февраль 2012.jpg
http://s018.radikal.ru/i509/1302/35/7a57e76fcfb8.jpg

2НДФЛ по прежней методике отпуск как зарплата
http://i052.radikal.ru/1302/1e/c00b68a80121.jpg
2НДФЛ по новой методике с декабря 2012 отпуск как прочий доход
http://s020.radikal.ru/i706/1302/54/8b957ffd2f76.jpg
Гость
2 - 25.02.2013 - 19:39
А зачем в 11 год полезли, зика заднее число не любит. Меняли бы константу текущим месяцем, разовыми начислениями корректировку вводили.
Гость
3 - 25.02.2013 - 20:35
(2)в 11 год никто не лез, откуда такие выводы?
константу и меняли текущим месяцем декабрь 12.
4 - 26.02.2013 - 05:02
Дата изменения значения константы должна быть 01.01.2012
Гость
5 - 26.02.2013 - 05:30
(4)попробовал, картина та-же,значит здесь что-то другое не так
6 - 26.02.2013 - 05:36
уберите в ГМ слово "Сторно":
http://forums.kuban.ru/f1040/К_вопро...-3195821.html
Гость
7 - 26.02.2013 - 06:17
(6)спасибо огромное! помогло. что характерно, если я правильно понял, то в теме (6) речь идет о том, что ЗиКа штатно "некрасиво" переносит весь исправляемый доход в месяц исправления, то есть в моем случае доход должен был появиться в феврале 2012, но исчезнуть в январе 2012. НО этого не произошло, доход остался и в январе 2012, и появился в феврале 2012, то есть задвоился. Получается, что штатный алгоритм ЗиК не просто переносит доход "некрасиво", но и некорректно!
8 - 26.02.2013 - 06:23
(7) не так поняли... после того, как перевели ВР отпуска с действия на регистрацию - все декабрьские по периоду регистрации 45 тысяч перепрыгнули в февраль...

главное - что работает убирание одного слова в ГМ... если хотите - пришлите в благодарность пустую выгрузку любой демо 332... а то у меня только 321 под рукой :)
Гость
9 - 26.02.2013 - 06:34
(8) так при этом и в январе 2012 остались начисления отпускных приходящиеся на январь 2012 по периоду действия, то есть по логике их-то ЗиК должна была исключить, тогда-бы это было просто "некрасиво", т.к. общая сумма дохода была-бы верной, а так получается именно неправильно, т.к. завышается сумма дохода.
332 выслал , еще раз спасибо огромное!
Гость
10 - 26.02.2013 - 06:37
+(9)тьфу-ты, а как мыло увидеть? что-то в нике не нахожу его, отрапортовал о высылке рано :)
11 - 26.02.2013 - 06:43
gen_mal на рамблере
Гость
12 - 26.02.2013 - 06:44
+(8)дело в том, что в теме в (6) многие ратуют за штатный механизм ЗиК и неприкосновенность МД, но ведь это практически невозможно, т.к. некрасиво и неправильно - вещи разные.
Гость
13 - 26.02.2013 - 06:47
(11)отправил через штатный механизм Т1С со ссылкой
Гость
14 - 26.02.2013 - 16:23
(6)"уберите в ГМ слово "Сторно":"

с этим изменением решается (0), но у другой сотрудницы в декабрь 2012 попадает из декабря 2011 исправление за октябрь 2011. В чем логика?
если использую второе исправление из (6), то исчезает сумма в декабре 2012 у этой сотрудницы, но снова появляется та-же самая проблема у сотрудника в (0).

Привожу скрины сотрудницы
Ввод расчета за Октябрь2011
http://s019.radikal.ru/i617/1302/63/6649cc89532d.jpg
Ввод исправительного расчета за Декабрь 2011
http://i024.radikal.ru/1302/f1/3beefec61ca4.jpg
2НДФЛ за 2012 год
http://i076.radikal.ru/1302/cf/a89fa47f9ac8.jpg
Гость
15 - 26.02.2013 - 17:15
+(14)почему при расчете НДФЛ за декабрь 2012 происходит анализ декабря 2011?

ВР Материальная помощь
ПериодДействия 01.10.11
ПериодРегистрации 31.12.11
ЖрнЗарплата.Результат -9222
16 - 26.02.2013 - 17:23
спасибо...

а какой код дохода у ВР Матпомощь?
17 - 26.02.2013 - 17:41
глянул... хорошее замечание... ликвидировав "Сторно", мы не попадаем сюда:

Если ДоходыПоРегистрацииСторно=1 Тогда
// здесь собираются доходы, по периоду регистрации

Док = ЖрнЗарплата.Документ;
Если ЖрнЗарплатаДляСторно.ВыбратьЗаписиПоДокументу(Док) =1 Тогда
ПериодРегистрацииЗаписи=ЖрнЗарплатаДляСторно.Перио дРегистрации.ДатаОкончания;
Если (ПериодРегистрацииЗаписи<НачалоГода) или (ПериодРегистрацииЗаписи>ОкончаниеГода) Тогда
Продолжить;
КонецЕсли;
КонецЕсли
;

следовательно, данный выделенный кусок надо впендюрить и в рабочий кусок выше - после:

Если ДоходыПоРегистрации=1 Тогда
// здесь собираются доходы, по периоду регистрации
...
Гость
18 - 26.02.2013 - 18:39
(16)код дохода 2760
Гость
19 - 26.02.2013 - 19:09
(17)кусок добавил, сумма мат.помощи в декабре 2012 исчезла, но теперь стал появляться отриц.доход в корректируемом месяце, и общая сумма НДФЛ не равна сумме НДФЛ помесячно. сейчас скрины выложу. причем этот эффект теперь у обоих сотрудников, у (0) и (14)
20 - 26.02.2013 - 19:16
похоже у матпомощи свой отдельный расчёт...
Гость
21 - 26.02.2013 - 19:19
(20)так это-же и у (0) случилось

скрины сотрудницы из (14)

2-НДФЛ по прежней методике
http://s54.radikal.ru/i146/1302/70/bfa10a69e40d.jpg

2-НФДЛ по новой методике с исправлениями
http://s017.radikal.ru/i430/1302/ac/888e44b11ee9.jpg

то есть перестал совпадать даже годовой доход
Гость
22 - 26.02.2013 - 19:20
готовлю скрины по сотруднику (0) после добавления куска из (17)
Гость
23 - 26.02.2013 - 19:25
скрины по сотруднику (0)
2-НДФЛ по прежней методике
http://s006.radikal.ru/i213/1302/1e/b066be5c3526.jpg

2-НФДЛ по новой методике с исправлениями
http://s017.radikal.ru/i413/1302/95/d43682132878.jpg
Гость
24 - 26.02.2013 - 19:29
+(23)то есть после добавления куска (17) мы вернулись к методике ЗиКи, когда она весь доходпереносит в месяц последнего исправления, см сумму 45730.32 с кодом 2012 во 2-м месяце. при этом еще и годовой доход от прежней методики снизился на 17 труб.
25 - 26.02.2013 - 19:38
тогда не надо (17)
Гость
26 - 26.02.2013 - 20:16
(25)если убираю (17) то нормально заполняется (0), а (14) с минусом суммы декабря 2011 в декабре 2012.

вернее так - короткое решение из (6) решает проблему (0), но создает проблему (14), длинное решение из (6) решает проблему (14), но возвращает проблему (0).
как-бы совместить короткое и длинное решение из (6)?
27 - 26.02.2013 - 20:27
временно поставьте код дохода матпомощи: не 2760, а 4800... что-нибудь изменилось?
Гость
28 - 26.02.2013 - 20:32
(27)не меняется код в справочнике "Виды расчетов", полез в конфигуратор
Гость
29 - 26.02.2013 - 20:45
(27)поменял код на 4800, убрал (17), заменил длинный вариант (6) на короткий, то есть сделал "уберите в ГМ слово "Сторно""

не помогает, в декабре 2012 появляется -9222
30 - 27.02.2013 - 04:48
пришлось самому лезть в ответ на 332...
не туда мы условие впендюрили... проверил на демо...
надо так: в районе строки 35980 (жирным - добавление)

ПростоДоходы=1;
ИначеЕсли (ВР.ВходитВГруппу(ГруппаРасчетов.ОсобоеИсчислениеН ДФЛ)=0) и (СписокВРПоПериодуРегистрации.Принадлежит(ВР)=1) Тогда
Если ЖрнЗарплата.Сторно=1 Тогда
//это сторно запись

Док = ЖрнЗарплата.Документ; // ГМ начало
Если ЖрнЗарплатаДляСторно.ВыбратьЗаписиПоДокументу(Док) =1 Тогда
ПериодРегистрацииЗаписи=ЖрнЗарплатаДляСторно.Перио дРегистрации.ДатаОкончания;
Если (ПериодРегистрацииЗаписи<НачалоГода) или (ПериодРегистрацииЗаписи>ОкончаниеГода) Тогда
ДоходыПоРегистрацииСторно=1;
Продолжить;
КонецЕсли;
КонецЕсли; //ГМ конец



//если вызов функции осуществлен для распределения НДФЛ по ИФ, не регистрируем в таблице доходов
//сторно дохода по периоду регитсрации, зарегистрированные в периоде формирования отчета
Если (ВызовДляРаспределенияНДФЛ=0) или ((ВызовДляРаспределенияНДФЛ=1) и (ЖрнЗарплата.НачалоПериодаПоДате(ПериодРегистрации )<>ЖрнЗарплата.НачалоПериодаПоДате(ДатаАктуальност и))) Тогда
//ДоходыПоРегистрацииСторно=1; // ГМ начало
ДоходыПоРегистрации=1; // ГМ конец
КонецЕсли;
Гость
31 - 27.02.2013 - 07:17
(30) нет-нет, 332 сам по себе, за помощь напишите сумму по итогам, я перечислю, и так спасибо огромное что время находите!

после исправлений (30) у сотрудницы (14) мат.помощь пропала и общая сумма дохода пошла с прежней методикой, а вот у сотрудника (0) завысился доход в январе 2012 (стал аж 76665,57) и как следствие годовой доход тоже. скрины формирую и выкладываю.
Гость
32 - 27.02.2013 - 07:36
+(31)
скрин001 - 2НДФЛ до начала изменений на период регистрации, в январе 2012 сумма отпуска 4035,03, в феврале 26900,20
http://s019.radikal.ru/i641/1302/70/f4fc9c459d89.jpg

скрин002- 2НДФЛ после исправления в ГМ только слово "Сторно" (6), сумма записей по отпуску ушла в январь 2012 и равна 30935,23
http://s018.radikal.ru/i509/1302/01/469320e7174d.jpg

скрин003 - 2НДФЛ после исправления (30), все записи по отпуску суммировались в январе 2012, но сумма завышена и составляет 76665,57
http://s018.radikal.ru/i523/1302/26/2843ff3fbcb8.jpg
33 - 27.02.2013 - 17:14
всё-таки плохо менять константу в период отпуска, который правят...

поставьте периодику не с 01.01.12 а с 01.12.11 или после отпуска - 01.03.12
Гость
34 - 27.02.2013 - 17:59
(33)речь о константе "Оплату отпуска в учете НДФЛ учитывать по месяцу начисления (применяется с 2012 г.)" ?

попробовал 01.12.11, 01.03.12 и даже 01.12.12 - результат одинаковый, все как было на скрине003 в (32) так и осталось, в январе 2012 показывает 76665,57. А отчего подозрение на дату константы пали? я так понял с какого месяца ее не задай алгоритм все равно весь год по новой методике считает, ведь НДФЛ нарастающим итогом считается.
35 - 27.02.2013 - 18:06
слишком нетипичный случай:
и период регистрации перешёл внутри отпуска, и дважды исправлялся...

поправьте руками...
Гость
36 - 27.02.2013 - 19:59
(35)руками в ЖР? или-же просто в форме карточки?
Гость
37 - 27.02.2013 - 20:49
(35)пошел дальше по списку сотрудников, проявляется и в более простых случаях, когда всего-лишь одно исправление, пошел в отпуск в декабре 2011, в январе 2012 заболел, отпуск продлился на дни БЛ. Получается такой-же кавардак. Скрины сейчас сделаю и выложу.
Что характерно, ведь если сделать только (6),то есть только убрать в ГМ слово "Сторно", то у таких людей отражает все верно. А когда добавляешь условие
Док = ЖрнЗарплата.Документ; // ГМ начало
Если ЖрнЗарплатаДляСторно.ВыбратьЗаписиПоДокументу(Док) =1 Тогда
ПериодРегистрацииЗаписи=ЖрнЗарплатаДляСторно.Перио дРегистрации.ДатаОкончания;
Если (ПериодРегистрацииЗаписи<НачалоГода) или (ПериодРегистрацииЗаписи>ОкончаниеГода) Тогда
ДоходыПоРегистрацииСторно=1;
Продолжить;
КонецЕсли;
КонецЕсли; //ГМ конец


то получается значительное завышение сумм в январе 2012, может это условие можно еще как-то сузить? например исключив его действие для отпусков? его-же из-за мат.помощи добавили?
Гость
38 - 27.02.2013 - 22:14
+(37)добавил условие:

Если (СокрЛП(ВР)<>"Отпуск очередной") и (СокрЛП(ВР)<>"Отпуск дополнительный") Тогда

Док = ЖрнЗарплата.Документ; // ГМ начало
Если ЖрнЗарплатаДляСторно.ВыбратьЗаписиПоДокументу(Док) =1 Тогда
ПериодРегистрацииЗаписи=ЖрнЗарплатаДляСторно.Перио дРегистрации.ДатаОкончания;
Если (ПериодРегистрацииЗаписи<НачалоГода) или (ПериодРегистрацииЗаписи>ОкончаниеГода) Тогда
ДоходыПоРегистрацииСторно=1;
Продолжить;
КонецЕсли;
КонецЕсли; //ГМ конец
КонецЕсли;

Теперь и (0) верно, и (14). НО у сотрудника (37) доначисление отпуска за февраль 2012 не попало никуда, то есть доход занизился на сумму отпускных переходящих на февраль 2012. И таких сотрудников несколько. Ушли в отпуск в конце декабря2011, заболели в декабре 2011 или январе 2012, часть отпуска перешла на февраль 2012. В январе 2012 есть только начисление отпуска за январь 2012, а начисление за февраль 2012 пропадает в пустоту.
Гость
39 - 27.02.2013 - 22:39
38-Looking > И нахрена так зарываться? Переходящих декабрь-январь немного... Главное, 12 год сдать, а потом корявки разработчики исправят, и все автоматически пересчитается: НДФЛ же всегда с начала года считается.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены