К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Заполнения табеля

Гость
0 - 05.03.2013 - 15:24
Всем доброго время суток, возник вопрос, как можно в документе Табель учета рабочего времени организации чтобы при заполнении отпускных за месяц в выходные праздничные дни ставилась бука "B" а не "ОТ"


Гость
1 - 05.03.2013 - 20:04
а сколько денег предлагают?
Гость
2 - 05.03.2013 - 22:29
для просто думал сравнить идеи, а форум изжил свое как таковой
Гость
3 - 05.03.2013 - 23:03
2-Гордиенко Сергей > Что-то я не заметил "идеи". Дурость - в наличии. "Идея" - где?
Гость
4 - 06.03.2013 - 07:05
3-VZ Идея такова, нашел обработку которая должна автоматом менять значение "ОТ" на "В" в документе Табель учета рабочего времени организации не получается, не меняет вот код:Процедура КнопкаВыполнитьНажатие(Кнопка)
ДокОбъект = мДокумент.ПолучитьОбъект();

мФорма = ДокОбъект.ПолучитьФорму();

ТабЧасть = мФорма.ЭлементыФормы.ОтработанноеВремя.Значение;
Для Каждого ТекСтрока Из ТабЧасть Цикл
Для Сч=1 По 31 Цикл
Если Не ЗначениеЗаполнено(ТекСтрока["ПервыйВидВремени"+Сч]) Тогда
ТекСтрока["ПервыйВидВремени"+Сч] = Справочники.КлассификаторИспользованияРабочегоВрем ени.ВыходныеДни;
ТекСтрока["ПервыйЧасов"+Сч] = 8;
Иначе
КонецЕсли;;
КонецЦикла;
КонецЦикла;
мФорма.Открыть();


КонецПроцедуры
не могу понять в чем ошибка.
5 - 06.03.2013 - 07:48
прежде чем кодить - сначала нужно понять смысл замены... уверяю - ни один кадровик в здравом уме не скажет, что все ОТ по всем выходным надо заменить на В - это просто чушь полная...

в действительности же есть такая нужная задача как заменить ОТ на В в праздники, только в 14 наших праздников, но никак не все выходные - это раз...

несерьёзно искать в алгоритме "8", т.к. смены бывают разные - это два...

"Если Не ЗначениеЗаполнено" сработает не только для ОТ, но и для любой другой маркировки невыхода: БО, Ж, ДО и т.п. - это три
Гость
6 - 06.03.2013 - 07:51
если мозг додумается ещё и в классификатор записать() - что жена и дети потом делать будут?
Гость
7 - 06.03.2013 - 07:56
(5)Гена а как сделать чтобы только в праздники заменяло От на В, можете подсказать
Гость
8 - 06.03.2013 - 08:05
Кто нибудь может подсказать решение
9 - 06.03.2013 - 08:06
(7) сначала уточните - Вам сказали только праздники подменить?
Гость
10 - 06.03.2013 - 08:13
(9) Гена да только праздники
11 - 06.03.2013 - 08:21
1. где-то задаём список 14 праздников
2. Интервал
3. Цикл по сотрудникам
4. Условие: Если для даты из п.1 найдено ОТ Тогда заменить на В
5. КонецЦикла
Гость
12 - 06.03.2013 - 08:23
(11) Гена не чего не понял,объясните в коде как это реализовать, голова вообще не варит
13 - 06.03.2013 - 08:24
код - это к программистам... не ко мне
Гость
14 - 06.03.2013 - 08:26
(13)Гена Спасибо и на это, народ помогите
15 - 06.03.2013 - 08:31
может мне везло по жизни, но всегда рядом был толковый программист, который кодил заданный алгоритм за 5 минут...
Гость
16 - 06.03.2013 - 08:35
(15) Наверное просто у меня или голова совсем не работает или я не знаю, простой код а сделать не могу
17 - 06.03.2013 - 08:42
нет под рукой снеговика, но может там есть Помощник ввода новой обработки?

щёлкните - какие обязательные процедуры она предложит? тогда начнём заполнять...
18 - 06.03.2013 - 08:47
ага... и через год, когда будем считать следующий очередной отпуск, не забыть бы учесть, что "просто В" для расчета среднего не выбрасывается, а "В посреди отпуска" - выбрасывается.

В связи с этим возникает пример - допустим, реализовали "алгоритм замены ОТ на В". Через год считаем средний. Берем 12 месяцев. Доходим до Мая месяца. Смотрим табель
стоит:
1 мая В
2 мая В
3 мая ОТ
4 мая ОТ
5 Мая ОТ
6 Мая ОТ
7 Мая ОТ
8 Мая ОТ
9 Мая В
с 10 и по 31 - ОТ
Вопрос - Сколько вешать в граммах? тоись - сколько брать в знаменатель для мая месяца? Сотрудник был в отпуске с 1 Мая или с 3 Мая?
19 - 06.03.2013 - 08:49
Картина маслом! Еще неродившийся программист на "отжившем свое" форуме. "Стою на асфальте я..."
Гость
20 - 06.03.2013 - 08:56
Народ можно же, например просто написать код чтобы значение "От" заменяло на "В" и все не каких трудностей не надо
21 - 06.03.2013 - 08:57
(18) кадрам фиолетовы расчёты средних... бухгалтеры давно привыкли и махнули рукой на праздничные отпускные дырки - не связываются с копейками...

кадрам нужен красивый табель - пусть получат... с кадрами не стоит ссориться, уверяю...
Гость
22 - 06.03.2013 - 08:57
(19) Просто запутался, флудит то не надо с каждым бывает(((
23 - 06.03.2013 - 08:58
(20) сначала ответь на элементарный вопрос из (18).
Ну это же очень просто - сколько в знаменателе? Ну же.. смелее.. Просто назови циферку..
Гость
24 - 06.03.2013 - 09:00
(23) (((
Гость
25 - 06.03.2013 - 09:02
Народ можете просто код подсказать, а не все подряд писать, просто реально помощь нужна, не ужели не у кого не было такой ситуации
26 - 06.03.2013 - 09:03
21-Гена > тот же простой вопрос - "сколько в знаменателе"?

зы: А по поводу "копеек" и с кем не стоит ссориться.. Не стоит ссориться с прокуратурой и трудовой инспекцией.
ИМХО.
:)
27 - 06.03.2013 - 09:04
господа, кто свободен - отвлекитесь от игр - дайте код человеку... видать, кадры сурово на него наехали...
28 - 06.03.2013 - 09:06
(25) Я подскажу код, если ты правильно ответишь на вопрос из (23). У тебя одна попытка.
Гость
29 - 06.03.2013 - 09:10
(28)Блондинка в шок Я толком вопрос не понял, не ужели прикол общения на форуме поиздеваться, не когда этого не понимал, ну знаешь больше ты ну подскажи
30 - 06.03.2013 - 09:11
волки...

(0) держите:
http://infostart.ru/public/162934/

(28) элементарно, Ватсон - праздничные дырки в отпусках входят в знаменатель СДЗ (увеличивают)
Гость
31 - 06.03.2013 - 09:19
(30) Гена я давно эту обработку пробовал не то, Т-13 не надо, нужна простая обработка которая не посредственно в табеле меняет
32 - 06.03.2013 - 09:20
30-Гена >держите:
опередил :)
33 - 06.03.2013 - 09:22
(31) Вы кто по профессии?
возьмите обработку и оттуда кусок модуля подставновки => впендюрьте в свой макет... и вуаля...
34 - 06.03.2013 - 09:23
31-Гордиенко Сергей > а, так тебе что, не в печатной форме поменять нужно?
Гость
35 - 06.03.2013 - 09:25
(34) ну да в самом документе Табель учета рабочего времени организации
36 - 06.03.2013 - 09:27
(35) не верю... никому не интересен документ, его реквизиты... лучше уточните у заказчика - он 100% хочет именно печатную форму...

я ещё не знаю ни одного пользователя, который хотел бы что-то видеть в диалоге, а не в печатной форме...
Гость
37 - 06.03.2013 - 09:27
(33) Гена пробовал не получается
Гость
38 - 06.03.2013 - 09:29
(36) Гена есть такие которые хотят не печатную форму
39 - 06.03.2013 - 09:35
дык... сам док табеля вводится только в редких случаях... для большинства сотрудников он лишний... например, для офисных работников...


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены