К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Запись данных в табличное поле

Гость
0 - 09.04.2014 - 14:53
Здравствуйте. Подскажите пожалуйста. Создается обработка. В форму вставлена ТаблицаЗначений.Колонки у нее меняются взависимости от выбранного банка. Проблема в том что присчитывании данных из текстового файла данные в таблицу не записываются.

ИначеЕсли Банк="Интеркама" Тогда
Сообщить("======== Начало обработки файлов для объединения и выгрузки в банк Интеркама ======= ");
Пользователь="";

Для каждого Строка Из Список Цикл
Если строка.Пометка=Истина ТОгда
Пользователь=Строка.Значение;
ПутьКФайлу=Диск+"Users\"+Пользователь+"\Zarplata\I nterkama\";
Сообщить("Начало загрузки с "+ПутьКФайлу);
НайденныеФайлы=НайтиФайлы(ПутьКФайлу,"*.075");

Для каждого файла из НайденныеФайлы Цикл
ДатаСозданияФайла=Формат(Файла.получитьВремяИзмене ния(),"ДФ=dd.MM.yyyy");
Если ДатаСозданияФайла=Формат(ТекущаяДата(),"ДФ=dd.MM.y yyy") ТОгда
//Текст = Новый ЧтениеТекста(Файла.полноеИмя,КодировкаТекста.ANSI) ;
//Стр = Текст.Прочитать();
//сообщить(стр);
Текст.Прочитать(Файла.ПолноеИмя);
Текст.УстановитьТипФайла(КодировкаТекста.OEM);

Для номерстроки=1 по Текст.КоличествоСтрок()Цикл
Сообщить(Текст.ПолучитьСтроку(номерстроки));
Стр=Текст.ПолучитьСтроку(НомерСтроки);

СтрокаТаблицы=ЭлементыФормы.ТЗ.ТекущаяСтрока;
**** СтрокаТаблицы.Таб=Сред(Стр,1,14
);

КонецЦикла;
Иначе
Сообщить("Файл "+Файла.ПолноеИмя+" НЕ ЗАГРУЖЕН, дата создания "+ДатаСозданияФайла+" сегодня "+ТекущаяДата()+" возможно это старый файл, перед загрузкой очистите каталоги от старых файлов.");
возврат;
КонецЕсли;
Конеццикла;
КонецЕсли;
КонецЦикла;

Сообщить("======== Конец обработки файлов для объединения и выгрузки в банк Интеркама ======= ");
КонецЕсли;

Пишет что Значение не является значением объектного типа (таб)



1 - 09.04.2014 - 14:59
1) В форму нельзя вставить ТаблицуЗначений. Можно элемент управления "Табличное поле" поставщиком данных для которого будет таблица значений.
2) Для добавления строк в коллекцию строк таблицы значений есть методы Добавить() и Вставить(). Не увидел их в приведённом куске кода.
Гость
2 - 09.04.2014 - 15:11
(1) В форму вставлен элемент управления, который просто назван ТЗ.

Получилось. Спасибо. странно а ведь так тоже пробовала
Гость
3 - 09.04.2014 - 15:22
(0) Можно еще вопрос. хоть и ставишь кодировку виндовс. все равно текстовая часть файла в dos-кодировки.В чем ошибка?

Текст.УстановитьТипФайла(КодировкаТекста.Ansi);
Uho
4 - 09.04.2014 - 16:28
Описание:

Устанавливает кодировку файла, в которой будет сохранен текстовый документ при интерактивной записи (например, при выборе пункта "Файл - Печать").
5 - 09.04.2014 - 16:30
(3)
в какой кодировке приходят файлы из банка?
Гость
6 - 10.04.2014 - 06:39
(5) dos
Гость
7 - 10.04.2014 - 07:05
(6) Пишу Текст.Прочитать(Файла.ПолноеИмя,КодировкаТекста.AN SI); все равно выходят калябаля
Uho
8 - 10.04.2014 - 09:21
7-Inna110850 > а прочитать в дос-кодировке религия не позволяет?
9 - 10.04.2014 - 09:27
(7)
ты указываешь здесь кодировку совсем не для дос...
нужно .OEM или "cp866"
Гость
10 - 10.04.2014 - 09:43
(9) спасибо большое.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены