К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Вывод строк из табличной части

Гость
0 - 19.08.2013 - 20:41
Дело в чем: в табличной части есть несколько строк, как в таблицу добавить эти строки, так чтоб строки основной секции не повторялись?
Код такой:
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Макет");

Таб.ВывестиСекцию("Лист1");
// Таб.ВывестиСекцию("Шапка2");


ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если НомерСтроки=1 Тогда
Отъезд=Отъезд;
Приезд = Приезд
Иначе
Отъезд="";
Приезд="";
КонецЕсли;
Таб.ВывестиСекцию("Лист1|Строка");
КонецЦикла;
Таб.ВывестиСекцию("Подвал2");

Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,0,0);
Таб.Показать("");


Секция главная
|строка1
| строка2 |Строка1второй секции
| строка3 |строка2второй секйии
|строка4
|строка5
|
При выводе он повторяет строки 2и3 и выводит строки второй секции.
Как сделать так, чтоб секция была одна и выводилась таблица.



1 - 19.08.2013 - 20:51
баф. елы-палы. тебе на мисте уже втолковывают 10 минут
2 - 19.08.2013 - 21:27
создать ВертикальнуюСекцию2 (столбец), в который войдут вот эти
Строка1второй секции
Строка2второй секции

вот этот цикл изменить
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если НомерСтроки=1 Тогда
Отъезд=Отъезд;
Приезд = Приезд
Иначе
Отъезд="";
Приезд="";
КонецЕсли;
Таб.ВывестиСекцию("Лист1|Строка");

//добавлено
Если <ТутПроверяемНадоЛиВывестиСекцию2> Тогда
Таб.ПрисоединитьСекцию("Лист1|ВертикальнуюСекцию2 ");
КонецЕсли;
//конец добавленного


КонецЦикла;


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены