К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Вышел релиз 7.70.609 "Бухгалтерский учет"

Гость
0 - 03.02.2016 - 01:09
Статусы налогоплательщика с 2015 года
" Предоставлены новые статусы налогоплательщиков для физических лиц, не являющихся налоговыми резидентами РФ:
- Участник программы по переселению соотечественников,
- Беженец или получивший временное убежище на территории РФ,
- Нерезидент, работающий по найму на основании патента,
- Гражданин страны-участника Договора о ЕАЭС"
Сервис 1С-Отчетность
Для упрощенной бухгалтерской (финансовой) отчетности (утвержденной приказом Минфина России от 17.08.2012 № 113н (в редакции приказа Минфина от 06.04.2015 № 57н)) внесены изменения в сервис 1С-Отчетность для осуществления возможности отправки электронных представлений."

При обновлении ошибка, если в справочнике сотрудники есть группы

"Периодический.ИспользоватьОбъект("Статус",СпрСотр удники.ТекущийЭлемент()); : {Обработка.ОбновлениеИБ.Форма.Модуль(11733)**: Статус не является константой или периодическим параметром!"

Лечится заменой штатного кода
Периодический.ИспользоватьОбъект("Статус", СпрСотрудники);

на код
Если СпрСотрудники.ЭтоГруппа()=0 Тогда
Периодический.ИспользоватьОбъект("Статус",СпрСотру дники.ТекущийЭлемент());
КонецЕсли;



Гость
1 - 03.02.2016 - 01:22
Нипонял...

С чего это вдруг:
1) Участник программы - нерезидент?
2) Беженец... Чегой-то он нерезидент?
3) Нипонял... Нерезидент... Это я понимаю.... Купил патент... Понимаю... Закон-то отдельный зачем?
4) Ну я гражданин страны ЕАЭС.. Меня зовут Хуао Дзинь Жуй... Я браконьерю вовсю, уже застрелил всех ваших тигров и козлов, вывез весь лес и чернозем уже к себе в Китай... Дальше чо?
Гость
2 - 03.02.2016 - 01:50
Также исправлены ошибки функционала

Отчет КнигаПродаж1137 ("Книга продаж по Постановлению № 1173")
Не выводилась валютная сумма в графе 13а.

Обработка ВыборФайловДляОтправки ("Выбор файлов для отправки")
Отсутствовала вкладка для Росприроднадзора
3 - 03.02.2016 - 08:30
0-Looking > - Спасибо за замеченную ошибку, но - неправильное исправление ошибки - нужно логическое изъятие группы в цикле, иначе группа будет обрабатываться дальше, с ни к чему не пришитой периодикой - скорее всего, пропишет периодику по текущему сотруднику, который уже отработан.

Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
Если СпрСотрудники.ЭтоГруппа()=1 Тогда
Продолжить;
КонецЕсли;
//... обработка периодики
КонецЦикла;
Гость
4 - 03.02.2016 - 11:14
(3)у меня тоже самое по функционалу, у Вас компактнее, у меня размазаннее по типовому коду.

Если СпрСотрудники.ЭтоГруппа()=0 Тогда
Периодический.ИспользоватьОбъект("Статус",СпрСотру дники.ТекущийЭлемент());
...........
типовой код по обработке периодики
...........
КонецЕсли;
5 - 03.02.2016 - 18:22
У разработчиков даже тестовой базы нет ?)
Гость
6 - 03.02.2016 - 20:33
5-USSR > Может, и есть...
Но там работают таджики и молдаване...
7 - 03.02.2016 - 20:35
Аналогичные косяки в УСН и ИП. Не ну проверку на группу можно забыть, но ТекущийЭлемент() - это стремно. Ну и хоть запустить .. Или там в справочнике без групп один Нуралиев
8 - 03.02.2016 - 22:44
(7) если много сотров без групп - все нормально проходит
Гость
9 - 03.02.2016 - 22:52
(7)возможно обновления поручают писать чистым восьмерочникам? без опыта 7.7, 6.0 и ранее?
Гость
10 - 03.02.2016 - 22:53
(8)точно проходит? или просто ошибку не показывает, но и обработку периодических значений при этом не производит?
11 - 03.02.2016 - 23:52
(10) а что наводит на мысль, что может не пройти ?
Гость
12 - 04.02.2016 - 10:20
(11)отсутствие .ТекущийЭлемент() не принципиально?
101
13 - 04.02.2016 - 10:22
отдел по написанию обновлений для 7.7 разогнали еще более года назад
14 - 04.02.2016 - 12:03
(10) поглядел, в базе с проверкой на группу точно всё прошло
если групп нет, должно быть аналагично
Гость
15 - 04.02.2016 - 13:53
(14)то есть то, что
Периодический.ИспользоватьОбъект("Статус", СпрСотрудники);

а не
Периодический.ИспользоватьОбъект("Статус", СпрСотрудники.ТекущийЭлемент());

норм?
101
16 - 04.02.2016 - 14:13
(15) поставь код

Если СпрСотрудники.Этогруппа()=1 тогда
продолжить;

КонецЕсли;


перед этой строкой и успокойсо ;)))
17 - 05.02.2016 - 19:40
гы-гы-гы-гы
вышел 610 релиз бух, УСН - 255, пбоюл - 255
18 - 05.02.2016 - 22:40
(17) в 1с прочитали и поправили )))
19 - 05.02.2016 - 23:58
15-Looking > если СпрСотрудники - это выборка, по которой ты ходишь - то указывай дополнительно .ТекущийЭлемент()

если СпрСотрудники - это ссылка - то не надо, если к ссылке укажешь .ТекущийЭлемент() - то просто передернет объект из базы (актуализирует)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены