К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

(в8 БП 3 типовая) Как при создании в обработке документа вызвать процедуры самого документа?

0 - 06.12.2014 - 09:11
Во внешней обработке создаю документ:

&НаКлиенте
Процедура ВыполнитьРеализацию(Команда)

Форма = ПолучитьФорму("Документ.РеализацияТоваровУслуг.Фор ма.ФормаДокументаТовары",,ЭтаФорма);
ДанныеФормы = Форма.Объект;

ВыполнитьРеализациюНаСервере(ДанныеФормы);


ПарамОтбора = Новый Структура("Ссылка", ДанныеФормы);
НовФорма = ПолучитьФорму("Документ.РеализацияТоваровУслуг.Фор маДокументаТовары", ПарамОтбора);

СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("Номер", ДанныеФормы.Номер);



КопироватьДанныеФормы(ДанныеФормы,Форма.Объект);

Форма.Открыть();

КонецПроцедуры

Затем

&НаСервере
Процедура ВыполнитьРеализациюНаСервере(ОперДанные)

НовыйДокументРеализация = Документы.РеализацияТоваровУслуг.СоздатьДокумент() ;
НовыйДокументРеализация.Организация = Объект.Организация;
НовыйДокументРеализация.Склад = Объект.Склад;
НовыйДокументРеализация.Контрагент = Объект.Контрагент;
НовыйДокументРеализация.ДоговорКонтрагента = Объект.Договор;
НовыйДокументРеализация.Дата = Объект.НаДату;
НовыйДокументРеализация.Ответственный = ПараметрыСеанса.ТекущийПользователь;

Для Каждого Инв из Объект.Инвентарь Цикл
Если Инв.Пометка Тогда
Если (Инв.Количество <> 0) или (Инв.Количество10 <> 0) Тогда
НоваяСтрокаДокумента = НовыйДокументРеализация.Товары.Добавить();
НоваяСтрокаДокумента.Номенклатура = Инв.Номенклатура;
НоваяСтрокаДокумента.Количество = ?(ЗначениеЗаполнено(Инв.Количество10),Инв.Количест во10,Инв.Количество);
НоваяСтрокаДокумента.Сумма = ?(ЗначениеЗаполнено(Инв.Сумма10),Инв.Сумма10,Инв.С умма);
НоваяСтрокаДокумента.Цена = ?(НоваяСтрокаДокумента.Количество <> 0,НоваяСтрокаДокумента.Сумма/НоваяСтрокаДокумента.Количество,0);
НоваяСтрокаДокумента.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
ОбработкаТабличныхЧастейКлиентСервер.РассчитатьСум муНДСТабЧасти(НоваяСтрокаДокумента, НовыйДокументРеализация.СуммаВключаетНДС, Ложь);
КонецЕсли;
КонецЕсли;
КонецЦикла;

ЗначениеВДанныеФормы(НовыйДокументРеализация,ОперД анные);
КонецПроцедуры


как мне после заполнения табличной части документа выполнить пересчет табличной части процедурами самого документа?





К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены