К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

v8.2 При использовании Менеджера документа выдается ошибка :Метод объекта не обнаружен

Гость
0 - 02.09.2012 - 12:25
Здравствуйте.
В менеджере документа "ПоступлениеТоваров" создана функция:
&НаСервереБезКонтекста
Функция ПолучитьНезаполненныеДокументы()Экспорт
Выборка=Выбрать();
Массив=Новый Массив;
Пока Выборка.Следующий() Цикл
Если Выборка.Контрагент.Пустая() Тогда
Массив.Добавить(Выборка.Ссылка);
КонецЕсли;
КонецЦикла;
Возврат Массив;

КонецФункции // ПолучитьНезаполненныеДокументы()

Для вызова функции "ПолучитьНезаполненныеДокументы()" создана обработка в которой по кнопке вызывается данная функция. Для вызова созданы процедуры:

&НаКлиенте
Процедура СписокНезаполненныхДокументов(Команда)
СписокНезаполненныхДокументовНаСервере()
КонецПроцедуры

и
&НаСервере
Процедура СписокНезаполненныхДокументовНаСервере()
Список=Документы.ПоступлениеТоваров.ПолучитьНезапо лненныеДокументы();
Для Счетчик = 0 По Список.ВГраница() Цикл
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = Строка(Список.Получить(Счетчик));
Сообщение.Сообщить();
КонецЦикла;

КонецПроцедуры // СписокНезапоненныхДокументовНаСервере()()

Подскажите,пожалуйста, почему при выполнении обработки выдается ошибка: Метод объекта не обнаружен(ПолучитьНезаполненныеДокументы)?



Гость
1 - 02.09.2012 - 15:11
Зачем в модуле менеджера прикладного объекта использовать директивы компиляции?
Гость
2 - 02.09.2012 - 18:39
добавлю к камраду Reaper(раз автор сам не догнал) - в этих модулях всегда на сервере....
Гость
3 - 02.09.2012 - 21:30
Спасибо большое,думал масло масленное.Убрал-все пошло.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены