К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Услуги сторонней организации

0 - 09.02.2012 - 16:02
После обновления на релиз 535, в документе услуги сторонней организации в графе счет-фактура пропали данные, а при попытке ввести данные и провести программа не видит данных в этом поле и не проводит документ, предлагая либо занести данные либо убрать галку по счет-фактуре. Что может тут быть, как побороть?

В других документах все нормально, проблема только с документом услуги сторонней организации.



1 - 09.02.2012 - 16:09
Конфа Бухгалтерия, релиз 535. До обновления все было нормально.
Uho
2 - 09.02.2012 - 16:10
О сколько нам открытий чудных готовят дятлы 1С...
3 - 09.02.2012 - 16:29
3-Uho > т.е. с модуля формы надо удалить полностью текст кода процедуры ПриПредъявленииСчетаФактуры()
и вместо нее вставить этот код?

/////
Процедура Показать_()
Если Показать=1 Тогда
Форма.ДатаНомерСчетаФактуры.Видимость(1);
Форма.ДатаСчетаФактуры.Видимость(0);
Форма.НомерСчетаФактуры.Видимость(0);
Иначе
Форма.ДатаНомерСчетаФактуры.Видимость(0);
Форма.ДатаСчетаФактуры.Видимость(1);
Форма.НомерСчетаФактуры.Видимость(1);
КонецЕсли;
КонецПроцедуры

/////

Процедура ПриПредъявленииСчетаФактуры()
Если Выбран()=1 Тогда
Если ((ПустаяСтрока(ДатаНомерСчетаФактуры)=1) и (ПустоеЗначение(ДатаСчетаФактуры)+ПустаяСтрока(Ном ерСчетаФактуры) > 0)) Тогда
СчетФактураПредъявлен = 0;
Если (ДатаДок<Константа.НачалоПримененияИсправленныхСче товФактур) и (ПустаяСтрока(ДатаНомерСчетаФактуры)=0) Тогда //Старая форма
Показать=1;//Показать Старую Форму
Показать_();
ИначеЕсли (ДатаДок>=Константа.НачалоПримененияИсправленныхСч етовФактур) и (ПустоеЗначение(ДатаСчетаФактуры)+ПустаяСтрока(Ном ерСчетаФактуры) = 0) Тогда //Новая форма
Показать=0;//Показать Новую Форму
Показать_();
КонецЕсли;
ИначеЕсли (ДатаДок<Константа.НачалоПримененияИсправленныхСче товФактур) и (ПустаяСтрока(ДатаНомерСчетаФактуры)=0) Тогда //Старая форма
СчетФактураПредъявлен = 1;
Показать=1;//Показать Старую Форму
Показать_();
ИначеЕсли (ДатаДок>=Константа.НачалоПримененияИсправленныхСч етовФактур) и (ПустоеЗначение(ДатаСчетаФактуры)+ПустаяСтрока(Ном ерСчетаФактуры) = 0) Тогда //Новая форма
СчетФактураПредъявлен = 1;
Показать=0;//Показать Новую Форму
Показать_();
КонецЕсли;
Иначе
СчетФактураПредъявлен = 0;
Если (ДатаДок<Константа.НачалоПримененияИсправленныхСче товФактур) и (ПустаяСтрока(ДатаНомерСчетаФактуры)=0) Тогда //Старая форма
Показать=1;//Показать Старую Форму
Показать_();
ИначеЕсли (ДатаДок>=Константа.НачалоПримененияИсправленныхСч етовФактур) и (ПустоеЗначение(ДатаСчетаФактуры)+ПустаяСтрока(Ном ерСчетаФактуры) = 0) Тогда //Новая форма
Показать=0;//Показать Новую Форму
Показать_();
КонецЕсли;
КонецЕсли;
/////


Все верно?
4 - 09.02.2012 - 16:46
А в 536-м релизе исправили ?
5 - 09.02.2012 - 16:52
5-Плюшкин >Исправили.
6 - 09.02.2012 - 16:53
Не знал что есть уже 536. нашел читаю:
Документ УслугиСтороннихОрганизаций ("Услуги сторонних
организаций")
----------------------------------------------------------------
Исправлена ошибка:
При открытии документа, если в нем указаны номер и дата
счета-фактуры, то эти реквизиты ошибочно не были доступны для
редактирования.

Внесены изменения в модуль формы документа.
Внесены изменения в диалог формы документа.

значит поправили получается.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены