К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Управляемые формы в УТ 10

Гость
0 - 03.05.2012 - 06:38
Настраиваю тонкого клиента в УТ 10. Столкнулся с проблемой, что не могу вызвать функции находящиеся в модуле документа. В частности, делаю команду документа АктСверкиВзаиморасчетов "Печать". Там примено такой код:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
ТабДокумент = ПолучитьТабДокументНаСервере(ПараметрКоманды);
КонецПроцедуры

&НаСервере
Функция ПолучитьТабДокументНаСервере(ДокументСсылка)
ДокументОбъект = ДокументСсылка.ПолучитьОбъект();
Возврат ДокументОбъект.ПечатьАктаСверки();
КонецФункции

Выдает ошибку. Говорит метод объекта не обнаружен. Не хотелось бы дублировать уже написанную функцию из модуля документа в модуль менеджера



Гость
1 - 03.05.2012 - 11:28
Посмотри на конструкцию, в которую заключена функция ПечатьАктаСверки в модуле документа. Скорее всего, это что вроде
#Если Клиент Тогда
#КонецЕсли
Исходя из этого можно сделать вывод, что на сервере указанная функция не существует вообще ни разу.
Гость
2 - 03.05.2012 - 11:40
Да, именно так. Спасибо. Посоветуете вынести функцию из этой конструкции? Не отразиться ли это потом на работе функции в обычном приложении?
Гость
3 - 03.05.2012 - 11:46
Впрочем, это я уже смогу проверить. Позже сообщу.
Гость
4 - 03.05.2012 - 13:12
(2) Попробуй прогнать синтаксис-контроль серверный. Если не заругается - все тип-топ.
Малоли какие там конструкции вроде "Вопрос" или "Предупреждение" выполнялись.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены