К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

УниверсальныйОбменДаннымиВФорматеXML.epf

Гость
0 - 12.07.2013 - 09:39
Почему если я в процедуре ПослеЗагрузки, размещаю код:

Для каждого СтрокаТЧ из Объект.Товары Цикл
Объект.ЗаполнитьСчетаУчетаВСтрокеТабЧасти(СтрокаТЧ , "Товары", Истина);
КонецЦикла;

...при загрузке выдается код ошибки, -

Ошибка формата обмена

добавляю в ПослеЗагрузки в конвертации данных этот кусок кода, после сохранения и перегрузке, при загрузке выдается эта ошибка, - Ошибка формата обмен

если этот кусок кода закоментировать, то при перезагрузке ошибки нет, то есть дело только в нем

в БП в модуле объекта документа РеализацияТоваровУслуг есть процедура, -

// Заполняет счета в строке табличной части

//

Процедура ЗаполнитьСчетаУчетаВСтрокеТабЧасти(СтрокаТЧ, ИмяТабЧасти, Заполнять) Экспорт

СчетаУчета = БухгалтерскийУчет.ПолучитьСчетаУчетаНоменклатуры(О рганизация, СтрокаТЧ.Номенклатура, Склад);
//СчетаРозницы = (Склад.ВидСклада = Перечисления.ВидыСкладов.Розничный);

ЭтоКомиссия = (ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионе ром);
МетаданныеДока = Метаданные();

ЗаполнитьСчета(СтрокаТЧ, ИмяТабЧасти, СчетаУчета, Заполнять, ЭтоКомиссия, МетаданныеДока);

КонецПроцедуры // ЗаполнитьСчетаУчетаВСтрокеТабЧасти()



Гость
1 - 12.07.2013 - 20:45
Осторожно спросю: тема про конфигурацию "Конвертация", или как она там?
Гость
2 - 12.07.2013 - 21:48
Версии конфигурации и обработки обмена в студию
Гость
3 - 16.07.2013 - 06:51
(1) Это тема про правила обмена в которых почему то при перегрузке в загруженных документах реализация товаров услуг отсутствуют счета в табличной части.
Правлю правила, да, загрузив их в конфигурацию конвертация данных!

(2) УТ 10.3, БП 2.0.38.6
УТ 10-3-12-3 - Бух 2-0-38-6
4 - 16.07.2013 - 07:59
В ПКО после загрузки:
Объект.ЗаполнитьСчетаУчетаВТабЧасти(Объект.Товары, "Товары", Объект.ОтражатьВБухгалтерскомУчете, Объект.ОтражатьВНалоговомУчете);

т.е. без перебора табличной части. Код выдран из обмена УТ - УПП. В БП будет аналогично
Гость
5 - 16.07.2013 - 09:46
(4) спасибо!
Гость
6 - 19.07.2013 - 06:52
(4) ПРИ ЗАГРУЗКЕ ВЫЛЕТАЕТ ОШИБКА

ОписаниеОшибки = Поле объекта не обнаружено (ОтражатьВБухгалтерскомУчете)
7 - 19.07.2013 - 06:54
В бухгалтерии надо настроить регистр сведений Счета учета номенклатуры.
Гость
8 - 19.07.2013 - 07:17
вот, вот это прописывает счета:

КоличествоСтрок = Объект.Товары.Количество();
Для НомерСтроки = 0 по КоличествоСтрок-1 цикл
СтрокаТЧ = Объект.Товары.Получить(НомерСтроки);

//Объект.ЗаполнитьСчетаУчетаВСтрокеТабЧасти(СтрокаТЧ , "Товары", Истина);

СтрокаТЧ.СчетУчета = ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;
СтрокаТЧ.СчетДоходов = ПланыСчетов.Хозрасчетный.ВыручкаНеЕНВД;
СтрокаТЧ.СчетРасходов = ПланыСчетов.Хозрасчетный.СебестоимостьПродажНеЕНВД ;
СтрокаТЧ.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.Продажи_НДС;
СтрокаТЧ.Себестоимость = СтрокаТЧ.Сумма - СтрокаТЧ.СуммаНДС;

//Если Не ЗначениеЗаполнено(СтрокаТЧ.Субконто) тогда
// СтрокаТЧ.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоКоду("0000 00002");
//КонецЕсли;
КонецЦикла;


но не прописывается субконто!!!
Гость
9 - 19.07.2013 - 07:57
Объект.СчетУчетаРасчетовПоАвансам = ПланыСчетов.Хозрасчетный.РасчетыСПокупателями;
Объект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.РасчетыСПокупателями;
Объект.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически;

КоличествоСтрок = Объект.Товары.Количество();
Для НомерСтроки = 0 по КоличествоСтрок-1 цикл
СтрокаТЧ = Объект.Товары.Получить(НомерСтроки);
СтрокаТЧ.СчетУчета = ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;
СтрокаТЧ.СчетДоходов = ПланыСчетов.Хозрасчетный.ВыручкаНеЕНВД;
СтрокаТЧ.СчетРасходов = ПланыСчетов.Хозрасчетный.СебестоимостьПродажНеЕНВД ;
СтрокаТЧ.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.Продажи_НДС;
СтрокаТЧ.Себестоимость = СтрокаТЧ.Сумма - СтрокаТЧ.СуммаНДС;
Если Не ЗначениеЗаполнено(СтрокаТЧ.Субконто) тогда
//СтрокаТЧ.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоКоду("0000 00002");
СтрокаТЧ.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименован ию("Товар");
КонецЕсли;
КонецЦикла;


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены