К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Удаление строки в табличной части

Гость
0 - 28.12.2012 - 08:54
как отменить интерактивный ввод строки, если пользователь пытается ввести дублирующую строку.


101
1 - 28.12.2012 - 09:17
хде ?
2 - 28.12.2012 - 09:46
самый простой способ - взять в руки дубину и дать юзеру по башке

Зверский способ - затирай цену/количество/сумму - пусть юзер сам и удаляет. С пустыми колонками док не должен проводиться.
3 - 28.12.2012 - 10:25
2(0) в 77 или 8х?
4 - 28.12.2012 - 10:27
2(2) первым устанет человек с дубиной...
Гость
5 - 28.12.2012 - 10:38
0-Pusto > А нахрена? Пусть вводит. При этом, как ты собираешься отследить "попытку"? Читать мыслю, не?

Не надо плодить сущности. Есть процедуры перед записью. Там и сообщить про дубли номенклатуры. Лучше всего прекращать проверку при первой обнаруженной паре. А потом снова проверять при записи. И снова, и снова. Пока в тупую башку не укоренится шаблон поведения.
101
6 - 28.12.2012 - 11:10
выгружать наф сворачивать и загружать наф
Гость
7 - 28.12.2012 - 11:18
6-101 > Не, это портить другие строки. И вообще, противоречие максимы не отменять команды человека. Вводит запрещенное - пусть сам и отменяет запрещенное. До посинения.
101
8 - 28.12.2012 - 11:53
(7) Оо как это портить ? все нормально с точки зрения математики ;)) сколько строк такой и ассортимент а цены/суммы/округления это уже часности :)
9 - 28.12.2012 - 12:40
(3) в любой программе - пусть юзер сам стучит себе по башке. Я не гадалка
Гость
10 - 28.12.2012 - 13:57
3) 8.2


дело в том, что у юзера за день очень большой продажа, документооборот соответственно. Поэтому такие случайные ошибки неисключение.

Процедура ПриОкончанииРедактирования(НоваяСтрока, ОтменаРедактирования)
Если ОтменаРедактирования = Истина Тогда
Предупреждение("Данная вносимая позиция уже есть в базе"+Символы.ПС+"Будьте внимательны....");
Возврат;
КонецЕсли;
КонецПроцедуры


Процедура ТоварыНоменклатураОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

//Для того чтобы не было задвоений при выборе, наложим условие
Если Товары.НайтиСтроки(Новый Структура("Номенклатура", ВыбранноеЗначение)).Количество() = 0 Тогда
НоваяСтрока = Товары.Добавить();
НоваяСтрока.Номенклатура = ВыбранноеЗначение;
Иначе
ПриОкончанииРедактирования(НоваяСтрока, Истина);
КонецЕсли;

КонецПроцедуры

Нужно сделать так, чтобы юзер не мог выйти из этой строки пока либо не отменить добавление, либо внесет номенклатуру правильно.
11 - 28.12.2012 - 13:59
2(10) Он добавляет строку через подбор или вручную?
Гость
12 - 28.12.2012 - 14:09
1. ПередЗаписью при проведении не давать проводить, если есть дубли. Сообщить номера строк с дублями.
2. Свернуть при проведении строки с одинаковыми параметрами без лишних вопросов.
А так пусть сидят и долбят, нефик их с толку сбивать.
Гость
13 - 28.12.2012 - 14:32
11. вручную
14 - 28.12.2012 - 15:26
2(13) Так повесь проверку в процедуру вызываемую при событии "При окончании редактирования строки" табличной части.
Гость
15 - 29.12.2012 - 00:37
Цитата:
Сообщение от Pusto Посмотреть сообщение
дело в том, что у юзера за день очень большой продажа, документооборот соответственно.
Нарушаешь закон 185-ФЗ от 12.11.12 г.

Цитата:
Сообщение от Pusto Посмотреть сообщение
Поэтому такие случайные ошибки неисключение
Бред. Если человек оформляет продажи общаясь с живыми людьми - ничто не мешает на последнем шаге оформления продажи проверить дубли. Описанное бычье дерьмо возникает, когда люди тупо долбят информацию с бумажек или файлов. Если нет толкового 1Сника для организации автоматической загрузки этих данных - решается:
1 человеком владеющим слепой печатью
2-мя недочеловеками, владеющими двухпальцевой печатью.
16 - 29.12.2012 - 00:44
Цитата:
Сообщение от Reaper Посмотреть сообщение
Описанное бычье дерьмо возникает, когда люди тупо долбят информацию с бумажек или файлов. Если нет толкового 1Сника для организации автоматической загрузки этих данных - решается:
У нас часто менеджерам приходится забивать номенклатуру прямо с чертежа. Клиент присылает схему или эскиз (по факсу) и требуется составить спецификацию на состав с расценками. Вот менеджер и елозит по рулону бумаги, находя детали из каталога, опознавая их параметры и иногда для скорости их сразу вносят в заказ покупателя в 1С, а на чертеже помечая уже внесенное крестиками. Разумеется, потом дубли просто сворачиваем.
Гость
17 - 29.12.2012 - 00:49
16-bma1 > Чертеж не тупая таблица. Там в разных частях могут быть один и те же болты с гайками - повторение это нормально. А у ТС то именно "тащить и не пущать!".


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены