К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

ТИС с подключенным ФР Атол 55Ф

0 - 19.06.2017 - 12:11
Добрый день уважаемые форумчане:)
Появилась следующая проблемка: настроил печать через на ФР. Но нужно чтобы чеки по розничной продаже (ЕНВД) фиксировались в 1 секцию, а услуги (УСН) во вторую секцию?
быстро погуглил - что-то не попалось информации. единственное, что вроде как в настройках склада есть секции - установил разхные секции. провел реализацию и реализацию (розница). сформировал 2 приходника. распечатал кассовые чеки - в итоге при гашении ккм разбиения сумм выручки по секциям не увидел.
ТИС 988 релиз.



1 - 20.06.2017 - 08:30
немного откорректировать FRATOL54FZ_comm и процедуру печати чека в ПКО - и все проблема решена.
2 - 22.06.2017 - 20:17
В Z-отчете и не будет разбиения выручки по секциям.
Включи через драйвер Расширенный Z-отчет.
3 - 23.06.2017 - 09:51
У клиента и x-отчет по кассирам почему то пустой выводится
4 - 23.06.2017 - 11:17
(3)X-отчет в данной компоненте не удалось заставить работать :-) Как вариант, промежуточный итог смотреть в личном кабинете провайдера ОФД
Еще ходят слухи, компонента для 1С из дистрибутива поставки кассы не работает с ОФД, но х-отчет сделать позволяет.
5 - 23.06.2017 - 11:20
(4)личный кабинет это прекрасно, но с ним и кассой может быть реальная нестыковка
6 - 23.06.2017 - 11:48
Цитата:
Сообщение от Sasha Посмотреть сообщение
(3)X-отчет в данной компоненте не удалось заставить работать :-)
Для X-отчета надо дописать ert, там нет команды на снятие отчета без гашения
Функция СнятьXОтчет(Объект)
Рез = 0;
Если ПустоеЗначение(Объект) = 1 Тогда
ОписаниеРезультата = "устройство не подключено";
ИначеЕсли ПодключитьсяКФР(Объект) = 1 Тогда
// переключение в режим снятия отчета (нужен пароль администратора)
РезультатККМ54XОтчет = Объект.НапечататьОтчетБезГашения(глФРИДУстройства) ;
ОписаниеПоследнейОшибки = "";
КодПоследнейОшибки = Объект.GetLastError(ОписаниеПоследнейОшибки);
Если СокрЛП(ОписаниеПоследнейОшибки) = "Ошибок нет" Тогда
Иначе
ОписаниеРезультата = ОписаниеПоследнейОшибки;
КонецЕсли;
Рез = ОтключитьсяОтФР(Объект);
КонецЕсли;
Возврат Рез;
КонецФункции
7 - 23.06.2017 - 11:49
Ну и плюс команду на снятие X-отчета в самой конфигурации
8 - 23.06.2017 - 11:53
Процедура XОтчет()

Если глФРВкл = 1 Тогда
Параметры = СоздатьОбъект("СписокЗначений");
Параметры.Установить("Процесс", "снять_X-отчет");
Параметры.Установить("Объект" , глФР);
РезТекст = глОборудованиеКоманда("ФР", глФРОбработка, Параметры);
Если ПустоеЗначение(РезТекст)=0 Тогда
Сообщить(РезТекст);
ИначеЕсли Параметры.Получить("Результат")=0 Тогда
Сообщить("Фискальный регистратор: ошибка при снятии X-отчета:");
Сообщить(Параметры.Получить("ОписаниеРезультата")) ;
КонецЕсли;
Иначе
Сообщить("ККМ не подключена");
КонецЕсли;
КонецПроцедуры
9 - 23.06.2017 - 12:11
все не осилил, например Параметры.Установить("Процесс", "снять_X-отчет"), но все делаю по науке, перевожу в нужный режим, задаю нужный номер отчета,но отчет пустой
это из 1с. Но он и из драйвера пустой. Речь про X отчет по кассирам
10 - 23.06.2017 - 15:25
Да, еще в frATOL54_comm.ert в ПриОткрытии() добавить
...
ИначеЕсли Процесс = "снять_x-отчет" Тогда
Объект = Парам.Получить("Объект");
Рез = СнятьXОтчет(Объект);
...
11 - 23.06.2017 - 15:26
Цитата:
Сообщение от USSR Посмотреть сообщение
Речь про X отчет по кассирам
Так X-отчет нужен или по кассирам ? Это разные отчеты.
12 - 23.06.2017 - 15:37
(11)X-отчет по кассирам. Отчет без гашения, номер по моему 7
13 - 23.06.2017 - 15:50
Вот это ?
14 - 23.06.2017 - 15:56
Напечатать X-отчет средствами FprnM1C82_54FZ.dll можно - через Объект.НапечататьОтчетБезГашения().
Можно ли напечатать отчет по номеру через эту компоненту - не знаю.
Если делаешь 8-Отчет по кассирам через драйвер ККМ и отчет пустой, то может быть просто смена не открыта или продаж не было ?
15 - 23.06.2017 - 16:07
Это, это, только драйвер используется не FprnM1C82_54FZ.dll , а из 8-ой бесплатной версии Атолла. Не знаю почему у 1С драйвер - FprnM1C82_54FZ.dll. Продажи есть. При закрытии смены сначала делается отчет по кассирам, потом z-отчет. Так вот отчет по кассирам выходит пустым, а z-отчет верным
16 - 23.06.2017 - 16:56
Драйвер ККМ и есть из АТОЛ ДТО v8.
А FprnM1C82_54FZ.dll - компонента для работы 1С с драйвером. Она входит в состав ДТО (или типовых конф 1С), но лучше брать из ДТО 8.14 (более правильная версия dll).
Точно снимаешь 8-Отчет по кассирам ?
Попробовал, у меня не пустой.
17 - 23.06.2017 - 17:45
Компонента у меня испольуется не из типовой, а FprnM1C.DLL. Обработка обслуживания - переделана из подаренной Victuan. Я встроил печать отчета в закрытие смены перед выдачей z-отчета. Все работает, кроме печати отчета по кассирам. Я сам там в офисе не был, но клиент печатал и непосредственно из драйвера Атолла, результат тот же
18 - 23.06.2017 - 17:49
Странно как-то. Хорошо было бы посмотреть сканы идущих подряд - чека продажи, Отчета по кассирам, X-отчета, Z-отчета.
Версия ДТО АТОЛ ?
Версия прошивки ККМ ?
19 - 23.06.2017 - 17:57
dto 8.14.0.0
Версию прошивки не знаю, в понедельник узнаю и сканы попрошу. Чеки идут нормально и все видны в личном кабинете
20 - 02.05.2018 - 19:04
6-mr Gilmor >EQUIP\FRATOL54_COMM_105.ERT(268)**: Поле агрегатного объекта не обнаружено (НапечататьОтчетБезГашения)

стоит последняя FprnM1C82_54FZ.dll
21 - 02.05.2018 - 19:07
РезультатККМ54XОтчет = Объект.НапечататьОтчетБезГашения(глФРИДУстройства) ;
22 - 05.05.2018 - 04:46
21-Капуста >Какая версия ДТО?
23 - 06.05.2018 - 16:04
22-victuan >8.16.2, 9.12 тоже стоит, как
9 как подключить к Тис? Подставляю длл, не подключается.
24 - 06.05.2018 - 16:05
fptrwin32_fz54_9_12_1_6236.dll это штука с 7-кой вообще работает?
25 - 07.05.2018 - 04:22
24-Капуста >Драйвер ККТ версии 8.16.2 Атол отозвал - видимо в нем ошибки.
Крайняя версия ККТ 8.16.1 - она стабильно работает с FprnM1C.dll, а не с FprnM1C82_54FZ.dll, хотя и есть некоторые глюки по сравнению с ККТ 8.15.3


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены