К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Терминал сбора данных в терминале

Гость
0 - 23.02.2012 - 17:43
Добрый день, уважаемые гуру!!
Возникла такая проблемма. Подключил терминал сбора даных через rpd (клиент через vpn цепляется к серваку, потом через терминал работает, обмен с ТСД через dcom), так вот, проблема =) на компе с ТСД все норм, а на остальных терминальных клиентах - вылазиет ошибка
MobileLogistics 4.x: Ошибка при подключении устройства.
Необходимо убедиться, что устройство правильно настроено и соответствующий порт не занят другим приложением.

10048 Only one usage of each socket address (protocol/network address/port) is normally permitted [bind()] Дескриптор: 456
Произошла ошибка при подключении торгового оборудования

можно ее убрать?
1C 8.2.15.289
Комплексная автоматищация 1.1.18.1
в 1ске тупс.. =((

Зарание спасибо!!



Гость
1 - 23.02.2012 - 18:15
можно убрать предварительно купив драйвер терминала сбора многопользовательский и добавив в нем несколько устройств
Гость
2 - 23.02.2012 - 18:19
не, соврал таместь поле такое компьютер та мнадо указать к какомукомпьютеру в сети он физ подключен драйвер долженбыть установлен и на локальной машине а по поводу покупки мноопользовательской версии ...модель терминала какая
3 - 23.02.2012 - 19:03
Главная проблема подключения торг.оборудования к 1С, запускаемой в терминальном режиме, заключается в том, что фирма 1С напрочь игнорирует наличие этого самого терминального режима. И заключается это в том, что в регистр сведений, хранящем сведения о подключенном оборудовании, записывается имя компьютера, к которому подключено оборудование, с помощью метода - ИмяКомпьютера().
В терминальном режиме этот метод вернёт имя сервера. И, при последующих запусках, под любым пользователем в терминале 1С будет пытаться подключить это торговое оборудование.
Но так как оборудование подключено только к одному клиенту, то только у него не будет возникать ошибка подключения, у всех остальных ошибка возникнет.
Проблема решается очень просто. Надо при запуске программы сообщать ей не имя компьютера, а имя компьютера клиента.
На примере УТ 10.3:

Функция ПолучитьИмяКомпьютераТО() Экспорт

//Изменения Billi
//Было:
//Если мИмяКомпьютера = Неопределено Тогда
// мИмяКомпьютера = ВРег(ИмяКомпьютера());
//КонецЕсли;
//Стало:
objScript = Новый COMObject("WScript.Shell");
objEnvironment = objScript.Environment("PROCESS");
ИмяКлиента=ВРег(objEnvironment.item("CLIENTNAME")) ;
Если ИмяКлиента="CONSOLE" Тогда
мИмяКомпьютера = ВРег(ИмяКомпьютера());
Иначе
мИмяКомпьютера = ИмяКлиента;
КонецЕсли;
//Конец изменений

Возврат мИмяКомпьютера;

КонецФункции // ПолучитьИмяКомпьютераТО()
Гость
4 - 23.02.2012 - 20:38
4-Billi >я все на какихто самописках больше не буду спорить у меня 8 тсд сайфер врозн магазиназ через терминальное с многопользовательским от атола мобалй логистик тож от него, ягвоорю щаспро драйвер (про ка не знаю) просто атол щасоптиконы толкает там драйвер считает что еслиоптикон уних покупался то он работает врабочем режиме поетомудлябюдэетных тсд (оптикон) достаточно норм драйвер насроить
Гость
5 - 23.02.2012 - 21:48
насчет разрещов ошибку признал все както получалось кто с разрезами работает покупают фронтол отсюда и косяк (
Гость
6 - 24.02.2012 - 14:40
Billi - спасибо огромное !!
Поковыряю седня вечером =)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены