К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Табличный документ, ввод данных. УФ

Гость
0 - 07.05.2015 - 12:30
Платформа 8.3, управляемые формы, база своя.
Задача: есть шаблон документа, в котором необходимо по ходу пьесы выбирать/заполнять значения в нужных местах.
Хочу сделать табличным документом (если получится). Создала документ, табличное поле на форме разместила, таблица заполняется из макета документа.
В макете у нужной ячейки установила свойства «содержит значение»=истина, «тип значения»=булево, «элемент управления»=флажок.
При запуске никакого флажка нет. Как его отобразить?



1 - 07.05.2015 - 12:41
А в режиме редактирования значения элемент управления есть?
Гость
2 - 07.05.2015 - 12:47
1-roma n > щелкаю на ячейке 2 раза, жму F4 ничего не появляется (. если Вы про это.
Гость
3 - 07.05.2015 - 12:51
&НаСервере
Функция ЧтениеТабличногоДокумента()
Таблица = Документы.Документ3.ПолучитьМакет("Макет");
Таблица.Защита = Ложь;
возврат Таблица;
КонецФункции

&НаКлиенте
Процедура ЗаполнитьТаблицу(Команда)
Таблица=ЧтениеТабличногоДокумента();
КонецПроцедуры

&НаКлиенте
Процедура ТаблицаВыбор(Элемент, Область, СтандартнаяОбработка)
Если Область.Имя="R1C5" тогда
СтандартнаяОбработка = Ложь;
Список = Новый СписокЗначений;
Список.Добавить("Мягкий");
Список.Добавить("Твердый");
Область.Текст = ВыбратьИзСписка(Список, Элемент);
КонецЕсли;

Если Область.Имя="R1C1" тогда
СтандартнаяОбработка = Ложь;
ДанныеВыбора = ВыборкаДанных();
ЭлСправочника=ВыбратьИзСписка(ДанныеВыбора, Элемент);
Область.Текст = ЭлСправочника;
КонецЕсли;
КонецПроцедуры


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены