К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Таблица значений в файл

Гость
0 - 27.10.2015 - 09:49
Здравствуйте!

Пытаюсь из реквизита обработки ТЗ1 (таблица значений) выгрузить данные в файл:

&НаСервере
Процедура КопируемВФайлНаСервере(ТЗ1)

ТЗвФайл=РеквизитФормыВЗначение(ТЗ1);
ЗначениеВФайл("C:\tz.dat",ТЗвФайл);

КонецПроцедуры

&НаКлиенте
Процедура КопируемВФайл(Команда)

КопируемВФайлНаСервере(ТЗ1);

КонецПроцедуры


Ругается:

Ошибка при вызове метода контекста (РеквизитФормыВЗначение)
ТЗвФайл=РеквизитФормыВЗначение(ТЗ1);
по причине:
Несоответствие типов (параметр номер '1')
Несоответствие типов (параметр номер '1')

Как сделать правильно?
Спасибо.



Гость
1 - 27.10.2015 - 09:57
а просто
&НаСервере
Процедура КопируемВФайлНаСервере()

ТЗвФайл=ТЗ1.выгрузить();
ЗначениеВФайл("C:\tz.dat",ТЗвФайл);

КонецПроцедуры

не сработает?
2 - 27.10.2015 - 12:17
Из СП

РеквизитФормыВЗначение(<ИмяРеквизита>, <Тип>)
Параметры:

<ИмяРеквизита> (обязательный)

Тип: Строка.
Имя реквизита формы, который необходимо преобразовать.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены