К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

СвязиПараметровВыбора в табличной части не срабатывает в первый раз

Гость
0 - 09.11.2014 - 09:24
1С:Предприятие 8.2 (8.2.19.90), управляемая форма.
Табличная часть: Клиенты. Колонка: Субконто.
Колонка имеет составной тип данных, поэтому связь установить в конфигураторе нельзя.

Код:
&НаКлиенте
Процедура КлиентыСубконтоНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтрокаТабличнойЧасти = Элементы.Клиенты.ТекущиеДанные;
...
КлиентыУстановитьВладельца();
ИначеЕсли СтрокаТабличнойЧасти.Тип = ПредопределенноеЗначение("Перечисление.ТипыСтрокиВ ыписки.Сч50") Тогда
СтандартнаяОбработка = Ложь;
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура КлиентыУстановитьВладельца()
НовыйМассив = Новый Массив;
НовыйМассив.Добавить(Новый СвязьПараметраВыбора("Отбор.Владелец", "КлиентФирмы", РежимИзмененияСвязанногоЗначения.Очищать));
Элементы.КлиентыСубконто.СвязиПараметровВыбора = Новый ФиксированныйМассив(НовыйМассив);
КонецПроцедуры

Проблема:
Если открывать в первый раз - то открывает без Владельца. Если закрыть и открывать потом - то все нормально.



Гость
1 - 11.11.2014 - 16:50
никому не по зубам вопрос ?
неужели никто не делал подчинение программно в табличной части ?
Гость
2 - 13.11.2014 - 07:25
Подниму вопрос, все так же актуален.
Гость
3 - 20.11.2014 - 09:26
Еще раз подниму вопрос.
Гость
4 - 20.11.2014 - 11:39
Интересно, а за неделю правда ни разу не пришла в голову мысль открыть БП 3.0 и посмотреть, как это реализовано там?


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены