К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

SQL: сторонний сервер SQL Ошибка безопасности SSL

bvb
0 - 23.10.2018 - 18:55
Работаю на терминальном сервере .
БАЗА на сервере 1С предприятия крутится на другом сервере
Обращаюсь к третьему серверу SQL (не 1С) для прямого SQL запроса
Все работало много лет

Счас при попытке соединения пишет :
Произошла исключительная ситуация (Microsoft OLE DB Provider for SQL Server): [DBNETLIB][ConnectionOpen (SECCreateCredentials()).]Ошибка безопасности SSL.

Где ошибка ?
На сервере SQL где сервер 1С Предприятия или на сервере к которому делается запрос ?

что делать ?
Перезагружате сервак SQL ?

Коннекчусь к SQL вот так :


eXsocet = Новый COMОбъект ("ADODB.Connection");
eXrowset = Новый COMОбъект("ADODB.Recordset");


eXsocet.Open(ConnectionString(Server,NameDatabase, UserID,Password));
eXrowset.ActiveConnection = eXsocet;

eXrowset.Open(СокрЛП(SqlQuery));


Функция ConnectionString(Server,NameDatabase,UserID = 0,Password = 0) Экспорт
Перем ConnectionString;

ConnectionString ="Provider=SQLOLEDB.1;Persist Security Info=False;";
ConnectionString = ConnectionString + "Initial Catalog="+СокрЛП(NameDatabase)+";Data Source="+СокрЛП(Server)+";";
Если ПустаяСтрока(UserID) <> 1 Тогда
ConnectionString = ConnectionString + "User ID="+СокрЛП(UserID)+";";
Иначе
ConnectionString = ConnectionString + "Integrated Security=SSPI;";
КонецЕсли;
Если ПустаяСтрока(Password) <> 1 Тогда
ConnectionString = ConnectionString + "Password="+СокрЛП(Password)+";";
КонецЕсли;

Возврат ConnectionString;
КонецФункции//ConnectionString



1 - 23.10.2018 - 19:11
Если возникает ошибка вида [DBNETLIB][ConnectionOpen (SECCreateCredentials()).]SSL Security error при обращении к MSSQL серверу, то решение следующее:
Необходимо установить значение Enable параметру групповой политики безопасности
Local Security Policy —> Local Policies —> Security Options —> ‘System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing

Затем от имени администратора выполнить в командной строке:
gpupdate /force
2 - 24.10.2018 - 09:37
Пытаешься организовать SSL соединение, а доверия сертификатам нет. ИМХО.
"Почему вдруг SSL", скорее всего, в 1)
bvb
3 - 24.10.2018 - 13:06
(1) Это нужно проделать на сервере SQL к которому идет обращение ?
4 - 24.10.2018 - 17:01
(3) Да


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены