К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Коронавирус Кубани
Рекомендовать в новости

Слетел GUID в при синхронизации доков УТ 10.3 и БУХ 3.0

0 - 22.06.2020 - 09:53
1.Две базы УТ 10.3 и БУХ 3.0
2.Обмен писанный , но синхронизация/присвоение новому осуществляется через GUID.
3.Обмен односторонний.
4.Все было нормально последние пол года.
5.Вчера, начал перезаливать уже залитый период
при сохрании документов начала вылетать ошибка:
документ с таким номером существует. Начал анализ GUID
залитого дока неделю назад и того же самого , которым
пытался перезалить имеют разный GUID.

Могут ли такие приколы происходить сами по себе? Если нет каковы причины.? Методы решения??? Заранее всем спасибо!!



1 - 22.06.2020 - 11:17
само такое не бывает
2 - 22.06.2020 - 11:27
Архивы есть ? гуид где изменился ? в залитой базе или базе откуда заливаешь ?
3 - 22.06.2020 - 11:27
2-СпецХ >в залитой базе
4 - 22.06.2020 - 11:29
1-USSR >само собой.. я тоже не понял, поэтому и обратился сюда.
5 - 22.06.2020 - 11:29
Кроме меня в базе никто не админит/пишет .. Вот я и не понял.
6 - 22.06.2020 - 12:54
Как вариант - в базе приемника по каким то причинам удалили документ и вместо него создали другой. GUID, который в приемнике вообще есть в источнике ? Если нет, то документ в приемнике точно создали руками, ну а старый документ ... спрятали ))) Могли поехать индексы в базе, при этом тоже могут быть фокусы
7 - 22.06.2020 - 13:00
6-USSR > Спасибо. Пороюсь в сторону поехавших индексов
8 - 22.06.2020 - 15:51
История объекта в журнале регистрации какова?
9 - 23.06.2020 - 07:06
Еще. Я сам ни разу не пробовал, но из GUID вроде как можно вытянуть дату и время создания документа. Вдруг добавит ясности в вопрос происхождения документа
10 - 23.06.2020 - 08:42
8-Пупкин >Не нашел ничего. Там только лог загрузки и все.
9-USSR > Да можно , попробую
11 - 23.06.2020 - 10:10
Цитата:
Сообщение от USSR Посмотреть сообщение
Еще. Я сам ни разу не пробовал, но из GUID вроде как можно вытянуть дату и время создания документа. Вдруг добавит ясности в вопрос происхождения документа
&НаСервере
Функция ПолучитьДатуСоздания(Ссылка)

Если НЕ ЗначениеЗаполнено(Ссылка) Тогда
Возврат Неопределено;
КонецЕсли;

Момент = Дата(1, 1, 1);
Попытка

УИ = Строка(Ссылка.УникальныйИдентификатор());
УИ = ВРег(СтрЗаменить(УИ,"-",""));

Если Сред(УИ, 13, 1) = "1" Тогда

Значение16 = ВРег(Сред(УИ, 14, 3) + Сред(УИ, 9, 4) + Сред(УИ, 1, 8));
Цифры16 = "123456789ABCDEF";
Значение10 = 0;
Длина16 = СтрДлина(Значение16);

Для Ном = 1 По Длина16 Цикл
Значение10 = Значение10 + Pow(16, Длина16-Ном)*Найти(Цифры16, Сред(Значение16, Ном, 1));
КонецЦикла;

Значение10 = Значение10/10000000;
Момент = Дата(1582, 10, 15, 3, 0, 0) + Значение10;

КонецЕсли;

Исключение
КонецПопытки;

Возврат Момент;

КонецФункции


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены