К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

СКД программый выбор настроек

Гость
0 - 29.12.2016 - 08:30
На форме имеем переключатель ВариантОтчета


Процедура ВариантОтчетаПриИзменении(Элемент)
СтруктураВариантов = Новый Структура;
пВарианты = СхемаКомпоновкиДанных.ВариантыНастроек;
Для Каждого пЭл ИЗ пВарианты Цикл
СтруктураВариантов.Вставить(пЭл.Имя,пЭл.Настройки) ;
КонецЦикла;

// потом выбираем нужную настройку


Если ВариантОтчета=1 Тогда
пНастройки = СтруктураВариантов.Настройка1
Иначе
пНастройки = СтруктураВариантов.Настройка2
КонецЕсли;
КомпоновщикНастроек.ЗагрузитьНастройки(пНастройки) ;
КонецПроцедуры

Проблема в том, что выполняется только первый вариант по умолчанию. После выполнения вышенаписанной процедуры отчет зависает и потом вываливается по ошибке "Не хватает памяти". Настройки в обоих вариантах нормальные. Порядок вариантов меняла. Первый выполняется, а потом никак.



1 - 29.12.2016 - 15:10
На какой строке валится-то?
Пользовательские настройки перед загрузкой очистить не пробовала?
Гость
2 - 29.12.2016 - 16:46
Разобралась уже. Нужно было немного переделать процедуру, так чтобы каждый раз при смене варианта настроек в эту настройку запихивать параметры, которые на форме. В частности период отчета. При смене варианта система компоновала данные за весь период, отсюда и зависание.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены