К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

СКД : Предопределенное значение в отчете

bvb
0 - 03.10.2018 - 18:44
Сделал простой отчет на УФ.
Формы нет есть только СКД и в модуле объекта СведенияОВнешнейОбработке.

Как в отбор СКД подпихнуть предопределенное значение справочника найденное по наименованию ?



1 - 04.10.2018 - 08:24
в параметры, а не в отбор, и именно предопределенное, а не по наименованию
bvb
2 - 04.10.2018 - 11:21
Я для установки значеня отбора использую вот такую функцию :

Процедура УстановитьЗначениеОтбора (НазваниеОтбора, ЗначениеОтбора, ВидСравнения, Использование = ИСТИНА) Экспорт

Для Каждого Элемент ИЗ КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл

Если Строка(Элемент.ЛевоеЗначение) = НазваниеОтбора Тогда
Элемент.ВидСравнения = ВидСравнения;
Элемент.ПравоеЗначение = ЗначениеОтбора ;
Элемент.Использование = Использование;

КонецЕсли;
КонецЦикла;

КонецПроцедуры


Просто как привязать ее к схеме СКД и на каком событии если формы нет ?
3 - 04.10.2018 - 12:07
(2)
в модуле отчета
Процедура ПриКомпоновкеРезультата
bvb
4 - 04.10.2018 - 13:07
(4) ПриКомпоновкеРезультата - почемуто не вызывается

А вот на ОбработкаПроверкиЗаполнения - срабатывает но только при нажатии на "Сформировать" а это не комильфо

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)

УстановитьЗначениеОтбора ("Контрагент", Справочники.Контрагенты.НайтиПоНаименованию("ПУПКИ Н",ИСТИНА), ВидСравненияКомпоновкиДанных.Равно);

КонецПроцедуры
5 - 04.10.2018 - 16:21
(4) это жесть, а не предопределенное значение. Изучите мат.часть про предопределенные в конфигураторе и не вводите людей в заблуждение. Например тут https://курсы-по-1с.рф/articles/%D0%...2-1%D1%81-8-3/
bvb
6 - 04.10.2018 - 17:07
(5)Спасибо за ссылку.
Вы предлагаете привязать предопределенное значение :
НайденнаяСсылка = Справочники.Контрагенты.НайтиПоНаименованию(“Пупки н”); ОбъектДанных = НайденнаяСсылка.ПолучитьОбъект(); ОбъектДанных.ИмяПредопределенныхДанных = “МойКонтрагент”; ОбъектДанных.Записать();

Затем указать его в параметрах схемы ?

У меня два впороса :
В апараметрах указывать в поле "Доступные значения" или "Значения" ?

В какой процедуре модуля отчета собственно привязывть значения ?
7 - 04.10.2018 - 17:50
6-bvb > "предлагаете привязать"
Предложение ясно выражено в (5) - не вводить людей в заблуждение <некорректным применением терминов>
Если речь о программной установке параметра СКД или отбора произвольным (заранее найденным, например) значением - копай в сторону (3)
bvb
8 - 04.10.2018 - 17:55
(7) Я дико извиняюсь за неправильный сабж.

На самом деле нужно и то и то и предустановка параметра и предустановка отбора.
Приоритетней отбор , котрый должен выставиться на момент открытия отчета , чтобы пользователь видел что он предустановлен и если нужно мог изментить
9 - 04.10.2018 - 18:12
Формы нет - негде перехватить событие создания/открытия и, следовательно, *модифицировать* настройки (с тем чтоб *показать* их пользователю). Если нужна визуализация предварительно модифицированных из кода настроек - создай форму и не мучь котенка.
bvb
10 - 04.10.2018 - 18:20
А вот в типовой есть :
#Область СлужебныйПрограммныйИнтерфейс

// Настройки общей формы отчета подсистемы "Варианты отчетов".
//
// Параметры:
// Форма - УправляемаяФорма - Форма отчета.
// КлючВарианта - Строка - Имя предопределенного варианта отчета или уникальный идентификатор пользовательского.
// Настройки - Структура - см. возвращаемое значение ОтчетыКлиентСервер.ПолучитьНастройкиОтчетаПоУмолча нию().
//
Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
Настройки.События.ПередЗагрузкойВариантаНаСервере = Истина;
КонецПроцедуры

// Вызывается в одноименном обработчике формы отчета после выполнения кода формы.
//
// Подробнее - см. ОтчетыПереопределяемый.ПередЗагрузкойВариантаНаСер вере
//
Процедура ПередЗагрузкойВариантаНаСервере(ЭтаФорма, НовыеНастройкиКД) Экспорт
Отчет = ЭтаФорма.Отчет;
КомпоновщикНастроекФормы = Отчет.КомпоновщикНастроек;

// Изменение настроек по функциональным опциям
НастроитьПараметрыОтборыПоФункциональнымОпциям(Ком поновщикНастроекФормы);

// Установка значений по умолчанию
УстановитьОбязательныеНастройки(КомпоновщикНастрое кФормы, Истина);

НовыеНастройкиКД = КомпоновщикНастроекФормы.Настройки;
КонецПроцедуры

#КонецОбласти


Не ?
11 - 04.10.2018 - 18:28
bvb
12 - 04.10.2018 - 19:15
Это типовой отчет по дебиторке из УТ 11.
Формы отчета там нет
13 - 04.10.2018 - 19:29
(12) Формы отчета там нет - зато там есть целая УТ с объявленной Основной формой отчета - так что есть там форма. лежит, правда, не в самом отчете, но разве это что-то меняет?
14 - 05.10.2018 - 08:11
(13) прав, там БСП и общая форма
bvb
15 - 05.10.2018 - 12:53
Т.е. я правильно понял :
В модуле нет предопределенной процедуры чтобы зарядить КомпоновщикНастроек ДО открытия формы отчета ?
16 - 05.10.2018 - 14:28
аффтар, вам шашечки или ехать ?
1) если отчет без форм и кода - то в параметры преопределенный
2)форма и код свой, или БСП и общая форма и код уже под БСП формат заточен, на ИТС читать надо


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены