К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Штрих-М-01Ф ИНН кассира

0 - 22.08.2018 - 21:32
Поменяли сегодня ФН, время пришло.
Соответственно поменялся ФФД с 1.0 на 1.05
Вследствие этого сильно хочется передавать в ОФД ИНН кассира.
как говорил один из киногероев - "Так сильно хочется, что аж кушать не могу". (с)



1 - 22.08.2018 - 21:48
вот что сильно смутило
в Общем руководстве по настройке ККТ
в описании таблицы 18 Fiscal storage
русским по-белому написано:
- Поле 23
- Назначение ИНН кассира
- Размер 13 CHAR

Открываю через Тест драйвера таблицы
а там в таблице 18 полей всего.. 22
ЦТО, где меняли ФН, божится, что аппарат перепрошили и прошивка актуальная.

???

Не, ну понятно, что через FNSendTag() типа
TagNumber =
TagType =
TagValueStr =
FNSendTag()
я в принципе любой тэг передать могу

но остался непонятный осадок - то ли ЦТО недоговаривает насчет прошивки, то ли в Общем руководстве по настройке ККТ фигня написана.
факт такой - в описании таблицы ИНН кассира есть, в реале - нет.
Это что ж - самой каждый раз за каждым чихом тэг формировать?
У Штриха ИНН кассира в таблицах не задается?
2 - 22.08.2018 - 21:52
а, да, самописка на 7.7.
типовые тут не подходят
3 - 23.08.2018 - 04:31
Цитата:
Сообщение от Блондинка в шок Посмотреть сообщение
Не, ну понятно, что через FNSendTag() типа TagNumber = TagType = TagValueStr = FNSendTag() я в принципе любой тэг передать могу
Любой не получится - ограничения драйвера, но тег 1203 (ИНН кассира) передать можно и нужно только так.
Его нужно передавать:
1) в отчетах об открытии смены
2) в отчетах об закрытии смены
3) в чеках
4) в чеках коррекции.

Есть особенности КАК передавать, иначе не сработает (ИНН кассира не передастся):
1) После метода FNBeginOpenSession
2) После метода FNBeginCloseSession
3) Перед закрытием чека ПОСЛЕ вывода позиций чека (или после метода OpenCheck)
4) После метода FNBeginBuildCorrectionReceipt

ИНН кассира передается в ОФД, но в бумажном чеке не печатается (т.к. такого требования нет в законе)
4 - 23.08.2018 - 09:36
3-victuan > елки-палки, про открытие я и забыла. Точно, там же тоже нужно ИНН кассира передавать. ОГРОМНОЕ спасибо за напоминание.

Так то я передаю после выводов позиций чека перед закрытием чека. Но это просто в чеке, а вот при открытии - это мой косяк, да. Просто до этого смена открывалась автоматически, с пробитием первого чека. Теперь придется отдельно смену открывать, да.
Ну и ладно, пару смен открыли получается без ИНН кассира, что уж теперь сделаешь.

И все-таки, значит, в Руководстве поле 23 в таблице 18 - это просто видимо задел на будущее или нереализованные задумки прошлого. В общем, слепо доверять Руководству нельзя.
5 - 27.08.2018 - 04:17
В Руководстве очень много ошибок и неточностей.

Если ИНН не валиден (не проходит проверку по контрольному числу), то он не будет передан.

Смену я открываю так:

Код:
	//открытие смены, если требуется
	Если Объект.ECRMode = 4 Тогда	// Закрытая смена 
		Объект.Password		= "30"; //глФРПарольАдминистратора ???  FNBegin*** только под паролем Администратора
		Попытка
			Объект.FNBeginOpenSession();// начинаем открытие смены
            
			Если ЕстьПоддержка54ФЗ = 1 Тогда   //начало 54ФЗ ФИО кассира установим перед открытием смены
				Если ПустоеЗначение(Кассир) = 0 Тогда // передаём в чек ФИО кассира ККМ // по сути программно ФИО кассира можно и не менять, а просто задать в Настройках торгового оборудования текущего пользователя - пароль кассира (а пронумерованный список ФИО кассиров задать через Тест драйвера, номер кассира = пароль кассира)
					ОбратитьсяКТаблицеФР(Объект, Пароль, "2-"+Пароль+"-2", лев(сокрлп(Кассир),64), 1, 1); //2-таблица "Пароль кассиров и администраторов", Пароль-номер строки, по сути - номер пользователя = пароль пользователя, 2-колонка № 2 содержит ФИО кассира, а колонка № 1 - пароль кассира (пароли кассиров желательно не менять, чтобы не запутаться, пусть пароль кассира = номеру кассира)
					Если ПустоеЗначение(КассирИНН) = 0 Тогда
						ЗаписатьТег(Объект, Пароль, 1203, 7, сокрлп(КассирИНН), 1)
					КонецЕсли;
				КонецЕсли;
			КонецЕсли; 
			Объект.FNOpenSession();
			Если Объект.ResultCode <> 0 Тогда
				ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
				ОтключитьсяОтФР(Объект, Пароль, 0);
			    Возврат 0;
			КонецЕсли;
			
		Исключение
			//Метод выдал ошибку - значит прошивка или драйвер ККМ старые и передача доп. тегов не поддерживается!!!
		КонецПопытки;
		Объект.Password = Пароль; //вернем пароль пользователя
	КонецЕсли;
6 - 05.09.2018 - 16:07
victuan, можешь прояснить такой вопрос.
PrintReportWithCleaning() закрытие смены, печатается Z отчет
и методы
FNCloseSession()
FNBeginCloseSession()
и по аналогии открытие смены. Ранее не использовал методы с FN...
Применять их вместе? Или вместо?
7 - 06.09.2018 - 04:19
Применять вместе:
FNBeginCloseSession + FNCloseSession
или
FNBeginCloseSession + PrintReportWithCleaning
Гость
8 - 06.11.2018 - 13:40
Добрый день.
Спасибо за подробные ответы.
Попробовал сделать так как описано в этой теме. И всё вроде работает. Касса не ругается. Но до ОФД доходит только имя кассира, а ИНН не доходит. В чём может быть проблема? Используете Addin.DrvFR? Какая дата прошивки кассы?
9 - 07.11.2018 - 05:01
8-kobayoshi >"Гораздо проще прочитать ФД по номеру в тесте драйвера и прверить есть там такой тег и информация по нему.
Если нет, значит ковырять ПО, есть тогда ОФД." (с) ТП Штрих-М.

Вот пример отчета с переданным тегом 1203 https://prnt.sc/jgi4ib
Гость
10 - 07.11.2018 - 09:25
Цитата:
Сообщение от victuan Посмотреть сообщение
8-kobayoshi &gt;"Гораздо проще прочитать ФД по номеру в тесте драйвера и прверить есть там такой тег и информация по нему. Если нет, значит ковырять ПО, есть тогда ОФД." (с) ТП Штрих-М. Вот пример отчета с переданным тегом 1203 https://prnt.sc/jgi4ib
Огромное спасибо за наводку!
Я посмотрел, ИНН в тесте драйвера присутствует. Но ОФД упорно утверждает, что он им не передаётся. Что ж, зато ясно, что ПО не при чём. Вопрос наверное к Штриху...
11 - 08.11.2018 - 11:50
Не подскажет кто, нужно будет указывать коды товара - как это сделать (кассовая прога самописка, нищеброды мы).
Гость
12 - 09.11.2018 - 10:20
Цитата:
Сообщение от Teddy3215 Посмотреть сообщение
Не подскажет кто, нужно будет указывать коды товара - как это сделать (кассовая прога самописка, нищеброды мы).
А конкретнее, что за код товара?
Не это?
PaymentItemSign ПризнакПредметаРасчета
Признак прдемета расчета. Возможные значения:
1. Товар
2. Подакцизный товар
3. Работа
4. Услуга
5. Ставка азартной игры
6. Выигрыш азартной игры
7. Лотерейный билет
8. Выигрыш лотереи
9. Предоставление РИД
10. Платеж
11. Составной предмет расчета
12. Иной предмет расчета
13 - 09.11.2018 - 11:59
Код товара вероятно скоро появится Разрабатывается единый классификатор товаров и код будет передаваться в чеке. Нынешние названия для контроля движения товара вещь абсолютно бесполезная, но это проба пера. Предполагаю, что потом в чеке появятся и данные покупателя )
14 - 09.11.2018 - 13:17
Цитата:
Сообщение от USSR Посмотреть сообщение
Разрабатывается единый классификатор товаров
А ОКПД - это не то? Шо, еще один классификатор? как они достали...
Гость
15 - 09.11.2018 - 16:37
Цитата:
Сообщение от USSR Посмотреть сообщение
Код товара вероятно скоро появится Разрабатывается единый классификатор товаров и код будет передаваться в чеке. Нынешние названия для контроля движения товара вещь абсолютно бесполезная, но это проба пера. Предполагаю, что потом в чеке появятся и данные покупателя )
От ЦТОшников слышал, что серию-номер паспорта покупателя нужно будет передавать при покупке акцизных товаров.

А теперь по делу: Такском просто не показывает в личном кабинете ИНН кассира по причине того, что это личные данные кассира. А я голову ломал! Неужели они сразу не могли дать этот ответ, ведь я конкретно в первый же раз спросил, где они у них должны отображаться((
16 - 12.11.2018 - 06:03
Цитата:
Сообщение от kobayoshi Посмотреть сообщение
Я посмотрел, ИНН в тесте драйвера присутствует. Но ОФД упорно утверждает, что он им не передаётся. Что ж, зато ясно, что ПО не при чём. Вопрос наверное к Штриху...
Не к Штриху, а к ОФД: если ИНН отражается в отчете драйвера, значит его передало ПО, а драйвер его передал в ОФД, но ОФД не отобразил.
17 - 12.11.2018 - 06:24
Цитата:
Сообщение от Блондинка в шок Посмотреть сообщение
Цитата: Сообщение от USSR Разрабатывается единый классификатор товаров А ОКПД - это не то? Шо, еще один классификатор? как они достали...
Видимо, речь о Проекте Постановления Правительства РФ "Об установлении дополнительного обязательного реквизита кассового чека или бланка строгой отчетности".
06.09.2018. В проекте Постановления Минфин России предлагает с 1 января 2019 года ввести дополнительный обязательный реквизит кассового чека -‎ "код товара"
Предусматривается, что в реквизите "код товара":

для товаров, в отношении которых на территории РФ принято решение о маркировке контрольными (идентификационными) знаками, указывается уникальная последовательность символов, представленная в средстве идентификации, содержащемся в контрольном (идентификационном) знаке данного товара;

для иных товаров будет указываться код товарной позиции в соответствии с ТН ВЭД ЕАЭС, к которой относится данный товар.
18 - 12.11.2018 - 09:52
Да, пока проект, перебдел. Но страшно подумать, если эти гркбаные алкогольные марки 100-значные еще и в чеке надо печатать д-лы б-ть (с) Лавров
19 - 13.11.2018 - 12:25
18-Teddy3215 >Алкогольные марки теперь 150-значные согласно приказа минфина 199н от 24.09.18
20 - 13.11.2018 - 12:37
Так какие же поля с нового года обязательны в чеке?
1. ИНН кассира (не печатается в чеке)
....
........
21 - 14.11.2018 - 12:17
(19) Подскажи, пожалуйста, сейчас используем твою обработку версии 2.0.3, касса АТОЛ 30Ф. После перепрошивки кассы и смене ФФД на 1.05 эта версия (2.0.3) будет работать или надо как-то обновиться до более свежей?
22 - 16.11.2018 - 05:40
21-Korpas >Версия 2.0.3 не будет работать корректно, нужно обновлять на версию 2.7.0, а если в чеке используется НДС, то на 2.8.0.
Можно написать мне на почту. Контакты указаны в 1С - Сервис - Дополнительные возможности - Панель управления ККМ.
23 - 16.11.2018 - 21:26
Доржи не дремлет!!!

:)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены