К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

рисунок. с диска...

Гость
0 - 16.03.2012 - 19:19
как проще напечатать рисунок с диска из 1с7...


Гость
1 - 16.03.2012 - 20:14
Не возможно?
Гость
2 - 16.03.2012 - 20:25
жди
3 - 16.03.2012 - 20:26
Все возможно...

Но не для всех.
Гость
4 - 16.03.2012 - 20:26
как?...
5 - 16.03.2012 - 20:28
Неправильный вопрос. Правильный: "Сколько?"
Гость
6 - 16.03.2012 - 20:29
морфологический анализ фразы "как проще?" предполагает, что ты уже каким-то образом решал задачу?
Гость
7 - 16.03.2012 - 20:29
сколько??? :-))))
Гость
8 - 16.03.2012 - 20:30
8-7d5x >охренеть!:-)
Гость
9 - 16.03.2012 - 20:30
7/ решал для 1с7 , проще- это в смысле без выкрутасов... если это еще вообще возможно....
Гость
10 - 16.03.2012 - 20:31
10 + ошибка- решал не в 1с7
Гость
11 - 16.03.2012 - 20:33
опиши
Гость
12 - 16.03.2012 - 20:35
скан-рисунки надо привязать к документу. при вывооде документа по необходимости надо печатать их...
Гость
13 - 16.03.2012 - 20:36
и что говорит Гугл на это?
Гость
14 - 16.03.2012 - 20:38
13+
14. намерился пути нахождения сканов хранить внутри документа- а как его печатать? в гуглить по 1с??
сейчас попробую. врядь ли там есть...
Гость
15 - 16.03.2012 - 20:40
14. есть! спасибо
16 - 16.03.2012 - 20:41
Цитата:
Сообщение от 7d5x
решал не в 1с7
Любопытно! А в чём ты решал, о юный падаван, перешедший на тёмную сторону силы?
Небось, на C# колбасил? Или на жабе?
А может, на плюсах???
Гость
17 - 16.03.2012 - 20:42
17. ты мудрёно говоришь, накрулся кальяна чтоли?
Гость
18 - 16.03.2012 - 20:42
17-Пацталоцци >не трожжь плюсссы!!!
Гость
19 - 16.03.2012 - 20:44
на базе MSACCESS, с хранением рисунков внутри базы
20 - 16.03.2012 - 20:45
Какой ещё кальян???
Киса, ты с какова города?
Запомни, чоткие поцоны говорят не "накурился", а "нажабался".
Гость
21 - 16.03.2012 - 20:47
21. мнеьше надо кальян мульён употреблять мы ведь на форуме по 1с :-)))
Гость
22 - 16.03.2012 - 22:21
даже на пятничный развод не похоже.
типичный .ох - одноЭсник
Гость
23 - 17.03.2012 - 11:11
столкнулся с тем что размер изображения ограничивается высотой строки и на печать позволил в полстраницы.... как напечать в размер А4??
Гость
24 - 17.03.2012 - 11:12
24-7d5x > Ты бы сменил наркотики, а? перешел бы на более легкие... И жить сразу проще станет...
Гость
25 - 17.03.2012 - 11:14
25/ я не курю, я только печатаю :-)))
Гость
26 - 17.03.2012 - 11:19
26+ через методы режимрисования, загрузить файл и вывести в строке таблицы- жутко медленно и с ограничением получаетя, через механизм креатеобүект интеретаппликашион - отрабатывает быстро но вместо изображения пустая область....
Гость
27 - 17.03.2012 - 11:20
27-7d5x > У тебя ошибка в 27-й строке кода.
Гость
28 - 17.03.2012 - 11:22
(28) ошибаешься. в 7, 23 и 146 строках
Гость
29 - 17.03.2012 - 11:22
29-Helen 1986 > Да не... В 23-й - еще куда ни шло... А вот в 27-й - вообще пипец...
Гость
30 - 17.03.2012 - 11:27
да....!! с вами действительно накуришшься!!
не выводит... и такой вот код-

IE = createobject("InternetExplorer.Application");
IE.Navigate("about:blank");
WIA = СоздатьОбъект("WIA.ImageFile");

Путь = "\\tss\share\ScanCopy\";
тзЖурнал.ВыбратьСтроки();
HTML = "";
ТекВысота = 0; Count = 0;
Пока тзЖурнал.ПолучитьСтроку() = 1 Цикл
Если тзЖурнал.Пикт = 1 Тогда Продолжить КонецЕсли;
Док = тзЖурнал.Док;
ИмяФайла = Путь + СокрЛП(тзЖурнал.IMEI) + ".jpg";
Если ФС.СуществуетФайл(ИмяФайла) = 0 Тогда
Сообщить("Не найдено изображение для " + СокрЛП(тзЖурнал.Модель) + " " + тзЖурнал.IMEI);
Продолжить;
КонецЕсли;

WIA.LoadFile(ИмяФайла);
HorizontalResolution = WIA.HorizontalResolution;
VerticalResolution = WIA.VerticalResolution;

Ширина = Цел(HorizontalResolution * 8.125);
Высота = Цел(WIA.Height * 100 / WIA.VerticalResolution);

ТекВысота = ТекВысота + Высота;
Count = Count + 1;
Если (ТекВысота >= 935) ИЛИ (Count = 2) Тогда
ТекВысота = 0;
Count = 0;
КонецЕсли;

HTML = HTML + "
|<DIV>
| <table cellpadding=0 cellspacing=0 border=1>
| <tr>
| <td width=" + Ширина + " height=" + WIA.Height + " valign=top background='file:" + ИмяФайла + "' style='background-repeat:no-repeat; " + ?(ТекВысота <> 0, "", "page-break-before:always") + "'>
| <table cellspacing=0 cellpadding=0>
| <tr>
| <td bgcolor=#FFFFFF style='height: 12px; padding-left: 1px; padding-right: 1px; font-size: 14px; font-weight: normal; font-family: Verdana, sans-serif;'><b>Заказ-наряд: " + тзЖурнал.Заказ + " Модель: " + СокрЛП(тзЖурнал.Модель) + " SN: " + тзЖурнал.IMEI + " Дата продажи: " + ?(ПустоеЗначение(тзЖурнал.ДатаПродажи) = 1,"Предторг", Строка(тзЖурнал.ДатаПродажи)) + "</b></td>
| </tr>
| </table>
| </td>
| </tr>
| </table>
|</DIV>
|";

КонецЦикла;
IE.document.write(HTML);
OLECMDID = 7; // Просмотр
IE.Visible = -1;
IE.ExecWB(OLECMDID, 2); // Выполнить комманду
IE.FullScreen = 0;
31 - 17.03.2012 - 11:56
Да ужжж... программисты 1С - они такие программисты... Лучше бы гуглили, чем кодили: http://infostart.ru/public/76108/
Гость
32 - 17.03.2012 - 14:13
(32) ТТО - гуглят и лазят по помойкам

а грамотные - пишут всего 1 строчку кода и поехали
33 - 17.03.2012 - 16:38
(33) Ехайте и не возвращайтесь. Направление напоминать не буду, вы его знаете.
Гость
34 - 17.03.2012 - 18:30
кто бы сомневался,

что это ты



[img]
http://www.picshot.ru/upload/600/1287255847.jpg[/img]
Гость
35 - 17.03.2012 - 18:30
Гость
36 - 17.03.2012 - 19:05
теперь я понял реакцию ПАЦЦТОЛОЦИ- сам уже "накурился кальяна" :-)))) .
уважаю тех благодаря кому все таки стараешься и получается....
с первым вариантом- нашёл косяк, а вот вариантом с интернетаппликайшенкреатеобъект-
не удалось таки найти причину не вывода на экран...- но он как вариант очень красивый ...может кто нить знает где косяк дымит? :-)
Гость
37 - 17.03.2012 - 19:08
35. хелена твой мотивтор или сайт откуда их черпает к рисункам аккуратно прикручивает вирусы... проверь свой компьютер
Гость
38 - 17.03.2012 - 19:18
с неделю назад продлила каспера
обновление - час назад
молчит как рыба в шампанском
Гость
39 - 17.03.2012 - 19:25
39. Да каспер молчал,а Секьюрети эссентиалз сказал что попытка вторжения вируса - Virus:JC.Decdec.A ....


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены