К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Результат Запроса. Как пользоваться?

Гость
0 - 25.12.2012 - 10:35
В справочнике Номенклатура с реквизитом Базовая ед изм (Спр.КлассификаторЕдИзм) и подчиненным справочником ЕдиницаИзм имеется много элементов, где имеется Единица изм только с Наименованием, но без заполненного реквизита КлассификаторЕдИзм и с пустым Коэффициентом. Делаю отбор по запросу :

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЕдиницыИзмерения.Ссылка КАК Ссылка,
| ЕдиницыИзмерения.Владелец КАК Владелец,
| ЕдиницыИзмерения.Наименование КАК Наименование,
| ЕдиницыИзмерения.ЕдиницаПоКлассификатору КАК ЕдиницаПоКлассификатору,
| Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК Наименование1
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
| ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
| ПО Номенклатура.Ссылка = ЕдиницыИзмерения.Владелец
| И Номенклатура.ЕдиницаХраненияОстатков = ЕдиницыИзмерения.Ссылка
|ГДЕ
| Номенклатура.ЭтоГруппа = ЛОЖЬ";

Результат = Запрос.Выполнить();
ТЗ=Результат.Выгрузить();

Для каждого СтрТЗ Из ТЗ Цикл
Если НЕ ЗначениеЗаполнено(СтрТЗ.ЕдиницаПоКлассификатору) Тогда
Если СокрЛП(СтрТЗ.Наименование)=СокрЛП(СтрТЗ.Наименован ие1) Тогда
//как заполнить поля ЕдиницыИзмерения.ЕдиницаПоКлассификатору и ЕдиницыИзмерения.Коэффициент ?
КонецЕсли;
КонецЕсли;
КонецЦикла;
Не могу теперь добраться до объекта Спр.ЕдиницаИзм, чтобы записать в него данные. Помогите, плиз. СтрТЗ.Ссылка иметт значение СправочникСсылка.ЕдиницыИзмерения, но метод ПолучитьОбъект() не работает , выдает ошибку – нет такого метода у объекта



1 - 25.12.2012 - 10:44
ЕдиницаКакОбъект = стрТЗ.Ссылка.ПолучитьОбъект();
ЕдиницаКакОбъект.Коэффциент = 1;
ЕдиницаКакОбъект.Обменданными.Загрузка = Истина;
ЕдиницаКакОбъект.Записать();


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены