К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Регистр остатков и его обороты

Гость
0 - 25.02.2013 - 09:11
Имеется регистр остатков КПдляЦР. Делаю непроведенными все документы, которые могут двигать этот регистр. Использую нижеприведенный код, чтобы убедиться, что регистр чист. В результате нет ни одного оборота, но есть итоги. Подскажите, это ошибка базы или я напортачил в коде и делаю что то не так?

Процедура Сформировать()
перем тз;
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("");
Таб.ВывестиСекцию("Шапка");
РегК = СоздатьОбъект("Регистр.КПдляЦР");
РегК.УстановитьФильтр(_Вагон);
РегК.ВыгрузитьИтоги(ТЗ);
РегК.ВыбратьДвижения('01.01.2000','31.12.2014');//,ПолучитьДатуТА());
Пока РегК.ПолучитьДвижение() = 1 Цикл
Таб.ВывестиСекцию("Строка");
КонецЦикла;
тз.выбратьстроки();
Пока тз.получитьстроку()=1 Цикл
Таб.ВывестиСекцию("Строка1");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,0,0);
Таб.Показать("");
КонецПроцедуры



Гость
1 - 25.02.2013 - 09:48
движения и остатки м.б. без даты, тогда своим запросом ты их не увидишь
Гость
2 - 25.02.2013 - 09:52
Пробовал РегК.ВыбратьДвижения(), в результате так же нет оборотов.
Гость
3 - 25.02.2013 - 10:00
попоробуй на копии прибить файл регистра
4 - 25.02.2013 - 10:04
зачем фильтр ? год бери 0001
Гость
5 - 25.02.2013 - 10:10
звучит как то страшно))
какой это конкретно файл?
Гость
6 - 25.02.2013 - 10:11
(4) фильтр по вагону делаю иначе там полная каша же.
Гость
7 - 25.02.2013 - 10:13
(4) сделал по году 0001 ничего не поменялось.
Гость
8 - 25.02.2013 - 10:23
сделай копию и прибей в ней регистр
потом проверь
Гость
9 - 25.02.2013 - 10:31
(8) нет опыта в этом деле. чем посмотреть какой именно файл отвечает за данный регистр?
Гость
10 - 25.02.2013 - 10:40
дд файло смотри - там все описано
11 - 25.02.2013 - 10:52
нет движений по вагону но есть остатки ? смотреть тогда прямо в регистр нуна
Гость
12 - 25.02.2013 - 10:56
(11) так и есть. В регистр это в файле искать?
13 - 25.02.2013 - 11:10
(12) Если это дбф - регистр - это 2 файлика - один файлик таблица движений, второй файлик - таблица итогов. Описание - в файле с расширением DD
Гость
14 - 25.02.2013 - 11:54
Разобрался, удалил оба файла, запустил 1с-ку, файлы восстановились пустыми. Перепровел несколько документов, двигающие этот регистр, файлы обновились. Запустил отчет из (1), опять появилась такая же ситуация. Отменил проведение всех документов, что провел после удаления файлов. В файле RA389.dbf пропали все строки, а вот в RG389.dbf остались вот такие строчки:
PERIOD SP390 SP391 SP392 SP398
01.02.2013 HPH A AY -3
01.03.2013 HPH A AY -3
01.04.2013 HPH A AY -3
01.05.2013 HPH A AY -3
01.06.2013 HPH A AY -3
01.07.2013 HPH A AY -3
01.08.2013 HPH A AY -3
01.09.2013 HPH A AY -3
01.10.2013 HPH A AY -3
01.11.2013 HPH A AY -3
01.12.2013 HPH A AY -3
01.01.2014 HPH A AY -3
01.02.2014 HPH A AY -3
01.03.2014 HPH A AY -3
01.04.2014 HPH A AY -3

Это как раз тот самый непонятный итог, что вылезает в отчете из (1), при том что движений нет.
15 - 25.02.2013 - 12:00
389 - если мне не изменяет память - это партии. Проверяй, что там накорябано "кривыми" ручками при проведении/отмене проведения доков.
Гость
16 - 25.02.2013 - 12:06
(15) партии? что за партии? вобще конфигурация полностью самописна, вариант кривых рук более чем вероятен.
17 - 25.02.2013 - 12:32
выложи оригинальную базу выгруженную на файлопомойку
Гость
18 - 25.02.2013 - 12:47
боюсь, если начальство узнает, что я слил их клиентов, мне больше тут не работать(
19 - 25.02.2013 - 13:54
на копии грохни файл справочника контрагентов, раз так печешься
Гость
20 - 25.02.2013 - 14:39
Похоже на то, что у тебя не стоит галка "автоматически удалять движения" на документе и нет процедуры, которая бы их чистила. Или ставь галку или пиши сам процедуру ОбработкаУдаленияПроведения()
Гость
21 - 25.02.2013 - 14:47
(20) стоит галка
Гость
22 - 25.02.2013 - 14:48
(20) да и причем тут не удаленные движения, когда движений то и нет, есть итоги.
Гость
23 - 25.02.2013 - 15:32
а права зачистки движений в этом регистре есть?
Гость
24 - 25.02.2013 - 15:40
(22) затрудняюсь ответить, где это можно посмотреть?
но о5 же движения появляются и пропадают при проведении/отмене документов, движения влияют на итоги правильно, вот только непонятно откуда к "правильным" итогам суммируется "-3", этот же итог "-3" виден при отмене всех документов. Надеюсь понятно выразился.
25 - 25.02.2013 - 16:16
ТиИ делал ?
Гость
26 - 26.02.2013 - 07:11
(25) делал выгрузку/загрузку
101
27 - 26.02.2013 - 07:57
(26) ТиИ <> выгрузка загрузка
28 - 26.02.2013 - 09:34
после загрузки/выгрузки на копии с непроведенными доками и сделать ТиИ как раз с пересчётами итогов
Гость
29 - 26.02.2013 - 10:09
ваще то выгрузка загрузка пересчитывает итоги по умолчанию
30 - 26.02.2013 - 11:49
Открой общий журнал документов.
Установи интевал видимости, где начало = пустая дата.
Гость
31 - 26.02.2013 - 12:07
(30) сделал, но что это даст?


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены