К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Расширение конфигурации

0 - 16.07.2018 - 08:40
Всем доброго дня!
Платформа 8.3.10.2699. Пробую простое расширение
Форма элемента справочника:

&НаКлиенте
Процедура УстановитьВидимость()
Элементы.Артикул.Видимость = Ложь;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
УстановитьВидимость();
КонецПроцедуры

Создаю расширение, и форме элемента перехватываю метод УстановитьВидимость()

&НаКлиенте
Процедура Расш1_УстановитьВидимостьПосле()
Элементы.Артикул.Видимость = Истина;
КонецПроцедуры

Все прекрасно работает. Артикул показывается. Но вот если метод УстановитьВидимость() сделать серверным, то процедура не перехватывается. База файловая, режим небезопасный. В интернете читал, что с перехватом серверных методов могут быть проблемы, но нифига не понял куда копать



1 - 17.07.2018 - 07:48
Цитата:
Сообщение от USSR Посмотреть сообщение
В интернете читал, что с перехватом серверных методов могут быть проблемы, но нифига не понял куда копать
Попробуй перехват с опцией "Вместо", а не "После". У меня на 8.3.10.2650 это сработало. На 2699 не пробовал.
2 - 17.07.2018 - 09:22
(1)Я посмотрю. Но это модельный пример, который пришлось сделать после неудачи в УТ11. Хотелось бы разобраться именно с таким вариантом, там именно серверная процедура и все ее замещать не хочется. Ну и вообще, для полноты картины)
Обработчики формы перехватываются без проблем
3 - 17.07.2018 - 16:44
Цитата:
Сообщение от USSR Посмотреть сообщение
Хотелось бы разобраться именно с таким вариантом
Технология все еще довольно сыроватая... поэтому ничему удивляться не следует. То что работает отлично на одних релизах может безбожно глючить на других. Я вот сам недавно на "мину" напоролся, когда функция получения строки соединения с базой на клиенте и на сервере давала разный ответ. Хотя функции сто лет в обед и все должно быть вылизано за прошедшие годы.
4 - 17.07.2018 - 17:17
Так никто не перехватывал серверный метод?
5 - 17.07.2018 - 18:23
вроде
в расширении:
&После("УстановитьВидимость")
Процедура Расш1_УстановитьВидимость()
...
КонецПроцедуры

режим совместимости = не использовать или поиграться от 8.3.9 и выше
ЗЫ
+ теория от создателей...
6 - 17.07.2018 - 19:27
Цитата:
Сообщение от user1C Посмотреть сообщение
режим совместимости
Кстати, да. У меня режим совместимости не использовался. Серверный метод перехватился.
7 - 17.07.2018 - 19:52
Режим совместимости у меня отключен )
(8)Перехватился именно произвольный метод, не обработчик событий ?
8 - 17.07.2018 - 20:45
Цитата:
Сообщение от USSR Посмотреть сообщение
Перехватился именно произвольный метод, не обработчик событий ?
Да, метод, вызываемый из обработчика.
9 - 17.07.2018 - 21:20
(8)это и у меня работает, например ПриСозданииНаСервере без пробоем перехватывается


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены