К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Проблема с подсистемой печати в УТ 11.1

0 - 24.06.2015 - 16:03
Есть типовая строка:
Макет = УправлениеПечатьюКлиент.ИнициализироватьМакет(Двои чныеДанныеМакета, ТипМакета);
Думаю многие ее видели она сидит внутри -
попытка
исключение
конецпопытки

так вот Уже мозг взорвался выдает ошибку!
{ВнешняяОбработка.ПечатнаяФормаНовая.МодульОбъекта (382,17)**: Переменная не определена (УправлениеПечатьюКлиент)

Макет = УправлениеПечатьюКлиент.ИнициализироватьМакет(Двои чныеДанныеМакета, ТипМакета);

F12 нажимаю функция есть она типовая. Что не так Спасибо!!!



1 - 24.06.2015 - 16:05
ПОЛНЫЙ ТЕКСТ ФУНКЦИИ

Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати) Экспорт

Состояние(НСтр("ru = 'Выполняется формирование печатной формы...'"));

ИмяМакета = "СтраховкаDOC";
ТипМакета = "DOC";
ДвоичныеДанныеМакета = ПолучитьМакет(ИмяМакета);
Области = ПолучитьОписаниеОбластейМакетаОфисногоДокумента();

ДанныеОбъекта = Новый Структура;

ДанныеОбъекта.Вставить("ТекущийГод", Год(ТекущаяДата()));

//ДанныеОбъекта = ПолучитьДанныеОбъекта();

Попытка
Макет = УправлениеПечатьюКлиент.ИнициализироватьМакет(Двои чныеДанныеМакета, ТипМакета);
Если Макет = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;
ПечатнаяФорма = УправлениеПечатьюКлиент.ИнициализироватьПечатнуюФо рму(ТипМакета, Макет.НастройкиСтраницыМакета);
Если ПечатнаяФорма = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

Область = УправлениеПечатьюКлиент.ПолучитьОбласть(Макет, Области["ВерхнийКолонтитул"]);
УправлениеПечатьюКлиент.ПрисоединитьОбласть(Печатн аяФорма, Область, Ложь);

Область = УправлениеПечатьюКлиент.ПолучитьОбласть(Макет, Области["НижнийКолонтитул"]);
УправлениеПечатьюКлиент.ПрисоединитьОбластьИЗаполн итьПараметры(ПечатнаяФорма, Область, ДанныеОбъекта, Ложь);

Область = УправлениеПечатьюКлиент.ПолучитьОбласть(Макет, Области["Договор"]);
УправлениеПечатьюКлиент.ПрисоединитьОбластьИЗаполн итьПараметры(ПечатнаяФорма, Область, ДанныеОбъекта, Ложь);

УправлениеПечатьюКлиент.ПоказатьДокумент(ПечатнаяФ орма);
Исключение
ОбщегоНазначенияКлиентСервер.СообщитьПользователю( ИнформацияОбОшибке());
УправлениеПечатьюКлиент.ОчиститьСсылки(ПечатнаяФор ма);
УправлениеПечатьюКлиент.ОчиститьСсылки(Макет);
Возврат Неопределено;
КонецПопытки;

УправлениеПечатьюКлиент.ОчиститьСсылки(ПечатнаяФор ма, Ложь);
УправлениеПечатьюКлиент.ОчиститьСсылки(Макет);

КонецФункции
Гость
2 - 24.06.2015 - 16:48
Цитата:
Сообщение от alex55 Посмотреть сообщение
{ВнешняяОбработка.ПечатнаяФормаНовая.МодульОбъекта (382,17)**: Переменная не определена (УправлениеПечатьюКлиент) Макет = УправлениеПечатьюКлиент.ИнициализироватьМакет(Двои чныеДанныеМакета, ТипМакета); F12 нажимаю функция есть она типовая. Что не так Спасибо!!!
Для тех кто в танке!
Клиентские общие модули не доступны для вызова на стороне сервера.
Гость
3 - 24.06.2015 - 17:05
"Семён Семёныч!?"
4 - 25.06.2015 - 09:59
Спасибо!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены