К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Прибыль 2015

0 - 13.03.2015 - 12:13
У кого есть дивиденды 9% поправьте в ( PRB1524.ERT )
---------------------------
//ИначеЕсли КодПоказателяВФормеОтчета = "П002140205" Тогда //стандартные вычеты
//
// флОбработанЭлементИдГруппы2 = 0;
// Для НомерТекСтрокиСтВычет = 1 По ТаблицаСтандартныеВычеты.КоличествоСтрок() Цикл
// ТаблицаСтандартныеВычеты.ПолучитьСтрокуПоНомеру(Но мерТекСтрокиСтВычет);
// СложнКодПоказателейВФормеОтчета = СокрЛП(КодПоказателейУзлаВФормеОтчета) + СокрЛП(КодПоказателяВФормеОтчета);
// xmlУзел = xmlФайлВыгрузки.СоздатьУзел("element", НаименованиеЭлемента);
// xmlУзелТекущий.ДобавитьПодчиненный(xmlУзел);
// ЗаполнениеПередачи(xmlФайлВыгрузки, xmlУзел, СсылкаНаВложенныйЭлемент, флОшибкаВВыгрузке, , СложнКодПоказателейВФормеОтчета,НомерТекСтрокиСтВы чет);
// флОбработанЭлементИдГруппы2 = 1;
// КонецЦикла;
//
// НомерТекСтрокиСтВычет = "";
//
// //Проверяем был ли выгружен хоть один из множественных элементов
// //и если элементы выгружены не были, а элемент - обязателен,
// //то прерываем выгрузку.
//
// Если (флОбработанЭлементИдГруппы2 = 0) и (СтрЧислоВхождений(ПризнакОбязательностиЭлемента, "Н") = 0) Тогда
// Сообщить(НаимРазделаОтчета + "
// |не найдено ни одной строки с данными """ + ПолноеНаименованиеЭлемента + " (" + НаименованиеЭлемента + ")"".", "!");
// // Обнаружена ошибка при выгрузке. Файл выгрузки сформирован не будет.
// флОшибкаВВыгрузке = 1;
// Возврат;
// КонецЕсли;
//
КонецЕсли; // Многострочность = "ИдГруппы2"
-----------------
//ИначеЕсли ИмяСекцииТаблицы = "Табл_71_СпрДохФЛ" Тогда //Таблица указанная в таблице ЭлементыФайлаОбмена в файле PRB1524.ERT
//
// //Сформируем таблицу для выгрузки стандартных вычетов
// СписокСтандартныйВычет = СписокСохраненныхДопСтрок.Получить(ИдГруппы2);
// СформироватьТаблицуСтандарныеВычеты(СписокСтандарт ныйВычет);
//
// // Добавляем новый сложный элемент в файл выгрузки для случая,
// //когда узел откуда вызывается этот раздел является множественным
// xmlУзел = xmlФайлВыгрузки.СоздатьУзел("element", НаимЭлемента);
// xmlУзелТекущий.ДобавитьПодчиненный(xmlУзел);
//
// ЗаполнениеПередачи(xmlФайлВыгрузки, xmlУзел, ИмяСекцииТаблицы, флОшибкаВВыгрузке,);
КонецЕсли;
----
Будет нормально выгружаться в СБИС и печататься в PDF417



1 - 13.03.2015 - 12:17
Вообще на кой они в прибыль физ. лиц засунули?
Засунули ладно, но забивать вручную, ладно 350 чел, а если укого 3500
banned
2 - 17.03.2015 - 09:20
Если у кого-то есть обособленные подразделения, - то во всех ерт-шках по прибыли в процедуре ОпределитьКППпоТитульному

следует сделать так:
// КППпоТитульному = ДанныеТитульногоЛиста.Получить("КПП");
КППпоТитульному = ДанныеТитульногоЛиста.Получить("КППпоТитульному");
banned
3 - 17.03.2015 - 09:27
У кого есть доступ на мисту, отпишите, пожалуйста, ссылку на эту ветку вот сюда: http://www.forum.mista.ru/topic.php?id=736928
banned
4 - 17.03.2015 - 21:47
Ы?
Никто мисту не посещает, чтоле?
Все там забанены, как и я?
banned
5 - 20.03.2015 - 12:28
2 недели уже человек мучается...
Неужели некому туда сходить и дать ссылку на мессидж (2)?
6 - 20.03.2015 - 14:26
Так пусть он сюда приходит)
banned
7 - 20.03.2015 - 14:28
6-Харлампий Дымба > Да он может даже и не знать про существование такого ресурса, как Т1С...
banned
8 - 20.03.2015 - 19:38
6-Харлампий Дымба > Где пропадал, дружище?
Несколько лет тебя на Т1С не было :-)
9 - 20.03.2015 - 20:32
7-Deimos Я здесь уже лет 15, со времён ТОТа и Любимова. ReadOnly). А про того беднягу - наверное, придётся на мисте зарегистрироваться, а то так и не сдаст...
banned
10 - 20.03.2015 - 20:51
9-Харлампий Дымба > Я прекрасно знаю, что ты тут старожил, как и я.

Вопрос был не об этом...

ОК, перефразирую вопрос: "Почему РидОнли"?
11 - 22.03.2015 - 23:41
Здесь всегда было в достатке людей, готовых помочь и имеющих, что сказать.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены