К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

При считывании сканером штрихкод обрезается

Гость
0 - 19.03.2013 - 09:13
Почему может обрезаться штрих код при считывании его сканером с товара.
В ручную по F7 вводишь все нормально обрабатывается, когда же считывается сканером штрих кода, в базе номенклатура не находится, так как считывается обрезанный штрих код! Как исправить можно эту ошибку?



Гость
1 - 19.03.2013 - 09:37
запрограммировать сканер не предлагать?
проверить обращение в иудейскую веру тоже не предлагать?
Гость
2 - 19.03.2013 - 09:41
(1) как запрограммировать? он запрограммирован, конфигурация розница 1, по F7 в документе ЧекККМ все нормально работает, в тч созданной мною формы, считанный штрихкод попадает обрезанный, почему?
Гость
3 - 19.03.2013 - 09:41
(1) если знакомая ситуация, подскажите как запрограммировать сканер?
Гость
4 - 19.03.2013 - 09:47
открываешь руководство и тычешь сканеру в морду нужные штрих коды
Гость
5 - 19.03.2013 - 09:59
(3) http://lmgtfy.com/?q=%D0%BA%D0%B0%D0...BD%D0%B5%D1%80
6 - 19.03.2013 - 10:10
2-LivingStar > для начала сходи на сканкод, найди модель и кури тех.рекомендации.
Гость
7 - 19.03.2013 - 10:29
(4) (6) так я же объясняю, что подобная ситуация в документе ЧекККМ обрабатывается нормально!!! В созданной мною форме же штрих код считывается обрезанный!!! Я так понимаю это я про написании кода что то не досмотрел...
8 - 19.03.2013 - 10:45
ШК не может считываться по-разному, различия в обработке считанных данных. Чего ты тогда от сообщества хочешь? Ошибка, как обычно, на своём месте - в третьей строке обработки.
Гость
9 - 19.03.2013 - 10:47
Как обрезается? Напиши пример, типа Должно быть - "123456789", а считывается - "12345" и естественно код приложи. А то на догадках сильно не поможешь.
Гость
10 - 19.03.2013 - 11:00
интересно, почему афтар не хочет проверить обращение в иудейскую веру?
Гость
11 - 19.03.2013 - 11:18
(9) к примеру код 111222, а при считывании получается 222, то есть 111 обрезается.

вернусь к этой задаче, опишу как и что там...
Гость
12 - 19.03.2013 - 12:32
11-LivingStar >Какая конфа? Что в отладчике возвращает функция: ШтрихКодыНоменклатуры.ПолучитьСведенияПоШтрихКоду( ДанныеШтрихкодов). Чему равны ДанныеШтрихкодов? это в УПП у тебя может быть другая функция
Гость
13 - 19.03.2013 - 12:34
(12) конфигурация Розница 1.
Гость
14 - 19.03.2013 - 12:37
Вот процедура которая вызывается по F7 в документе ЧекККМ. Штрих код берется от сюда:

Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();

Функция ВвестиШтрихкод() Экспорт

Результат = "";

ВвестиСтроку(Результат, "Введите штрихкод");

Возврат Результат;

КонецФункции // ВвестиШтрихкод()

то есть просто считывается на место курсора сканером или же набивается с клавиатуры


Процедура КнопкаВвестиШтрихкодНажатие(Кнопка)

Если Не мОтображатьПодборВПравойЧастиЭкрана Тогда

Результат = ЭлементыФормы.ИнфНадписьТекущееЗначение.Значение;

НажатиеКлавиши(ЭлементыФормы.КоманднаяПанельАкселе раторы.Кнопки.КлавишаСтереть);

КонецЕсли;

Если мОтображатьПодборВПравойЧастиЭкрана
ИЛИ Не ЗначениеЗаполнено(Результат) Тогда

Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();

КонецЕсли;

Если Не ПустаяСтрока(Результат) Тогда
РаботаСТорговымОборудованием.ОбработатьВведенныйШт рихкод(Результат, ЭтаФорма, Истина);
КонецЕсли;

УстановитьАктивныйЭлемент();

КонецПроцедуры //КнопкаВвестиШтрихкод
Гость
15 - 19.03.2013 - 12:39
в документе ЧекККМ штрих код сканером считывается не обрезанный

в моей же форме вызывается процедура тоже по F7 и в верхней строке, сразу стоит считывание

Штрихкод = РаботаСТорговымОборудованием.ВвестиШтрихкод();

но вот тут он появляется обрезанным, и не находится такой номенклатуры в справочнике
Гость
16 - 19.03.2013 - 12:41
может что я из этой процедуры не перетащил?

КнопкаВвестиШтрихкодНажатие(Кнопка)

я просто не пойму, зачем, код же считывается в текстовое поле и все, но вот в моем случае почему то обрезанный!
Гость
17 - 19.03.2013 - 13:07
единственное что добавил в своем коде это

Если Не ПустаяСтрока(Штрихкод) Тогда
РаботаСТорговымОборудованием.ОбработатьВведенныйШт рихкод(Штрихкод, ЭтаФорма, Истина);
КонецЕсли;


это единственное чем отличается функционал в документе ЧекККМ от моей обработки по существу
Гость
18 - 19.03.2013 - 14:32
15-LivingStar >Штрихкод = РаботаСТорговымОборудованием.ВвестиШтрихкод();
А чему равен размер "ШтрихКод" - может длина мала?
Гость
19 - 20.03.2013 - 05:23
(18) да нет, длина та которую введут, произвольная наверное, не ограниченная!

дело в том что в документ когда сканируют не обрезается, а в мою форму обрезаются
Гость
20 - 20.03.2013 - 07:44
19-LivingStar >... произвольная наверное..
Я имел ввиду не длину штрихкода, а размер поля (реквизита) куда помещаешь считанный штрихкод. Все-таки, что показывает отладчик? ... код же считывается в текстовое поле... встань в эту точку Штрихкод = РаботаСТорговымОборудованием.ВвестиШтрихкод();
21 - 20.03.2013 - 09:09
в блокноте что сканирует ?
Гость
22 - 20.03.2013 - 09:48
(20) почитай (11). как то странно обрезается. вроде бы должен хвост рубиться, а отлетает голова
23 - 20.03.2013 - 10:32
22-Helen1986 > у тебя есть уверенность в показаниях ТС?
Гость
24 - 20.03.2013 - 10:38
да он ваще какой то .... тормозной
Гость
25 - 20.03.2013 - 13:49
22-Helen1986 >Ну мыж не знаем, что там происходит может поле 3 символа с выравниванием вправо
Гость
26 - 20.03.2013 - 13:51
(25)
встав на него, можно стрелками побегать и увидеть все
в отладчике религия не дает посмотреть?
Гость
27 - 20.03.2013 - 14:43
26-Helen1986 >Это ты мне или ТС? :-)
28 - 20.03.2013 - 15:17
если у тебя для EAN-13 реквизит строка (13), то обычно после считывания данных идёт суффикс в виде символов #13 #10, может что еще. Вот они и подвинут начальные символы. Блокнот рулит - сохрани пикнутый файл и по байтам посмотри в 16-ричном редакторе HEX что там кроме символов ШК
Гость
29 - 20.03.2013 - 15:18
- Куда ты завёл нас, Сусанин-герой?
- Идите к чертям, я и сам здесь впервой!
- Давайте отрежем Сусанину ногу!
- Не надо, ребята, я вспомнил дорогу!
Гость
30 - 20.03.2013 - 16:23
Народ, а кто знает где найти расшифровку параметров у Компонент = Новый("AddIn.КартинкаШтрихкода.Barcode")
Например какие параметры подкрутить, чтобы "полоски" штрих кода размещались от края до края картинки штрихкода. Как ни крутил все-равно оставляет поле слева или справа при печати
Гость
31 - 20.03.2013 - 17:11
(30) По стандарту EAN должно быть свободное место слева и справа, по стандарту где-то 2,8 мм. Иначе штрих-код просто не будет считываться.
Кому интересно, ссылка на ГОСТ ИСО/МЭК 15420-2001 Автоматическая идентификация. Кодирование штриховое.
http://docs.cntd.ru/document/1200028884
Гость
32 - 21.03.2013 - 15:34
Слава отладчику! Он как микроскоп, помогает понять суть явления. Можно долго строить догадки, обсуждать причины. Но пока не посмотришь в него, ничего не поймешь.
Гость
33 - 22.03.2013 - 07:43
32-zaic >Отладчик это канечно Да! Но как быть в моем случае (30)? Когда смотришь на печатную форму этикетки (упр приложение),там штрихкод - это картинка. Но картинка имеет поля слева и справа шириной мм 8 (а не 2.8 как пишет (31)). Я понимаю что этими полями управляют параметры самой компаненты. Но где найти это означают эти пираметры, которые задаются числом?
Компонент.МинимальнаяШиринаКода - в каких единицах? мм, пункты, пиксели?
Компонент.Ширина - тоже самое и тд.

Конечно путем подбора я сделал то что мне надо, но хотелось бы не тыкаться как слепой котенок, а действовать осознанно.
Вот что показывает отладчик:
Компонент
AddIn.КартинкаШтрихкода.Barcode
ECL 1 Число
АвтоТип Истина Булево
ВертСмещение 0 Число
ВидимостьКС Истина Булево
ВыравниваниеКода 2 Число
Высота 100 Число
ГорСмещение 0 Число
ГрафикаУстановлена Истина Булево
ЗначениеКода Недоступно для чтения
ИмяФайла "" Строка
КоличествоСтолбцов 0 Число
КоличествоСтрок 0 Число
КоличествоШрифтов 235 Число
КонтрольныйСимвол "8" Строка
МинимальнаяВысотаКода 2 Число
МинимальнаяШиринаКода 109 Число
ОриентацияТекста 4 Число
ОтображатьТекст Истина Булево
ПоложениеТекста 0 Число
ПрозрачныйФон Ложь Булево
Пропорции "1:4" Строка
РазделителиКода 30 Число
РазмерКрая 0 Число
РазмерШрифта 10 Число
СодержитКС Ложь Булево
ТекстКода "1234567890128" Строка
ТипКода 1 Число
УголПоворота 0 Число
ЦветПолос 0 Число
ЦветТекста 0 Число
ЦветФона 0 Число
Ширина 150 Число
Шрифт "Aria선" Строка

И что это мне дает?
Гость
34 - 22.03.2013 - 09:29
(33) Это я для автора еще раз про отладчик. Он же в (2) признался, что криво сделал форму по документу ЧекККМ.
По поводу параметров картинки надо искать рук-во по компоненте. Если не найти авторов, то я бы оставил с полями и не мучился.
Гость
35 - 22.03.2013 - 09:39
34-zaic >Дело в том, пришлось менять принцип формирования штрих кодов, тк при одинаковой длине сканер читает нормально, терминал сбора данных не читает (разрешение разное) тип штрих кода Code39. ТСД (который у меня) код больше 15 символов не читает...
Гость
36 - 01.04.2013 - 07:02
Дело было в кнопке к которой было привязанно действие F7, только она лежала на заднем фоне за таблицей, это и вызывало эффект обрезанного кода. Удалил эту кнопку, и добавил в нижней панели.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены