К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Помогите НазначитьВид(<Значение>,<Вид>)

Гость
0 - 19.07.2012 - 12:51
Бухгалтерия 7.7 В документе создала реквизит табличной части «Автомобиль» справочник неопределенного вида.
Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога, ФлагСтандОбр)
Если ИдентЭлемДиалога = "Автомобиль" Тогда
СЗ = СоздатьОбъект("СписокЗначений");
СЗ.ДобавитьЗначение("ОсновныеСредства");
СЗ.ДобавитьЗначение("Материалы");
ВыбранныйВид = "";
Если СЗ.ВыбратьЗначение(ВыбранныйВид,,,,2) = 0 Тогда
ФлагСтандОбр = 0;
Иначе
НазначитьВид(Автомобиль, ВыбранныйВид);
КонецЕсли;
КонецЕсли;
КонецПроцедуры

В программе при клике по этому полю появляется список: ОсновныеСредства, Материалы; но при нажатии на любое значение открывается окошко выбора справочника, причем правильно позиционируется. Как его обойти? Хотелось бы сразу попасть в нужный справочник. В отладчике после НазначитьВид(Автомобиль, ВыбранныйВид) Автомобиль становится правильного вида.



Uho
1 - 19.07.2012 - 12:53
Автомобиль в материалах это, конечно, круто
Гость
2 - 19.07.2012 - 12:56
1-Uho > )) изначально было только для автомобилей
Гость
3 - 19.07.2012 - 12:59
0-Svetic >Кури метод НеИзменятьВид
Гость
4 - 19.07.2012 - 13:08
3-Duke1C > Спасибо!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены