К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Получить доступ к реквизитам документа на управляемых формах.

Гость
0 - 19.04.2018 - 10:21
Подскажите плиз. Туплю. Есть форма обработки на управляемых формах. На ней реквизит - тип Документ. Как получить доступ к реквизитам данного документа?


Uho
1 - 19.04.2018 - 10:32
Документ.Реквизит
2 - 19.04.2018 - 10:33
тип ДокументСсылка ? ПолучитьОбъект() не ?
Гость
3 - 19.04.2018 - 10:35
на клиенте не дает через документ.реквизит, не видит реквизита
Гость
4 - 19.04.2018 - 10:36
Мойдокумент = Объект.НужныйМнеДокумент, но доступа к реквизитам нет.
5 - 19.04.2018 - 10:42
что за конфа ? БСП ОбщегоНазначения.ПолучитьРеквизитОбъекта
или проваливаться на сервер и получать весь объект
6 - 19.04.2018 - 11:04
3-kotmurlot > ну так чтоб получить что-то "через точку" от ссылки это нужно прочитать из базы данных. Никакое чтение данных из базы на клиенте невозможно.
Внеконтекстный вызов сервера. Или свой, или (5)
Гость
7 - 19.04.2018 - 11:11
Разобрался что все на сервере надо делать, а как сделать чтобы перебрать все строки документа на сервере передавая на клиент по одной и там ее обрабатывая?
Uho
8 - 19.04.2018 - 11:34
зачем?
9 - 19.04.2018 - 11:35
вызов серверный один должен быть, посмотри хэлп по РеквизитФормыВЗначение и ДанныеФормыВЗначение
10 - 19.04.2018 - 12:42
(8)+
и для чего?)
11 - 19.04.2018 - 12:51
(7) Попробуй значения реквизитов строки ТЧ документа в массив засунуть, а затем сформировать массив из этих строк и верни на клиента.
Гость
12 - 19.04.2018 - 13:32
7-kotmurlot >По-человечески - никак. Обрабатывай все сразу на сервере. Или получай с сервера массив структур, сформированный из данных строк, и с ним работай.
Гость
13 - 19.04.2018 - 15:33
есть документ, выбран на форме, данные из него надо сохранить в текстовый файл, как шапку, так и табличную часть. На серверной части получаю данные, а в на клиенте сохраняю в файл
Uho
14 - 19.04.2018 - 15:38
13-kotmurlot > Файл передавай через временное хранилище с сервера на клиент
Гость
15 - 19.04.2018 - 16:18
14-Uho > т.е. формировать его на сервере и передавать на клиент?
Гость
16 - 19.04.2018 - 16:19
14-Uho > а почему тогда сразу не сохранить его на сервере?
Uho
17 - 19.04.2018 - 18:13
Если нужно на клиентском компе сохранить, то передавай с сервера на клиент.
Если на сервере или, допустим, в общей папке, в которою есть доступ у пользователя агента сервера, то сохраняй сразу на сервере.
Гость
18 - 24.04.2018 - 09:57
Получаю на сервере доступ к табличной части документа. В табличной части есть реквизит, но в данных документа его нет и когда обращаюсь к табличной части, то к нему доступа тоже нет. Как получить доступ к реквизиту формы обращаясь к самой табличной части?
19 - 24.04.2018 - 10:20
(18)
запросом, например? мало понятно, что нужно в итоге...
Гость
20 - 24.04.2018 - 10:43
я имею доступ напрямую к объекту на сервере, напрямую к табличной части. На форме документа в табличной части есть реквизит, но среди данных табличной части документа его нет. Когда я обращаюсь например МойДокумент.ТЧ то я вижу и получаю доступ к реквизитам, которые заведены в данных, но не могу получить доступ к нужному мне реквизиту.
Гость
21 - 24.04.2018 - 11:24
В реквизитах есть объект в нем табличная часть но этого реквизита ТЧ нет и есть в реквизитах отдельно типа эта табличная часть и в составе нее уже есть реквизит нужный мне. вот как получить доступ к нему? через форму? на сервере это сделать нельзя? только на клиенте?
22 - 24.04.2018 - 13:00
Кто на ком стоял?
Них... не понятно.
Что у тебя отображено на форме (см путь к данным для элемента управления)? данные объекта (что-то типа "Объект.ТабличнаяЧасть...") или реквизит формы (типа "Реквизит_ТаблицаЗначенийПоТЧ")?
Если я правильно понимаю - последнее. И это последнее если найти его среди реквизитов формы (в правой верхней четверти окна формы в конфигураторе) имеет тип "(ТаблицаЗначений)". Именно так, со скобками. В этом случае нужно в контекстном серверном вызове с помощью РеквизитФормыВЗначение получить "настоящую" таблицу значений, обработать её и, если необходимо, вернуть обратно методом значениеВРеквизитФормы
Гость
23 - 24.04.2018 - 16:14
22-roma n >именно так, не у объекта, в правом верхнем углу. Мне нужно просто получить значения и все. Записывать их обратно в форму не надо.
24 - 24.04.2018 - 17:37
Цитата:
Сообщение от kotmurlot Посмотреть сообщение
есть в реквизитах отдельно типа эта табличная часть и в составе нее уже есть реквизит нужный мне
какой тип у этой "табличной части"? она показывается на форме через элемент "таблица"?
Uho
25 - 24.04.2018 - 18:21
автор, выложи уже скриншот что ли, раз словами написать не можешь

PS.
&НаСервере
Процедура ПрочитатьТЗ()
Для Каждого Строка ИЗ ТЗ Цикл
Сообщить(Строка.Реквизит1);
КОнецЦикла;
КонецПроцедуры
Гость
26 - 25.04.2018 - 15:16
У меня есть обработка. На ней есть объект типа документ. Мне нужно получить РеквизитФормыВзначение с его формы, как достучаться до формы объекта через обработку?
27 - 25.04.2018 - 15:30
Автор, в чем исходная задача? Объясни на предметном уровне, а не на уровне реквизитов формы
Гость
28 - 25.04.2018 - 15:36
Есть обработка. На ней реквизит типа Документ. В котором есть табличная часть. Мне необходимо эту табличную часть скинуть в таблицу значений через РеквизитФормыВзначение и обработать ее.
Uho
29 - 25.04.2018 - 15:41
28-kotmurlot > Нет такого типа "Документ", есть "ДокументСсылка", "ДокументОбъект"
30 - 25.04.2018 - 15:44
Гость
31 - 25.04.2018 - 15:52
29-Uho > сорри, ДокументСсылка
Гость
32 - 25.04.2018 - 15:53
30-user1C > все так плохо?)
33 - 25.04.2018 - 15:56
(32)
огу)
на сервере запросом получай табличную часть документа по ДокументСсылка в таблицу значений...
Uho
34 - 25.04.2018 - 15:59
31-kotmurlot >


&НаСервереБезКонтекста
Процедура ПрочитатьТЧДокументаНаСервере(РеквизитДокументСсыл ка)

Запрос = Новый Запрос("ВЫБРАТЬ
| ТвойДокументТвояТабличнаяЧасть.РеквизитТЧ КАК РеквизитТЧ
|ИЗ
| Документ.ТвойДокумент.ТвояТабличнаяЧасть КАК ТвойДокументТвояТабличнаяЧасть
|ГДЕ
| ТвойДокументТвояТабличнаяЧасть.Ссылка = &Ссылка");
Запрос.УстановитьПараметр("Ссылка",РеквизитДокумен тСсылка);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
Сообщить(Выборка.РеквизитТЧ);
КонецЦикла;

КонецПроцедуры

&НаКлиенте
Процедура ПрочитатьТЧДокумента()
ПрочитатьТЧДокументаНаСервере(РеквизитДокументСсыл ка);
КонецПроцедуры
Uho
35 - 25.04.2018 - 16:01
Или просто

&НаСервере
Процедура ПрочитатьТЧДокументаНаСервере()

Запрос = Новый Запрос("ВЫБРАТЬ
| ТвойДокументТвояТабличнаяЧасть.РеквизитТЧ КАК РеквизитТЧ
|ИЗ
| Документ.ТвойДокумент.ТвояТабличнаяЧасть КАК ТвойДокументТвояТабличнаяЧасть
|ГДЕ
| ТвойДокументТвояТабличнаяЧасть.Ссылка = &Ссылка");
Запрос.УстановитьПараметр("Ссылка",РеквизитДокумен тСсылка);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
Сообщить(Выборка.РеквизитТЧ);
КонецЦикла;

КонецПроцедуры

&НаКлиенте
Процедура ПрочитатьТЧДокумента()
ПрочитатьТЧДокументаНаСервере();
КонецПроцедуры
36 - 25.04.2018 - 16:06
(35)+
желанная таблица значений будет туто
ТЗ = Запрос.Выполнить().Выгрузить();
Гость
37 - 25.04.2018 - 16:15
наверное я объясняю через одно место, но таким образом он не видит этот реквизит и выдает ошибка, реквизит введен для формы в верхнем правом углу он присутствует, а если смотреть свойства документа и Данные - то там в табличной части этого реквизита нет.
38 - 25.04.2018 - 16:23
я объясняю через одно место - фточку :)
Ещё раз перечитал. Выдвигаю очередное предположение:
на форме документа отображается реквизит формы типа "(ТаблицаЗначений)". Необходимо получить эту самую ТаблицуЗначений не имея под рукой контекста формы документа, но имея ссылку на документ. Угадал?
39 - 25.04.2018 - 16:25
все, я пас)))


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены