К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Подключение обработок из хранилища

0 - 27.03.2017 - 09:03
Народ, помогите разобраться.
В базе в поле справочника лежит залитая обработка.
Хочется дать возможность людям ее открыть, прав на внешние давать не планируется.
Ссылка есть, если на клиенте получить из хранилища временного то там будут данные двоичные.
Но вот ОбъектДанных при передаче с сервера имеет ТИП строка "ВнешняяОбработка" и в итоге открывается обработка пустая, тоесть новая но не та что во временном хранилище.

&НаСервере
Функция ОткрытьДанныеНаСервере()
АдресДанных = ПолучитьФайлНаСервере();
Если АдресДанных = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

Если Найти(Объект.ИмяФайла, ".epf") > 0 Тогда // Отчет
ОбъектДанных = ВнешниеОтчеты.Подключить(АдресДанных, Объект.ИмяОбъекта);
Иначе // Обработка
ОбъектДанных = ВнешниеОбработки.Подключить(АдресДанных, Объект.ИмяОбъекта);
КонецЕсли;

Возврат ОбъектДанных;
КонецФункции

&НаКлиенте
Процедура ОткрытьДанные(Команда)
ИмяОбработки = ОткрытьДанныеНаСервере();

Если Найти(Объект.ИмяФайла, ".epf") > 0 Тогда // Отчет
Если ИмяОбработки = Неопределено Тогда
Предупреждение("Нет прикрепленного отчета");
Иначе
ОткрытьФорму("ВнешнийОтчет." + ИмяОбработки + ".Форма",, ЭтаФорма);
КонецЕсли;
Иначе // Обработка
Если ИмяОбработки = Неопределено Тогда
Предупреждение("Нет прикрепленной обработки");
Иначе
ОткрытьФорму("ВнешняяОбработка." + ИмяОбработки + ".ФормаОтчета",, ЭтаФорма);
КонецЕсли;
КонецЕсли;
КонецПроцедуры



1 - 27.03.2017 - 09:35
Вроде заработало, почему не понятно, тема закрыта.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены