К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Подключение к двум базам через OLE

Гость
0 - 30.04.2014 - 12:08
Собственно вопрос: кто-нибудь пробовал работать сразу с двумя или больше базами через OLE механизм ? все базы v7.7


banned
1 - 30.04.2014 - 12:20
В рамках одной обработки - я обращался последовательно к многим базам.

Не вижу никаких проблем, чтобы обратиться не последовательно, а одновременно. Разноимёнными объектами вида "v7 Application".

Только ЗАЧЕМ?
Зачем одновременно-то?

Вот у тебя есть соединения: База1_ОЛЕ, База2_ОЛЕ, База3_ОЛЕ...
Что ты с ними одновременно делать собрался, почему не последовательно обращаться к одному и тому же объекту: База_ОЛЕ?
2 - 30.04.2014 - 12:26
затем, что так упадёт громче
Гость
3 - 30.04.2014 - 12:34
Да все норм, просто сформулировал вопрос криво, сори, конечно последовательно. У меня три базы одна главная в остальные надо номенклатуру синхронизировать ну и пару доков создавать в одной или другой базе в зависимости от условий, т.е. хочу создать два конекта и чтобы они были постоянно подключены.
101
4 - 30.04.2014 - 12:41
оле настолько тормознутая весч шо ппц ...
Гость
5 - 30.04.2014 - 12:43
вот если при каждой необходимости синхронизации данных подключаться отключаться то капец долго, а если коннект есть то норм поидее все должно быть
Гость
6 - 30.04.2014 - 13:45
Добавить в ГМ
Код:
Перем V77_Applications[2];

Функция V77_Applications()
	Выражение=0;
	V77_Applications[1]=СоздатьОбъект("V77.Application");
	V77_Applications[2]=СоздатьОбъект("V77.Application");
	Выражение=Выражение+V77_Applications[1].Initialize(
		V77_Applications[1].RMTrade,""
		+" /D"//КаталогБазыОле
		+" /N"//ПользовательОле
		+" /P"//ПарольОле
		,"NO_SPLASH_SHOW");
	Выражение=Выражение+V77_Applications[2].Initialize(
		V77_Applications[2].RMTrade,""
		+" /D"//КаталогБазыОле
		+" /N"//ПользовательОле
		+" /P"//ПарольОле
		,"NO_SPLASH_SHOW");
	Если Выражение<>2 Тогда
		Предупреждение("Неудалось подключить базы");
		Возврат 0;
	Иначе
		Возврат 1;
	КонецЕсли;
КонецФункции

Процедура ПриНачалеРаботыСистемы()
	СтатусВозврата(V77_Applications());
КонецПроцедуры
7 - 30.04.2014 - 14:27
кто тебе пообещал, что у тебя будет ПОСТОЯННЫЙ коннект?
плюнь ему в пиво!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены