К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

По онлайн кассам

0 - 15.08.2017 - 10:11
Ну что, у кого какой опыт подключения? ну и вопросы, ессно


41 - 25.10.2017 - 16:03
38-serpent >Это не единственный баг это прошивки. До кучи:
1) нельзя отключить печать электронного чека
2) перепутаны ставки НДС, например вместо ставки "Без налога" выйдет ставка "10/110%"
3) не передается в ОФД тип оплаты "ЭЛЕКТРОННЫМИ", передается всё как "НАЛИЧНЫМИ"
42 - 25.10.2017 - 16:04
39-SergeyY >Она в моей обработке https://infostart.ru/public/603118/
43 - 25.10.2017 - 19:12
(42) Маркетинговый ход? :))) А без покупки с кодом процедуры не ознакомите? Драйвером 4.13 от штриха такое реализуемо?
44 - 26.10.2017 - 04:32
43-SergeyY >Да, реализуемо. Код процедуры для Штриха или для Атола интересует?
45 - 26.10.2017 - 04:36
Для Штрих-М:
Код:
//******* идея синтаксиса volk13 *********
Функция ОбратитьсяКТаблицеФР(Объект, текПароль, стрАдрес, текЗначение, типПоля = 0, флЗапись = 0)
	
	Объект.Password		= "30"; //глФРПарольАдминистратора ???
	Попытка
		стрСЗ_Адрес = СтрЗаменить(стрАдрес,"-","" "");
		Объект.TableNumber	= СтрПолучитьСтроку(стрСЗ_Адрес, 1);
		Объект.RowNumber	= СтрПолучитьСтроку(стрСЗ_Адрес, 2);
		Объект.FieldNumber	= СтрПолучитьСтроку(стрСЗ_Адрес, 3);
		//Объект.GetFieldStruct();
		Объект.ReadTable();
		ПредЗначение = ?(типПоля=0, Объект.ValueOfFieldInteger, Объект.ValueOfFieldString); //типПоля = 0 - целое число, 1 - строка символов
		Если флЗапись = 1 Тогда
			Если ПредЗначение <> текЗначение Тогда
				Если типПоля=0 Тогда
					Объект.ValueOfFieldInteger = текЗначение
				Иначе
					Объект.ValueOfFieldString = текЗначение
				КонецЕсли;
				Объект.WriteTable();
			КонецЕсли;
		Иначе
			текЗначение = ПредЗначение;
		КонецЕсли;
	Исключение
		Объект.Password = текПароль; //пользователя
		Сообщить("Ошибка "+?(флЗапись = 1, "записи в таблицу ", "обращения к таблице ") + стрАдрес);
		Возврат 0;
	КонецПопытки;
	Объект.Password = текПароль; //пользователя
	Если Объект.ResultCode <> 0 Тогда
		Сообщить("Ошибка "+?(флЗапись = 1, "записи в таблицу ", "обращения к таблице ") + стрАдрес+": "+ПолучитьОписаниеРезультата(Объект));
		Возврат 0
	КонецЕсли;
	
	Возврат 1; // 0 - ошибка исполнения, 1 - успешная запись или чтение
	
КонецФункции
46 - 26.10.2017 - 08:04
(45) Супер! Спасибо большое. Буду пробовать!
47 - 03.11.2017 - 11:06
Волку наш комсомольский
48 - 10.11.2017 - 18:49
Маладца


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены