К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Перемещение ТМЦ

Гость
0 - 12.12.2012 - 11:03
Оприходовали ТМЦ не на тот склад. На оптовый, а надо на розничный. А то с оптового не продает. Чтоб занового не перебивать уеву тучу товара пытаемся сделать документ "Перемещение ТМЦ" на основании "Поступление ТМЦ". Пишет ошибку:
Цена = ТаблицаДокумента.ПродЦена;
{Документ.ПеремещениеТМЦ.Форма.Модуль(655)**: Поле агрегатного объекта не обнаружено (ПродЦена)

Вот этого вот ПродЦена поиском больше нигде в модуле не нашел. И в глобальнике не нашел. Чего не так то?



Гость
1 - 12.12.2012 - 11:19
Типовая конфа
101
2 - 12.12.2012 - 11:29
процедура ввод на основании ... вид документа и вообще чо за конфа
Гость
3 - 12.12.2012 - 11:56
Конфа "Торговля и Склад" в этой рубрике и создана тема. Вид документа вроде написал "Перемещение ТМЦ".
Ппороцедура ввод ни основании - это что значит? Всю процедуру выложить?
4 - 12.12.2012 - 12:00
сейчас гляну
5 - 12.12.2012 - 12:04
(1) "Оприходовали ТМЦ не на тот склад". Выражайся яснее. Каким документом оформили приход ТМЦ на "не на тот склад"..?
6 - 12.12.2012 - 12:07
Проверяй в этом самом документе "оприходования на не тот склад" - смотри какой склад стоит в этом документе, смотри ТЩАТЕЛЬНО - склад у тебя розничный почему-то там оказался скорее всего, что типовыми действиями добиться затруднительно.
Гость
7 - 12.12.2012 - 12:07
5-Чучундер > Сделали документ "Поступление ТМЦ" на оптовый склад, а нужно "Поступление в розницу" на розничный. Теперь нужно переместить на розничный склад, чтобы с него можно было продавать
101
8 - 12.12.2012 - 12:07
чтобы увидеть в какой рубрике тема нада перетыкать все рубрики ... это так к слову ...
(3) процедура ввод на основании в документе перемещение ... и нужен точный вид документа как он задан в конфигураторе - и оприходования и перемещения
Гость
9 - 12.12.2012 - 12:08
3-GoodwinX > Вообще-то, "вводнаосновании" есть предопределенная процедура формы документа, а так же режим создания нового документа. В последнем случае в интерактивном режиме платформа подсовывает при вызове аргумент в виде ссылки "основания", и соответствующая процедура получает доступ к реквизитам этого самого "основания".
P.S. Я полагал, что ТС знаком с этим механизмом, но раз прозвучал вопрос "что это значит?"....
10 - 12.12.2012 - 12:11
Гланды через Ж..
Проще создать обработку, которая создаст документы "Поступление в розницу", заполнив их ошибочными документами "ПоступлениеТМЦ"
Гость
11 - 12.12.2012 - 12:17
Но это же типовая конфа с типовым механизмом. Почему не работает?
Гость
12 - 12.12.2012 - 12:17
+9 "Предопределенная процедура" должна содержать модуль, написанный разработчиком. Обычно, [грамотный] разработчик предусматривает в этом модуле проверку аргумента, и, в зависимости от вида объекта-ссылки, целенаправленно забирает от него аргументы.
Если вид объекта-ссылки не предназначен быть "основанием", то увы и ах...
Можно ли в данном случае использовать ПоступлениеТМЦ - Чу обещал посмотреть (4)
Гость
13 - 12.12.2012 - 12:19
8-101 > В конфигураторе так же: Поступление ТМЦ, ПеремещениеТМЦ
101
14 - 12.12.2012 - 12:20
к слову говоря обработка та вообще может содержать два реквизита и процедуру выгрузитьтабличную часть и загрузить предварительно найдя сделанные документы
ЗЫ что впрочим и с перемещением удалив не нужные колонки или выгрузив нужные
Гость
15 - 12.12.2012 - 12:21
9-VZ > В том и дело, что я не вижу что можно подсунуть
101
16 - 12.12.2012 - 12:21
(13) идентификаторов с пробелами не бывает ;))
Гость
17 - 12.12.2012 - 12:23
12-VZ > В списке видов документов для ввода на основании предлагается в том числе и Перемещение ТМЦ
Гость
18 - 12.12.2012 - 12:24
16-101 > Ну извините, скопипастил с топика.
ПоступлениеТМЦ
19 - 12.12.2012 - 12:24
(7) на чем зиждется уверенность что сделал поступление ТМЦ на оптовый склад?
20 - 12.12.2012 - 12:25
Гудвин, давай на e.meil@mail.ru ид и пароль от тима. разберемся быстро.
101
21 - 12.12.2012 - 12:27
не знаю чо там происходит но у меня все провелось
Гость
22 - 12.12.2012 - 12:27
17-GoodwinX > Какбы сообщение "Поле агрегатного объекта не обнаружено" говорит об обратном. Есть, конечно, вариант ошибки разработчика. Есть вариант, что типовая конфа не совсем уж "типовая", и "улутшатель" чегой-то не подумал - но это можно выяснить токмо разглядывая данную конфу.
101
23 - 12.12.2012 - 12:28
ща будешь объяснять чо такое тим ;))))
24 - 12.12.2012 - 12:31
//************************************************** ****************************
// ЗаполнениеПоДокументуОснованию()
//
// Параметры:
// Нет
//
// Возвращаемое значение:
// Нет
//
// Вызывается из формул элементов диалога:
//
// Описание:
// Производит заполнение документа по документу - основанию.
//
Функция ЗаполнениеПоДокументуОснованию()
Перем ЦенаЦены, ЕдиницаЦены, ВалютаЦены;

Если ДокОснование.Выбран()=0 Тогда
Возврат "Документ - основание не выбран!";
КонецЕсли;

ВидОсн = ДокОснование.Вид();

Если (ВидОсн <> "ПоступлениеТМЦ")
и (ВидОсн <> "ВводОстатковТМЦ")
и (ВидОсн <> "ПоступлениеТМЦИмпорт") Тогда
Возврат "Неверный вид документа - основания!";
КонецЕсли; // вид ДокОснования

ТаблицаДокумента = СоздатьОбъект("ТаблицаЗначений");
ДокОснование.ВыгрузитьТабличнуюЧасть(ТаблицаДокуме нта);

// очищаем наш документ
УдалитьСтроки();

// Для передачи в розницу надо заполнить цены по типу цен,
// а в случае ввода на основании документа "Ввод остатков ТМЦ на складе (розница)"
// надо заполнить цены из документа основания
ЕстьЦена = 0;
ЕстьРозничнаяЦена = 0;
Если (Склад.РозничныйСклад = 0) И (СкладПолучатель.РозничныйСклад = 1) Тогда
ТипЦен = глЗначениеПоУмолчанию("ОсновнойТипЦенПродажи");
Если ТипЦен.Выбран() = 1 Тогда
ЕстьЦена = 1;
КонецЕсли;
ИначеЕсли ДокОснование.Склад.РозничныйСклад = 1 Тогда // т.е. документ основание - "Ввод остатков ТМЦ на складе (розница)"
ЕстьРозничнаяЦена = 1;
КонецЕсли;

ТаблицаДокумента.ВыбратьСтроки();
Пока ТаблицаДокумента.ПолучитьСтроку()=1 Цикл

НоваяСтрока();
Номенклатура= ТаблицаДокумента.Номенклатура;
Количество = ТаблицаДокумента.Количество;
Единица = ТаблицаДокумента.Единица;
Коэффициент = ТаблицаДокумента.Коэффициент;

Если ЕстьЦена = 1 Тогда

Если глВернутьЦену(Номенклатура, ТипЦен, ДатаДок, ЦенаЦены, ЕдиницаЦены, ВалютаЦены) = 0 Тогда
Цена = 0;
Иначе
глПересчитатьЦенуВДокументе(Контекст,
УчитыватьНП, УчитыватьНДС,
ЦенаЦены, ВалютаЦены,
ТипЦен.ЦенаВклНП, ТипЦен.ЦенаВклНДС);
глПересчетТаблЧасти(Контекст, "Цена");
КонецЕсли;
ИначеЕсли ЕстьРозничнаяЦена = 1 Тогда

Цена = ТаблицаДокумента.ПродЦена;
глПересчетТаблЧасти(Контекст, "Цена");
КонецЕсли;

КонецЦикла; // по строкам основания

Возврат "";

КонецФункции // ЗаполнениеПоДокументуОснованию()
Гость
25 - 12.12.2012 - 12:33
19-Чучундер > ВоооОт!!! Спасибо.
Значит что было? Они приходовали на оптовый склад документом Поступление ТМЦ, т.к. при попытке приходования на розничный выскакивало сообщение: "Этим документов можно оформлять только на оптовый склад". После всех оприходований залезли в справочник Складов и изменили тип склада на розничный.
23-101 > Я не буду это комментировать
26 - 12.12.2012 - 12:34
проверяй
1. что склад, указанный в поступлении - точно оптовый?
2. в спр.пользователи для пользователя, под которым выполняешь действие, - задан ли основной тип цен продажи.
.я голосую что у тебя склад, который стоит в поступлении - розничный. Может когда-то он и был оптовым, но потом внем поставили флажок "розничный" - наплевав на вываливающееся при этом предупреждение.
27 - 12.12.2012 - 12:35
я - чемпион по перемещениям, вау!!!
28 - 12.12.2012 - 12:35
Мне CAPS LOCK включить, чтобы меня услышали?
Телепатирую. ТС завел оптовый склад, документом "ПоступлениеТМЦ" оприходовал на него МЦ. Потом выяснил, что нужно было оприходовать на розничный. Изменил тип оптового склада на розничный (а программа его при этом предупредила "Этот реквизит устанавливается только для нового склада"!).

Для розничных складов документ "ПоступлениеТМЦ" запрещен.
Для них предназначен "ПоступлениеТМЦВрозницу".

Поэтому (10).
29 - 12.12.2012 - 12:36
(25) для поступления тмц на розничный склад - есть отдельный документ Поступление ТМЦ(розница) - можно сразу приходовать на розничный склад.
30 - 12.12.2012 - 12:36
упс. я опоздал.
31 - 12.12.2012 - 12:37
(28) опоздун, в (6) все было уже рассказно.
32 - 12.12.2012 - 12:39
(25) как в (28) отмечено - когда у тебя умные люди меняли в карточке товара склад с оптового на розничный - прога их предупредила о бяковости такого поступка и необходимости перепроведения доков.
.
теперь лезб в журнал регистрации и смотри кто у тебя склад пменял тип - ну и прменяй к нему рекатльно ручку от швабры
Гость
33 - 12.12.2012 - 12:43
Реально очень благодарен всем отписавшимся! Никогда не имел дело с Торговлей, долго бы еще башку ломал
Гость
34 - 12.12.2012 - 12:50
33-GoodwinX > Можно подумать, что хитрожопые юзеры только с "торговлей" работают. Ты как с Луны свалился. Или первый раз обслуживаешь...
101
35 - 12.12.2012 - 13:11
(34) да он походу мало того что скорее восьмерочных так еще и Зуп/зик


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены