К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Переход с Бюджет 7.7 ред.6.2 в 8.2

0 - 01.03.2012 - 17:51
Стандартный перенос данных. Перенос справочников и остатков на 31.12.11 на 53% вылетает ошибка:
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъе кта(4761)**: Ошибка записи объекта
ТипОбъекта = Инвентарные номера ОС
Объект = М000000717
ОписаниеОшибки = Ошибка при вызове метода контекста (Записать): Не удалось записать "М000000717 (Инвентарные номера ОС)"!
ПозицияМодуля = Обработка.УниверсальныйОбменДаннымиXML.МодульОбъек та(4754)
КодСообщения = 26
ВызватьИсключение СтрокаСообщенияОбОшибке;



Что можно попробовать что бы продолжить перенос, как устранить эту ошибку?



1 - 01.03.2012 - 18:30
А за это скажи спасибо уродам из 1С.
если обратиться к первоисточнику
Цитата:
каждому объекту основных средств... присваивается уникальный инвентарный номер...
мало того, что они в справочнике ОС в качестве инвентарного номера использовали предопределенный реквизит "код" (что само по себе является бредом, поскольку в справочнике ОС могут быть элементы, которым не нужен инвентарный номер, например, капвложения, а "код"/инвентарный номер" хочешь не хочешь приходится заполнять), так они еще умышленно сделали это код НЕуникальным в пределах всего справочника.Т.е. умышленно начхали на инструкцию...

А бушки - что бушки? Это ж аксиома - если в каком-либо справочнике возможно дублирование чего либо, то бух непременно и обязательно этот дубль сделает. Аксиома.

Так что ищи в 7.7 дублирующиеся инвентарные номера и исправляй. Перед переносом.
2 - 01.03.2012 - 18:40
2-Блондинка в шок > да уж, позиций там много. Спасибо за инфу, буду искать дубли, удалять. В справочнике ОС я так понял искать надо?
3 - 01.03.2012 - 20:01
Странно так, нашел в справочнике позицию с инвентарным номером М000000717, дописал в конце номера 1, получилось М0000007171, всеравно ругается с той же ошибкой.
4 - 01.03.2012 - 20:50
на, поиграйся:
http://zalil.ru/32801363

зы: мопед не мой, на авторские права (с) не претендую никоим образом.
5 - 01.03.2012 - 21:15
5-Блондинка в шок > спасибо попробую) уже сколько времени та же ошибка вылазит, меняю номер он такую же точно ошибку выдает просто пишет уже тот номер на который я поменял в ошибке. Заметил одну штуку, данная позиция ОС в ней толком не заполнены реквизиты, но пометил на удаление всеравно выдает оишбку) Сейчас попробую заполнить реквизиты у этого ОС, может прокатит)
6 - 02.03.2012 - 11:24
Вот процедура проверки дублей:

//*******************************************
Процедура ДублиНомеровОС()

Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//**{ЗАПРОС(Сформировать)
|ТекущийЭлемент = Справочник.ОсновныеСредства.ТекущийЭлемент;
|Код = Справочник.ОсновныеСредства.Код;
|Функция Счётчик = Счётчик();
|Группировка Код;
|Группировка ТекущийЭлемент упорядочить по ТекущийЭлемент.Код без групп;
|"//****ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("ДублиНомеровОС");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
Если Запрос.Счётчик < 2 Тогда
Продолжить;
КонецЕсли;
// Заполнение полей Код
Таб.ВывестиСекцию("Код");
Пока Запрос.Группировка(2) = 1 Цикл
// Заполнение полей ТекущийЭлемент
Таб.ВывестиСекцию("ТекущийЭлемент");
КонецЦикла;
КонецЦикла;
// Заполнение полей "Итого"
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Контроль дублирующихся инвентарных номеров ОС", "");

КонецПроцедуры

А исправляем с помощью uchoice - тупо перенумеровываем, если дублей много. А если 1, 2, 10 - ручками.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены