К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Передача параметра в запрос ДинамическогоСписка???

0 - 01.07.2015 - 15:42
Ситуевина следующая:
Есть форма списка, который формируется динамически по произвольному запросу. Как можно передать значение параметра в этот запрос?



1 - 01.07.2015 - 16:04
Через его КомпоновщикНастроек
2 - 01.07.2015 - 16:11
Т.е. как программно внести в него значение и получить это значение в текте запроса ДинамическогоСписка?
3 - 01.07.2015 - 16:29
Из типовой БП
Процедура УстановитьПараметрДинамическогоСписка(Список, ИмяПараметра, Значение, Использование = Истина) Экспорт

ЗначениеПараметраКомпоновкиДанных = Список.Параметры.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(ИмяПараметра));
Если ЗначениеПараметраКомпоновкиДанных <> Неопределено Тогда
Если Использование И ЗначениеПараметраКомпоновкиДанных.Значение <> Значение Тогда
ЗначениеПараметраКомпоновкиДанных.Значение = Значение;
КонецЕсли;
Если ЗначениеПараметраКомпоновкиДанных.Использование <> Использование Тогда
ЗначениеПараметраКомпоновкиДанных.Использование = Использование;
КонецЕсли;
КонецЕсли;

КонецПроцедуры
4 - 02.07.2015 - 14:28
(3) Спасибо!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены