К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Перебор реквизитов ТЧ и все что с этим связано.

0 - 28.04.2012 - 08:10
Всем привет. Возникла задача перебрать реквизиты табличной части документа и по определенному условию сохранить их, например в ТЗ.
Перебрал примерно в таком цикле реквизиты:
Для каждого РеквизитТЧ из Ссылка.Метаданные().ТабличныеЧасти.ТЧ.Реквизиты Цикл
....
КонецЦикла.
Теперь, по идее, нужно сделать вложенный цикл, операцию сравнения и, если реквизит нужный - записать его имя и значение.
Прошу помощи в синтаксисе. Как по имени реквизита тч получить его значение?



1 - 28.04.2012 - 08:23
Всем спасибо, задача решена примерно следующим образом :)
Для каждого РеквизитТЧ из Ссылка.Метаданные().ТабличныеЧасти.ТЧ.Реквизиты Цикл
Сообщить("РеквизитТЧ - " + РеквизитТЧ.Представление());
Для каждого стр из ТЧ Цикл
Сообщить(Стр[РеквизитТЧ.Имя]);
КонецЦикла;
КонецЦикла;
2 - 28.04.2012 - 10:06
а чем "ВыгрузитьКолонки()" не понравилось?
3 - 28.04.2012 - 10:31
(2), у меня есть список реквизитов, которые необходимо контролировать от изменения и писать, в случае изменения в регистр. Это не только реквизиты табличной части, но и реквизиты шапки. ПОэтому просто выгрузитьКолонки() ниче не даст.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены