К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Печатная форма "Акт сверки взаиморасчетов"

Гость
0 - 10.09.2012 - 14:28
В 1С 8.2 есть Расчеты - Расчеты с контрагентами - Акт сверки взаиморасчетов. Табличная часть формируется по кнопке "Заполнить по данным бухгалтерского учета". вроде бы все правильно и красиво, даты строго в хронологическом порядке. При выводе печатной формы даты скачут в одном им известном порядке, выводится информация сначала например за июнь-июль, потом неожиданно появляются строки за февраль, потом за май и опять за февраль.

С чем это связано? И как расположить в нормальном хронологическом порядке? (Актов много, потому правка в экселе не лучший вариант)



Uho
1 - 10.09.2012 - 15:30
ох.. помнится в 7.7 в каком то релизе был такой же глюк))), в том случае проблемы были с сортировкой операций (насколько помню, именно из-за релиза)
Uho
2 - 10.09.2012 - 15:32
0-Nikolos > ну а в твоем случае нужно разбираться, у меня, например, ничто не "скачет"
Гость
3 - 11.09.2012 - 13:54
(0)
1. Невредно указывать конфигурацию
2. Встречал в УПП или КА, сечас не помню, там в запросе тупо отсутствует конструкция УПОРЯДОЧИТЬ ПО, что на файловой версии дает результат приближенный к ТЧ, а на SQL - как попальный.
Гость
4 - 11.09.2012 - 15:59
Конфигурация: Бухгалтерия государственного учреждения, редакция 1.0 (1.0.12.3)

Если можно поясните на примере.
Гость
5 - 12.09.2012 - 08:56
Неужели ни у кого нет этой конфигурации? Сбросьте обработчик кнопки печати, хоть сравню с тем что у меня
6 - 12.09.2012 - 16:20
Куда скинуть то?
Все приходиться из ТС клещами выдирать:(
7 - 12.09.2012 - 16:21
Функция ПечатьАктаСверки()

ТабДок = Новый ТабличныйДокумент;
ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_АктСверкиВзаиморасчетов_АктСверк и";
Макет = ПолучитьМакет("АктСверки");

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьНачОстатки = Макет.ПолучитьОбласть("НачОстатки");
ОбластьДоговор = Макет.ПолучитьОбласть("Договор");
ОбластьДоговорИтоги = Макет.ПолучитьОбласть("ДоговорИтоги");
ОбластьОбороты = Макет.ПолучитьОбласть("Обороты");
ОбластьОборотыИтог = Макет.ПолучитьОбласть("ОборотыИтог");
ОбластьКонОстатки = Макет.ПолучитьОбласть("КонОстатки");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();
Если НЕ РазделятьАкты Тогда
СтруктураВозврата = ВывестиЗаголовок(ТабДок, Учреждение);
ВывестиПоУчреждению(Учреждение, ТабДок, СтруктураВозврата);
Иначе
Для каждого ТекСтрока из СписокУчреждений Цикл
СтруктураВозврата = ВывестиЗаголовок(ТабДок, ТекСтрока.Учреждение);
ВывестиПоУчреждению(ТекСтрока.Учреждение, ТабДок, СтруктураВозврата);
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЦикла;
КонецЕсли;

Возврат ТабДок;
КонецФункции


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены