К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Печать в КА 1.1

0 - 28.07.2018 - 21:18
Всем привет, такая вот проблема:

1С:Предприятие 8.3 (8.3.10.2561)
Комплексная автоматизация, редакция 1.1 (1.1.78.2)

Документ реализация товаров и услуг, делаю печать выбираю УПД.
Запускается еще форма каким образом сформировать письмо по отправке УПД (штатное все), выбираешь и выводить печатную форму и письмо отдельно которое отправляет менеджер с этой печатной формой.
Так вот как не бился отладкой не доходит до места где печать и все тут.
Доходит до "ОткрытьФорму("ОбщаяФорма.ПечатьДокументовУправляе мая", ПараметрыОткрытия, ВладелецФормы, КлючУникальности);"

В нее проваливается сразу в ПриОткрытии, а ПриСозданииНаСервере никак, на сколько вижу там свиду есть вывод печатной формы, а в ПриОткрытии только создание письма.

А ищу я все это для того, чтобы исправить такую крайне не приятную ерунду, как не правильный вывод на печать, выводит пол страницы на 1 листе, видимо дальше разрыв страниц, дальше с повторением шапки на полную, дальше одна строка только без шапки на след. странице (видать не влезло) и т.д.

Сколько не бьюсь найти не могу где эти расчеты :(

Может кто сталкивался в этой конфе?



1 - 28.07.2018 - 21:38
скан "неправильной" печатной формы выложи... а то может ты ошибаешься что она "неправильная"
2 - 28.07.2018 - 22:08
Детально не могу, но так видно о чем речь?





3 - 29.07.2018 - 12:03
Печать, скорее всего, заложена в фоновом задании.
При отладке включи их (фоновые задания) тоже.
4 - 29.07.2018 - 18:27
включал все галки в отладке не ловит :(
5 - 30.07.2018 - 08:55
(4) А серверные процедуры/функции ловишь в отладке?
6 - 30.07.2018 - 14:17
сложно сказать что там серверное :) это же не УФ, а какая то переходная конфа, потому как к примеру форма ПечатьдокументовУправляемая и вот тут ПриСоздании не ловит как раз никак, а она уже УФ.
7 - 30.07.2018 - 15:13
(6) Скорее всего, ты отлавливаешь только клиентские модули. Колонка "Сервер" в отладчике присутствует?
8 - 30.07.2018 - 19:58
9 - 30.07.2018 - 20:51
(8) Я не про настройки, а когда замер производительности делаешь, в отловленном коде замера присутствует колонка "Сервер" и есть ли строки кода ей соответствующие?
10 - 02.08.2018 - 04:39
11 - 02.08.2018 - 15:38
(10) Смотри общий модуль "УчетНДС.ВывестиСчетФактуруВТабличныйДокумент( )". Там идет процесс заполнения и вывода макета УПД.
12 - 03.08.2018 - 20:39
11-US1C > Не понятно отладчик почему туда не заходит тогда :(
Я предполагал, что там что то должно быть, но пока не видно каких то делений на страницы.
13 - 03.08.2018 - 20:42
#Если Сервер ИЛИ ВнешнееСоединение Тогда
РезультатПроверкиВывода = ФормированиеПечатныхФормСервер.ПроверитьВыводТабли чногоДокумента(ТабДокумент, СтрокаСПодвалом);
#ИначеЕсли ТолстыйКлиентОбычноеПриложение Тогда
РезультатПроверкиВывода = ФормированиеПечатныхФорм.ПроверитьВыводТабличногоД окумента(ТабДокумент, СтрокаСПодвалом);
#КонецЕсли

Если НЕ РезультатПроверкиВывода Тогда

Если КоличествоСтрок > 0 Тогда
// Вывод разделителя и заголовка таблицы на новой странице
ТабДокумент.ВывестиГоризонтальныйРазделительСтрани ц();
ТабДокумент.Вывести(ОбластьМакетаЗаголовокТаблицы) ;
КоличествоСтраниц = КоличествоСтраниц + 1;
КонецЕсли;

КонецЕсли;

ТабДокумент.Вывести(ОбластьМакета);


Тут есть вот такое, но по идее она должна тогда ПроверитьВывод корректно определять, а она странно решает что вместилось, а что нет.
14 - 04.08.2018 - 14:40
(12) А у тебя сервер 1С с режимом отладки запущен? А то по ходу, ты только клиентские процедуры перехватываешь.
15 - 04.08.2018 - 22:22
На других системах где чисто 8.3 с УФ и без отладки сервера ловит, разве режим отладки сервера не для другого?
16 - 04.08.2018 - 22:40
14-US1C > Спасибо, не знал что для толстого клиента такое нужно, теперь ловит хотя бы серверные.
17 - 09.08.2018 - 19:11
у вас скорее всего что-то с полями (с верху/с низу) напортачено (3-я страница) это лечится в параметрах печати самого принтера, а в остальном так и должно быть.
18 - 09.08.2018 - 19:20
Косяк небольшой есть, что 1-я страница не до конца печатается... Если в конфе не включен режим разрешения изменений - пиши в 1С или свою внешнюю форму. Зная любовь 1С переделывать вызовы разных функций - начал бы с письма в 1С и почитал их ответ. Потом принимал решение ждать или самому писать внешнюю форму.
19 - 11.08.2018 - 16:36
Не знаю как на картинке, но там видно что вставляется программно разделитель, у настроек принтера вовсе стоит без полей со всех сторон и по ширине страницы.
20 - 13.08.2018 - 16:37
19-pavlo1c > Разумеется там стоит программный разделитель страниц и его положение рассчитывается... уберите масштаб "по ширине" и поставьте поля хотя бы по 10мм
21 - 13.08.2018 - 16:45
19-pavlo1c > только что проверил у себя.
масштаб - по ширине страницы
Поля свеху 12
22 - 13.08.2018 - 16:46
снизу 0
колонтитулы по 10.
--
печатает нормально.
23 - 13.08.2018 - 16:47
19-pavlo1c > поставил масштаб - 100% тоже все нормально
24 - 13.08.2018 - 18:29
ну вот получается что суть не в принтере


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены